Bug 33754 - Searching email by date
Summary: Searching email by date
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: commands and actions (show other bugs)
Version: 1.99.0
Platform: Debian testing Linux
: NOR wishlist with 487 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 76068 87073 122209 185497 208348 210677 251144 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-10-16 03:48 UTC by esigra
Modified: 2014-04-05 11:02 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Pratte 2001-10-16 03:45:04 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           1.3.1 (using KDE 2.2.1 )
Severity:          wishlist
Installed from:    Debian Package 4:2.2.1-7 (testing/unstable)
Compiler:          gcc version 2.95.4 20010902 (Debian prerelease)
OS:                Linux (i686) release 2.4.9
OS/Compiler notes: 

It would be nice if in the edit / search through messages (S)  there would be an option to search for messages at a given range of dates...

(sorry if it is not the exact menu item; I have KDE in French) 

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Ingo Kl 2001-10-16 23:38:42 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Tuesday 16 October 2001 05:45 pratg00@dmi.usherb.ca wrote:
> It would be nice if in the edit / search through messages (S)  there
> would be an option to search for messages at a given range of
> dates...

If you sort the search results by date you achieve almost the same.=20
Searching only messages in a given range of dates won't be faster than=20
searching all messages.

Regards
Ingo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE7zMUCGnR+RTDgudgRAv7RAKDhu1CDUtAhAazHG9YqiHn6hpcQ6QCfbVQb
o/vs3oEP/H0AGqcP1EfkHEU=3D
=3DEv+r
-----END PGP SIGNATURE-----
Comment 2 Guillaume Pratte 2001-10-17 02:12:05 UTC
Le 16 Octobre 2001 19:38 vous avez écrit :
> On Tuesday 16 October 2001 05:45 pratg00@dmi.usherb.ca wrote:
> > It would be nice if in the edit / search through messages (S)  there
> > would be an option to search for messages at a given range of
> > dates...
>
> If you sort the search results by date you achieve almost the same.
> Searching only messages in a given range of dates won't be faster than
> searching all messages.


This is not about having a faster find...

This is about having a filter. I want to see all the messages from two day 
ago; I don't want to have to search for "*" then sort them by date then 
manually find in my 2000 messages where that date is...
Comment 3 Ingo Kl 2001-10-17 20:33:12 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wednesday 17 October 2001 04:12 Guillaume Pratte wrote:
> Le 16 Octobre 2001 19:38 vous avez =E9crit :
> > On Tuesday 16 October 2001 05:45 pratg00@dmi.usherb.ca wrote:
> > > It would be nice if in the edit / search through messages (S)=20
> > > there would be an option to search for messages at a given range
> > > of dates...
> >
> > If you sort the search results by date you achieve almost the same.
> > Searching only messages in a given range of dates won't be faster
> > than searching all messages.
>
> This is not about having a faster find...
>
> This is about having a filter. I want to see all the messages from
> two day ago; I don't want to have to search for "*" then sort them by
> date then manually find in my 2000 messages where that date is...

It was just a suggestion for a temporary workaround.

Thanks for your bug report! The search dialog really needs some=20
improvements.

Regards
Ingo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE7zesIGnR+RTDgudgRAquCAJwLiQLN61VCp9hU2XHve1IwuP+bqQCdGrPK
PvgZEHUR67jxOvX3Ys+gLMg=3D
=3DYAlD
-----END PGP SIGNATURE-----
Comment 4 Tim Middleton 2003-12-12 13:01:53 UTC
This is THE main remaining feature I miss from "The Bat" (or even Mozilla Mail). 

In The Bat specifying a date range also had the excellent benefit of making full text searches of the entire email database feasible, because all messages were indexed by date: so if you limited a search to messages written during a certain week it was extremely fast in going through each folder and executing the search only on the messages falling within that range.

Currently in Kmail if i'm desperate to find some info in one of my vast number of folders and have to do a full text search, then sort by date, it takes nearly forever.

But I agree with a former note, speed is not even the main reason we need date range searches: the main reason is just to be able to make matches within a certain date range (avoiding a massive number of hits if one's mail archive is very old), regardless of speed.
Comment 5 Stephan Kulow 2004-05-20 21:17:34 UTC
Replaced pratg00@dmi.usherb.ca with sigra@home.se due to bounces by reporter
Comment 6 Tom Albers 2004-08-12 22:22:36 UTC
*** Bug 87073 has been marked as a duplicate of this bug. ***
Comment 7 Aurelien Bompard 2004-10-15 18:07:54 UTC
I second that.

Here is an example : I sort all my incoming mails in subfolders, and I'd like to get a list of the 50 last mails I recieved, or the mails I recieved in the last 5 days, regardless of where I sorted them.

Having this feature would be just great !
Comment 8 Bram Schoenmakers 2007-03-09 23:56:59 UTC
*** Bug 122209 has been marked as a duplicate of this bug. ***
Comment 9 W Randolph Franklin 2007-06-29 19:38:17 UTC
This bug was first reported almost 6 years ago.   If there is no intention to fix this, could that be announced?   My bias is that this one problem is almost enough to make me leave kmail.  Every other mail program does this.  Thanks.
Comment 10 Tim 2007-11-28 08:00:27 UTC
Hello all!  

I too would like to know if there is no intention of fixing this.  I have revisited this bug-page for many-a-year... should I just move on? 

Thanks in advance, 
  Tim.
Comment 11 Louis-Dominique Dubeau 2008-04-30 04:30:30 UTC
I've just switched from Gnome to KDE but I'm still using evolution because the feature requested here is missing from kmail.  What a shame!
Comment 12 p92 2009-04-07 16:36:04 UTC
not present in kde 4.2.2
Comment 13 Ian Turner 2009-04-22 02:49:37 UTC
This feature will not be added until someone who has the time to write a patch actually does so. The primary kmail maintainers don't seem to feel that this is an important issue, and since kmail is a community project, they are perfectly entitled not to work on it. Complaining will not result in a speedier resolution of this or any other bug.

If some of the people clamoring for this feature are willing to pay to have it done, I'd certainly be willing to chip in. I don't know how much time it would take to add this feature, but I'd guess that a bounty of around US$5000 would attract some interest.
Comment 14 Björn Ruberg 2009-12-19 23:24:15 UTC
*** Bug 76068 has been marked as a duplicate of this bug. ***
Comment 15 Björn Ruberg 2010-03-06 15:12:37 UTC
*** Bug 208348 has been marked as a duplicate of this bug. ***
Comment 16 Björn Ruberg 2010-03-06 21:47:42 UTC
*** Bug 210677 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Giboudeaux 2010-03-29 10:47:28 UTC
*** Bug 185497 has been marked as a duplicate of this bug. ***
Comment 18 Randall Wood 2010-07-01 18:40:11 UTC
I'll chime in on this issue.  It's a real show stopper for me.  Thunderbird can do it - wouldn't that code be a good start, in the spirit of source code reuse?  Hell, Mutt does it too.  I'm sorry to see this bug was first reported almost 10 years ago — wish I knew how to code.
Comment 19 Christophe Giboudeaux 2011-05-03 23:09:36 UTC
*** Bug 251144 has been marked as a duplicate of this bug. ***
Comment 20 Olek Gut 2011-11-23 01:20:55 UTC
This feature request is still valid for KMail 2
Comment 21 Anne-Marie Mahfouf 2011-11-23 07:40:56 UTC
Reassigning to KMAIL2
Comment 22 Dr. Christoph Pospiech 2011-12-29 18:51:02 UTC
I just noted that on kmail2 the search option "Age in days is less or equal to 90 days" didn't have any effect on the search result. Even if given as the only search parameter, Mails were found dating from 2009 (hence > 90 days).

Now that everything is held in a data base, which should ease and speed up queries, I strongly vote for a working query for a date range.
Comment 23 Laurent Montel 2014-04-03 14:27:10 UTC
Work fine in 4.13
Comment 24 Jekyll Wu 2014-04-05 10:14:17 UTC
(In reply to comment #23)
> Work fine in 4.13

So should this ticket be closed now ?
Comment 25 Laurent Montel 2014-04-05 11:02:13 UTC
indeed I close it