Bug 336687 - KMail Crashes with "nepomukserver" and Trying to Search
Summary: KMail Crashes with "nepomukserver" and Trying to Search
Status: RESOLVED INTENTIONAL
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-06-25 06:16 UTC by William Paul Liggett
Modified: 2014-07-03 20:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Paul Liggett 2014-06-25 06:16:30 UTC
Application: kmail (4.12.5)
KDE Platform Version: 4.12.5
Qt Version: 4.8.6
Operating System: Linux 3.14.8-200.fc20.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

See the bug report for #311184 as I did a write-up of my background of how I arrived at this situation.  Essentially, I am on GNOME Shell v3.10.2 (Fedora 20, 64-bit) and I am using KMail v4.12.5, and I was unable to use the full e-mail search capability (the binoculars icon).  So, I ran the "nepomukserver" command in terminal to make the full search dialog actually work.  However, this is where this bug comes in, after I type something for the search dialog to look for and right when I click on "Search", KMail crashes from a segmentation fault.

--William (junktext)

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7feb1d1a4900 (LWP 1949))]

Thread 4 (Thread 0x7fea9993b700 (LWP 2043)):
#0  0x00007feb165c179d in read () from /lib64/libc.so.6
#1  0x00007feafe242eb1 in ?? () from /usr/lib64/nvidia/tls/libnvidia-tls.so.331.79
#2  0x00007feb09c597b0 in g_wakeup_acknowledge () from /lib64/libglib-2.0.so.0
#3  0x00007feb09c1909c in g_main_context_check () from /lib64/libglib-2.0.so.0
#4  0x00007feb09c19533 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#5  0x00007feb09c19a3a in g_main_loop_run () from /lib64/libglib-2.0.so.0
#6  0x00007feb0551f376 in gdbus_shared_thread_func () from /lib64/libgio-2.0.so.0
#7  0x00007feb09c3ea45 in g_thread_proxy () from /lib64/libglib-2.0.so.0
#8  0x00007feb1876df33 in start_thread () from /lib64/libpthread.so.0
#9  0x00007feb165cfded in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fea93dda700 (LWP 2045)):
#0  0x00007feb18771d20 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007feb0eb411bd in JSC::BlockAllocator::blockFreeingThreadMain() () from /lib64/libQtWebKit.so.4
#2  0x00007feb0ee33a86 in WTF::wtfThreadEntryPoint(void*) () from /lib64/libQtWebKit.so.4
#3  0x00007feb1876df33 in start_thread () from /lib64/libpthread.so.0
#4  0x00007feb165cfded in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fea91e95700 (LWP 2047)):
#0  0x00007fff52d2875d in clock_gettime ()
#1  0x00007feb165ddf3d in clock_gettime () from /lib64/libc.so.6
#2  0x00007feb17192afb in qt_gettime() () from /lib64/libQtCore.so.4
#3  0x00007feb17275f49 in QTimerInfoList::updateCurrentTime() () from /lib64/libQtCore.so.4
#4  0x00007feb17274d27 in timerSourceCheckHelper(GTimerSource*) () from /lib64/libQtCore.so.4
#5  0x00007feb09c18ff9 in g_main_context_check () from /lib64/libglib-2.0.so.0
#6  0x00007feb09c19533 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#7  0x00007feb09c196dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#8  0x00007feb17274a7e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#9  0x00007feb1724495f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#10 0x00007feb17244cad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#11 0x00007feb17138e8f in QThread::exec() () from /lib64/libQtCore.so.4
#12 0x00007feb1713b6bf in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#13 0x00007feb1876df33 in start_thread () from /lib64/libpthread.so.0
#14 0x00007feb165cfded in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7feb1d1a4900 (LWP 1949)):
[KCrash Handler]
#5  0x00007feb19aa1be0 in Akonadi::PersistentSearchAttribute::setQueryLanguage(QString const&) () from /lib64/libakonadi-kde.so.4
#6  0x00007feb1bf23b66 in KMail::SearchWindow::slotSearch() () from /lib64/libkmailprivate.so.4
#7  0x00007feb1bf283c5 in KMail::SearchWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib64/libkmailprivate.so.4
#8  0x00007feb1725a938 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#9  0x00007feb182d2ce2 in QAbstractButton::clicked(bool) () from /lib64/libQtGui.so.4
#10 0x00007feb18015c23 in QAbstractButtonPrivate::emitClicked() () from /lib64/libQtGui.so.4
#11 0x00007feb18016fd7 in QAbstractButtonPrivate::click() () from /lib64/libQtGui.so.4
#12 0x00007feb180170dc in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQtGui.so.4
#13 0x00007feb17ca1d78 in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
#14 0x00007feb17c4ee7c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#15 0x00007feb17c55921 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#16 0x00007feb1cbc3b0a in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#17 0x00007feb17245ebd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#18 0x00007feb17c55097 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /lib64/libQtGui.so.4
#19 0x00007feb17cca76b in QETWidget::translateMouseEvent(_XEvent const*) () from /lib64/libQtGui.so.4
#20 0x00007feb17cc91dc in QApplication::x11ProcessEvent(_XEvent*) () from /lib64/libQtGui.so.4
#21 0x00007feb17cf0c04 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQtGui.so.4
#22 0x00007feb09c192a6 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#23 0x00007feb09c19628 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#24 0x00007feb09c196dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#25 0x00007feb17274a7e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#26 0x00007feb17cf0d86 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#27 0x00007feb1724495f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#28 0x00007feb17244cad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#29 0x00007feb1724a399 in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#30 0x0000000000402f2d in main ()

The reporter indicates this bug may be a duplicate of or related to bug 311184.

Reported using DrKonqi
Comment 1 Laurent Montel 2014-06-25 07:25:48 UTC
kdepim 4.13 doesn't use nepomuk.
So we can't fix it.
I close this report
Comment 2 William Paul Liggett 2014-07-03 20:01:25 UTC
Okay, thanks for letting me know, Laurent.  I'll look forward to trying out the newer version of KMail once it is part of my distro's repository.  Take care!