Bug 311184 - Everlasting "Please wait while the message is transferred"
Summary: Everlasting "Please wait while the message is transferred"
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.9.3
Platform: Chakra Linux
: NOR major with 22 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-05 09:56 UTC by Bernd Oliver Sünderhauf
Modified: 2016-05-26 08:11 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Oliver Sünderhauf 2012-12-05 09:56:38 UTC
For some reasons, my preview pane now always keeps showing "Retrieving Folder Contents" even though Akonadi has finished syncing. Doubleclicking a mail, the message viewer doesn't open, and editing a message leads to a dialog "Please wait while the message is transferred".
A restart of kmail doesn't help.

Don't know exactly how I borked this, but did probably a bit too much testing.
Last thing I can remember is that saving a message as draft failed, because the draft folder wasn't set up for the identity. After setting it up, saving the message as draft still failed with the message window being greyed out. So I closed the individual windows.
Also, the sent-mail and drafts folders I set up for my identity don't get stored always disappearing.

ATM, my kmail isn't usable anymore, so I should probably configure my kmail from the scratch on this machine. However, in order to get the bug fixed, I will refrain from it for now... :)

Reproducible: Always
Comment 1 Peter Davis 2013-04-13 13:39:52 UTC
I have a very similar problem.  There have long been occasions when KMail has taken a long time for "Retrieving Folder Contents
Please Wait . . .", but since upgrading to OpenSUSE 12.3 it has become a serious problem.  In my case, I can usually read a small number of messages, but then become stuck with this message on a background in the preview pane of the Plymouth Boot Screen.  On occasions restarting KMail has briefly helped.
Before becoming stuck, if I try to edit a message, I'm asked interminably to "Please wait while the message is transferred".
Comment 2 Peter Davis 2013-04-14 15:40:08 UTC
Perhaps I should add that I can try to edit a message for which I'm Retrieving Folder Contents, and with the same result.
I also now get the Plymouth Boot Screen as a background in the viewing pane when I open Konqueror, and have on occasion been unable to see what I wanted.
Comment 3 bjoernv 2013-10-11 12:37:06 UTC
I have the same with KMail 4.11.2 and openSUSE 12.3.  It can't be a network problem, because I see the bug also on local KMail folders.
Comment 4 William Paul Liggett 2014-06-25 05:19:44 UTC
Yeah, I am having the same issues that the original poster, Bernd Oliver Sünderhauf, mentioned two years ago, but I may have arrived at the same conditions via a different path.  I am using KMail v4.12.5 on GNOME Shell v3.10.2 (Fedora 20, 64-bit) and this is a summary of my issue to be clear:

1. I cannot open any e-mails any longer.  Double-clicking on a message does nothing.  It doesn't even attempt to open the e-mail.  When I right-clicking on a message and select "Reply" (or if I press the "R" key), all that happens is an endless loading dialog that says, "Please wait while the message is transferred".  Nothing ever happens.

2. I was using KMail successfully, with two different e-mail accounts.  One was an IMAP (via SSL) connection to a regular e-mail server, and my other e-mail was a connection to a GMail account.  Both were working fine until...

3a.  Since I am on Fedora (on GNOME Shell, not KDE), I was trying to figure out how to get the full search feature (Nepomuk) working.  As when I would click on the icon with the binoculars (that has the pop-up label "Open Full Search"), I would simply get a message saying:

Search Not Available - KMail

The Nepomuk semantic search service is not available. Searching is not possible without it. You can enable it in "System Settings".

3b. Keep in mind that I am on GNOME Shell, not KDE, thus I don't think the reference to me opening up and enabling Nepomuk in "System Settings" means much to me (I cannot find such a menu on GNOME Shell).  After searching around on the forums/bug reports, I ran across hints about needing to start the Nepomuk program and to monitor what it is doing via the Akonadi Console.  In short on this regard, I ran the command "nepomukserver" in terminal then I was able to get Akonadi Console to make the "Akonadi Nepomuk Feeder" agent to fully index my e-mail.  I was happy about this, since I wanted to search my e-mail more thoroughly and I was finally able to get the binocular icon to show me a search dialog (instead of the error message).  Yet, this new search dialog ended up being worthless, since it couldn't pull up any e-mails I searched for.

4.  This is when I noticed the problem of not being able to open up any of my e-mail messages as I stated at paragraph label "1."  Thus, I think Nepomuk destroyed my KMail.  In the meantime, I'll head back to using GNOME's Evolution.  But, I'll leave my KMail in this state of disrepair in case somebody has a suggestion.

--William
Comment 5 William Paul Liggett 2014-06-25 06:20:01 UTC
My apologies, I've just restarted my computer and KMail can now open up e-mails once again.  However, before I restarted I did fully restart KMail a number of times (I had to use the "kill -9" method as it wouldn't die.  Well, visually the app would quit but I could still see it in "ps aux").

However, out of curiosity (after rebooting and getting KMail to work again), I re-ran "nepomukserver" in terminal and after I clicked on the binocular icon, KMail crashed via a segmentation fault.  I opened a new bug report on this matter over at: https://bugs.kde.org/show_bug.cgi?id=336687

--William
Comment 6 Martin Steigerwald 2015-09-10 10:39:22 UTC
Thank you Bernd for your report and to everyone who commented. It is about a version of KMail which uses Nepomuk and is unmaintained. Thus closing. If you still see performance issues please open new reports. But please follow the following guide lines to avoid unnecessary work for the developers:

- Ideally test with KDEPIM and Akonadi 15.08. It contains some performance improvements like the binary protocol.

- Otherwise at least use KDEPIM 4.14.10 and newest Akonadi 1.13 you can get as
it already contains some performance improvements.

- If you can wait, please retest with KDEPIM and Akonadi 15.12 once they become available for you. Akonadi 15.12 will contain *massive* performance improvements implemented by Dan due to new database indexes, optimized queries and leveled file_db directory. All of these are in master already, so if you dare use kdesrc-build to compile KF5, kdepim and kdepim-runtime. I am using this currently and it basically moves the bottleneck to KMail (slow threading for example). It is a *huge* improvement. Also Volker and others work on performance improvements in KMail as well.

Thank you and greetings from KDE Randa Meetings,
Martin
Comment 7 Johannes Falke 2016-05-25 15:17:40 UTC
I'm still intermittently having this issue on kmail/akonadi/kdepim up to version 16.04.1-1
Comment 8 Martin Steigerwald 2016-05-26 08:11:52 UTC
Johannes, thank you for the imformation. Please report a new bug tough in order to have it being free of old and outdated information about an unmaintained release of KDEPIM.

Also explain exactly what you are seeing there. What does "intermittently" mean? I am not seeing this message much anymore and if so just for a few seconds, but I also tuned my MySQL config. Can you make out in which situations it happens?

So if you care, please report a new bug. Feel free to set me on Cc. Thanks, Martin