Bug 335013 - The face recognition and detection tool does not respect the albums selection to process
Summary: The face recognition and detection tool does not respect the albums selection...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Recognition (show other bugs)
Version: 4.2.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-18 22:56 UTC by Roland Wolters
Modified: 2017-08-02 06:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.2.0


Attachments
Face detection dialog showing the main options. (87.68 KB, image/png)
2014-05-19 22:56 UTC, Roland Wolters
Details
Main album interface during face recognization (90.67 KB, image/png)
2014-05-19 22:56 UTC, Roland Wolters
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Wolters 2014-05-18 22:56:25 UTC
When I go to the tab for face recognition and detection and pick certain albums to search, this is not respected. Instead, all available albums are searched, continuing a search I launched much, much earlier and ended by closing digikam.

Reproducible: Always

Steps to Reproduce:
1. Got to the face detection
2. pick an album
3. launch the search
Actual Results:  
The picked albums are not searched, no new faces come up.

Expected Results:  
The picked albums - and only them - should be searched. With only few images, that should be rather quick.

Not sure if a previous search which was cancelled by closing Digikam (because there is no button to cancel searches) is mixing up the situation here.
Comment 1 caulier.gilles 2014-05-19 05:38:26 UTC
>Not sure if a previous search which was cancelled by closing Digikam

yes it must be.

> (because there is no button to cancel searches) is mixing up the situation here

Look on bottom right corner of albugui. There is a progress indicator on statusbar, where you can see details of scan cancel operation.

Gilles Caulier
Comment 2 caulier.gilles 2014-05-19 05:38:56 UTC
Which options do you use to process Faces scan exactly ?

Gilles Caulier
Comment 3 Roland Wolters 2014-05-19 22:56:11 UTC
Created attachment 86717 [details]
Face detection dialog showing the main options.
Comment 4 Roland Wolters 2014-05-19 22:56:46 UTC
Created attachment 86718 [details]
Main album interface during face recognization
Comment 5 Roland Wolters 2014-05-19 22:59:08 UTC
In the above uploaded pictures you can see the options I picked this time, though here no ablums are selected.
Besides, the second screen shot was done directly after I started a recognization of the entire collection - and no status bar is shown. In the background several digikam processes are running, though...
Comment 6 caulier.gilles 2014-05-20 05:40:33 UTC
Why do you turn on "Whole Albums Selection" and "Whole Tags selection" options ?

These options will ignore custom album/tag selections done through tre-view combobox and process whole collection instead...

Gilles Caulier
Comment 7 Roland Wolters 2014-05-20 21:52:49 UTC
I'm sorry, the screenshot was the wrong one. With the usual search I do not turn on "Whole Album selection", but only pick two albums. I do however turn on "Whole Tags Selection". Does this still trigger an entire collection scan?

I changed the search options to only search two albums together with two tags. Upon start, the option window vanishes, and CPU and RAM for two digikam processes spikes. Btw., again there is no status bar or anything but my process viewer (and my laptop fan) indicating that there is any background process... or am I just not seeing it?

Anyway, I tested two times, an each time - again, two albums and two tags chosen, together roughly 150 photos, 600 MB of space - OOM-Killer ( ! ) killed both processes... we speak about a system with 8G Ram and as much swap space. But that might be another bug?
Comment 8 caulier.gilles 2014-05-22 11:41:47 UTC
yes it's another problem. Look here : 

https://bugs.kde.org/show_bug.cgi?id=323888
Comment 9 caulier.gilles 2014-08-24 09:26:50 UTC
Problem still reproducible using last digiKam 4.2.0 ?

Gilles Caulier
Comment 10 caulier.gilles 2014-08-24 11:39:48 UTC
*** Bug 334183 has been marked as a duplicate of this bug. ***
Comment 11 caulier.gilles 2014-08-27 13:51:23 UTC
To respond on comment #7

I do however turn on "Whole Tags Selection". Does this still trigger an entire collection scan?

==> I start a scan of all image tags with virtual albums selection. If tags is used on many place, this will take a time to process...

I just checked album selector widget with some debug statement, and selection of albums to process in background is repected.

The main problem is not album selector here, but memory consumption in background...

Gilles Caulier

*** This bug has been marked as a duplicate of bug 323888 ***
Comment 12 caulier.gilles 2016-09-14 20:26:01 UTC
Git commit 42ccb101aeb7c3ed79dd41d0d10a8f67a53883e2 by Gilles Caulier.
Committed on 14/09/2016 at 20:23.
Pushed by cgilles into branch 'master'.

make the album selection widget exclusive with album type : PAlbum or TAlbum (not and operator).
This will prevent to scan a selection of PAlbum when TAlbum are selected.
Related: bug 334183, bug 366558
FIXED-IN: 5.2.0

M  +3    -0    NEWS
M  +103  -29   libs/album/albumselectors.cpp
M  +9    -0    libs/album/albumselectors.h

http://commits.kde.org/digikam/42ccb101aeb7c3ed79dd41d0d10a8f67a53883e2