Bug 334183 - Face recognition folder selection scans all available folders
Summary: Face recognition folder selection scans all available folders
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Recognition (show other bugs)
Version: 4.2.0
Platform: Archlinux Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-01 14:29 UTC by robspamm
Modified: 2017-08-02 06:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.2.0


Attachments
Settings Screenshot Maintenance Tool (79.15 KB, image/png)
2014-05-08 19:59 UTC, robspamm
Details
Digikam 4.2 clear unknown faces (108.71 KB, image/png)
2014-08-11 14:08 UTC, robspamm
Details
Digikam 4.2 settings for face detection (121.82 KB, image/png)
2014-08-11 14:09 UTC, robspamm
Details
Digikam 4.2 result after manually stopping face recognition. (269.22 KB, image/png)
2014-08-11 14:10 UTC, robspamm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robspamm 2014-05-01 14:29:29 UTC
When trying to search a specified folder for faces in face detection, all other folders in that collection are scanned afterwards.

Reproducible: Always

Steps to Reproduce:
1. Select face recognition
2. Uncheck "Whol albums collection"
3. Select a folder and start
Actual Results:  
Face search scans specified folder and continues with all other available folders.

Expected Results:  
Search should stop after scanning the specified folder.
Comment 1 caulier.gilles 2014-05-01 20:40:29 UTC
Do you use Maintenance  tool for that ?

Gilles Caulier
Comment 2 robspamm 2014-05-05 15:07:01 UTC
The same happens with the maintenance tool.
Comment 3 caulier.gilles 2014-05-07 07:40:27 UTC
Here i use next 4.0.0 (devel), not yet released

I cannot reproduce the problem in maintenance tool, using tool as thumbs, fingerprints, etc... and Face detection.

Q : what are you using as settings from Face detection ? (Skip, Scan Again, or Clear) ?

Gilles Caulier
Comment 4 robspamm 2014-05-08 19:59:37 UTC
Created attachment 86533 [details]
Settings Screenshot Maintenance Tool
Comment 5 robspamm 2014-05-08 20:02:04 UTC
I attached a screenshot with the settings ( in german ). As you are unable to reproduce the issue, I will create an empty digikam installation and add some images and see, whether I am able to reproduce the behaviour. As my library is quite big, I don't want to scan all my pictures at once but work through the single folders instead.
Comment 6 robspamm 2014-05-08 20:05:51 UTC
(In reply to comment #3)
> Here i use next 4.0.0 (devel), not yet released

Ah, I just read that. So I will probably wait for the release ( and hope, that my database will survive the transition ).
Thanks for the quick replys.
Comment 7 caulier.gilles 2014-05-11 20:51:13 UTC
ok, i close this file as solved for 4.0.0.

Reopen if necessary if problem is back with next 4.0.0

Gilles Caulier
Comment 8 robspamm 2014-08-10 18:13:50 UTC
I upgraded to Digikam 4.1, tried with a new user account, created a test repository with two albums and some images and it worked as expected.

Afterwards removed all configuration files I can find in my usual account (in .kde/share/apps and .kde/share/config), the sqlite databases and reimported all my image files (50 Gb). With this configuration the bug still persists. I select just one album and Digikam scans all albums (until I stop it).

As this bug seems to depend on my file configuration or some meta information in some image I guess I will not be able to debug this.
Comment 9 robspamm 2014-08-11 13:53:34 UTC
Just saw that Digikam 4.2 is in the Archlinux reps, so I installed that one. He still scans ALL folders when trying to recognize faces, regardless of any other options.

I am currently building a debug version of the package.
Comment 10 robspamm 2014-08-11 14:08:50 UTC
Created attachment 88220 [details]
Digikam 4.2 clear unknown faces
Comment 11 robspamm 2014-08-11 14:09:23 UTC
Created attachment 88221 [details]
Digikam 4.2 settings for face detection
Comment 12 robspamm 2014-08-11 14:10:01 UTC
Created attachment 88222 [details]
Digikam 4.2 result after manually stopping face recognition.
Comment 13 caulier.gilles 2014-08-24 11:39:48 UTC

*** This bug has been marked as a duplicate of bug 335013 ***
Comment 14 caulier.gilles 2016-09-14 20:26:01 UTC
Git commit 42ccb101aeb7c3ed79dd41d0d10a8f67a53883e2 by Gilles Caulier.
Committed on 14/09/2016 at 20:23.
Pushed by cgilles into branch 'master'.

make the album selection widget exclusive with album type : PAlbum or TAlbum (not and operator).
This will prevent to scan a selection of PAlbum when TAlbum are selected.
Related: bug 335013, bug 366558
FIXED-IN: 5.2.0

M  +3    -0    NEWS
M  +103  -29   libs/album/albumselectors.cpp
M  +9    -0    libs/album/albumselectors.h

http://commits.kde.org/digikam/42ccb101aeb7c3ed79dd41d0d10a8f67a53883e2