Bug 334999 - Closing a second window loses the translation of the places that has to do with desktop search
Summary: Closing a second window loses the translation of the places that has to do wi...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: panels: places (show other bugs)
Version: 4.13.1
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: reproducible
: 335439 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-18 20:25 UTC by Cor Blom
Modified: 2014-05-28 07:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Blom 2014-05-18 20:25:53 UTC
If I close a dolphin window while leaving another dolphin window open, in that open window everything below "Recently Accessed" and "Search For" is set back to English (I use Dutch), though not the titles. I get Today, Yesterday, etc, instead of "Vandaag" "Gisteren" etc.

Reproducible: Always

Steps to Reproduce:
1. Open a dolphin window
2. Open a second window
3. Close the second window again
Actual Results:  
The translations under "Recently Accessed" and "Search For" in the still open window that is left, are gone. They are in English now

Expected Results:  
The names would stay Dutch
Comment 1 Frank Reininghaus 2014-05-19 11:25:46 UTC
Thanks for the bug report! I can confirm the problem. There have been some discussions about this problem already: http://lists.kde.org/?t=139660468400004&r=1&w=2
Comment 2 Frank Reininghaus 2014-05-20 06:35:28 UTC
Git commit 8f0202514bf692d6b9b046063392151ee10e364c by Frank Reininghaus.
Committed on 20/05/2014 at 06:31.
Pushed by freininghaus into branch 'KDE/4.13'.

Do not lose translation of Places items if a Dolphin window is closed

If the "Places" are updated outside the current Dolphin process,
PlacesItemModel::updateBookmarks() is called, which invokes
PlacesItem::setBookmark(const KBookmark& bookmark) for each item. This
commit ensures that the correct translation is used for system
bookmarks like "Root", "Network", etc.

Without this patch, all Places entries in the remaining Dolphin windows
would switch to US English if one of multiple windows is closed.

See http://lists.kde.org/?t=139660468400004&r=1&w=2 for details.
REVIEW: 118207
FIXED-IN: 4.13.2

M  +1    -1    dolphin/src/panels/places/placesitem.cpp

http://commits.kde.org/kde-baseapps/8f0202514bf692d6b9b046063392151ee10e364c
Comment 3 Cédric Bellegarde 2014-05-28 07:18:14 UTC
*** Bug 335439 has been marked as a duplicate of this bug. ***