Bug 334969 - In KPatience the Yukon game crashes on resize
Summary: In KPatience the Yukon game crashes on resize
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-18 00:00 UTC by Ored
Modified: 2014-06-25 09:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ored 2014-05-18 00:00:27 UTC
Application: kpat (3.6)
KDE Platform Version: 4.13.0
Qt Version: 4.8.6
Operating System: Linux 3.11.0-15-generic i686
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
After playing a few games of "Mod3" then Opening the "Yukon" game, it crashes after trying to resize the cards by holding down the "Ctrl" key and moving the mouse wheel. This has happened more then a few times. (Not sure how many)

Randy

The crash can be reproduced sometimes.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb413a740 (LWP 2574))]

Thread 3 (Thread 0xb142eb40 (LWP 2575)):
#0  0xb500ad2e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb500b138 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4fc5372 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4fc6288 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4fc6528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6b4595f in QEventDispatcherGlib::processEvents (this=0xb0b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0xb6b14823 in QEventLoop::processEvents (this=this@entry=0xb142e258, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6b14b49 in QEventLoop::exec (this=this@entry=0xb142e258, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6a0123d in QThread::exec (this=this@entry=0x87c7040) at thread/qthread.cpp:537
#9  0xb6af4c44 in QInotifyFileSystemWatcherEngine::run (this=0x87c7040) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb6a03b6f in QThreadPrivate::start (arg=0x87c7040) at thread/qthread_unix.cpp:349
#11 0xb509cf70 in start_thread (arg=0xb142eb40) at pthread_create.c:312
#12 0xb5cf770e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 2 (Thread 0xaead3b40 (LWP 2762)):
#0  0x08099bbb in _start ()

Thread 1 (Thread 0xb413a740 (LWP 2574)):
[KCrash Handler]
#7  __lll_timedlock_wait () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/lowlevellock.S:210
#8  0xb50a00b2 in _L_timedlock_285 () from /lib/i386-linux-gnu/libpthread.so.0
#9  0xb509fa81 in pthread_mutex_timedlock (mutex=0xaee51008, abstime=0xbfa70538) at ../nptl/pthread_mutex_timedlock.c:96
#10 0xb6e9ef21 in pthreadTimedLock::lock (this=0x87d3408) at ../../kdecore/util/kshareddatacache_p.h:252
#11 0xb6e9db43 in lock (this=0x88f4258) at ../../kdecore/util/kshareddatacache.cpp:1236
#12 cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#13 CacheLocker (_d=0x88f4258, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#14 KSharedDataCache::find (this=this@entry=0x87ea058, key=..., destination=destination@entry=0xbfa70618) at ../../kdecore/util/kshareddatacache.cpp:1606
#15 0xb71cd4d4 in KImageCache::findPixmap (this=0x87ea058, key=..., destination=0xbfa70664) at ../../kdeui/util/kimagecache.cpp:150
#16 0x0809ccc0 in ?? ()
#17 0x0809d04a in ?? ()
#18 0xb6b278aa in QMetaCallEvent::placeMetaCall (this=0x89125c8, object=0x87e0e10) at kernel/qobject.cpp:524
#19 0xb6b2f6fb in QObject::event (this=0x87e0e10, e=0x89125c8) at kernel/qobject.cpp:1194
#20 0xb60227f4 in QApplicationPrivate::notify_helper (this=0x857bbf0, receiver=0x87e0e10, e=0x89125c8) at kernel/qapplication.cpp:4567
#21 0xb60292d3 in QApplication::notify (this=0xbfa70d30, receiver=receiver@entry=0x87e0e10, e=e@entry=0x89125c8) at kernel/qapplication.cpp:4353
#22 0xb71610a4 in KApplication::notify (this=0xbfa70d30, receiver=0x87e0e10, event=0x89125c8) at ../../kdeui/kernel/kapplication.cpp:311
#23 0xb6b15e4a in QCoreApplication::notifyInternal (this=0xbfa70d30, receiver=receiver@entry=0x87e0e10, event=event@entry=0x89125c8) at kernel/qcoreapplication.cpp:953
#24 0xb6b1970d in sendEvent (event=0x89125c8, receiver=0x87e0e10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x85532d8) at kernel/qcoreapplication.cpp:1577
#26 0xb6b19c1c in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#27 0xb6b4623e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x8584b10) at kernel/qeventdispatcher_glib.cpp:287
#29 0xb4fc61e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb4fc6468 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb4fc6528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb6b4593b in QEventDispatcherGlib::processEvents (this=this@entry=0x8553e48, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#33 0xb60d75de in QGuiEventDispatcherGlib::processEvents (this=0x8553e48, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0xb6b14823 in QEventLoop::processEvents (this=this@entry=0xbfa70c38, flags=...) at kernel/qeventloop.cpp:149
#35 0xb6b14b49 in QEventLoop::exec (this=this@entry=0xbfa70c38, flags=...) at kernel/qeventloop.cpp:204
#36 0xb6b1a8fe in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#37 0xb6020a24 in QApplication::exec () at kernel/qapplication.cpp:3828
#38 0x08061680 in ?? ()
#39 0xb5c24a83 in __libc_start_main (main=0x805f650, argc=3, argv=0xbfa70e24, init=0x80ae7e0 <__libc_csu_init>, fini=0x80ae850 <__libc_csu_fini>, rtld_fini=0xb7783180 <_dl_fini>, stack_end=0xbfa70e1c) at libc-start.c:287
#40 0x0806203c in _start ()

Possible duplicates by query: bug 332393.

Reported using DrKonqi
Comment 1 Christoph Feck 2014-06-25 09:29:15 UTC

*** This bug has been marked as a duplicate of bug 309824 ***