Bug 332393 - Une application s'arréter
Summary: Une application s'arréter
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-21 09:01 UTC by jp.platek
Modified: 2014-03-22 06:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jp.platek 2014-03-21 09:01:41 UTC
Application: kpat (3.6)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-60-generic x86_64
Distribution: Ubuntu 12.04.4 LTS

-- Information about the crash:
Démarrage normal de l'ordinateur . Déjà la même application s'arrêter pendant l'utilisation normal. Pas de concomitance avec quelconque opération

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f95ac8e3780 (LWP 1832))]

Thread 2 (Thread 0x7f95987cd700 (LWP 1881)):
#0  0x00007f95a927ea43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f95a5271ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f95a5272124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f95aa9ca43e in QEventDispatcherGlib::processEvents (this=0x7f95900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:435
#4  0x00007f95aa999c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f95aa999ed7 in QEventLoop::exec (this=0x7f95987ccdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f95aa898fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f95aa9799ff in QInotifyFileSystemWatcherEngine::run (this=0x2424970) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f95aa89bfcb in QThreadPrivate::start (arg=0x2424970) at thread/qthread_unix.cpp:298
#9  0x00007f95a5b36e9a in start_thread (arg=0x7f95987cd700) at pthread_create.c:308
#10 0x00007f95a928a3fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f95ac8e3780 (LWP 1832)):
[KCrash Handler]
#6  __lll_timedlock_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:187
#7  0x00007f95a5b39ede in _L_timedlock_108 () from /lib/x86_64-linux-gnu/libpthread.so.0
#8  0x00007f95a5b396f6 in pthread_mutex_timedlock (mutex=0x7f9598e6c008, abstime=0x7fffd961e540) at pthread_mutex_timedlock.c:80
#9  0x00007f95aaf2b99c in pthreadTimedLock::lock (this=0x2207910) at ../../kdecore/util/kshareddatacache_p.h:187
#10 0x00007f95aaf2fd58 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1232
#11 KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fffd961e8a0) at ../../kdecore/util/kshareddatacache.cpp:1255
#12 0x00007f95aaf308d0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fffd961e8a0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#13 0x00007f95aaf29ed6 in KSharedDataCache::find (this=0x2204eb0, key=..., destination=0x7fffd961e910) at ../../kdecore/util/kshareddatacache.cpp:1630
#14 0x00007f95ab4658af in KImageCache::findPixmap (this=0x2204eb0, key=..., destination=0x23a20d8) at ../../kdeui/util/kimagecache.cpp:150
#15 0x00007f95ac4d967a in KAbstractCardDeckPrivate::requestPixmap (this=0x2208420, id=<optimized out>, faceUp=<optimized out>) at ../../../kpat/libkcardgame/kabstractcarddeck.cpp:205
#16 0x00007f95ac4d9870 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at ../../../kpat/libkcardgame/kabstractcarddeck.cpp:506
#17 0x00007f95ac4dbea4 in KCard::paint (this=0x2201ca0, painter=0x7fffd961f6f0, option=<optimized out>, widget=<optimized out>) at ../../../kpat/libkcardgame/kcard.cpp:319
#18 0x00007f95aa33d8e9 in QGraphicsScenePrivate::draw (this=0x2200250, item=0x2201cb0, painter=0x7fffd961f6f0, viewTransform=0x7fffd961f3c0, transformPtr=0x7fffd961ee90, exposedRegion=0x2059438, widget=0x207cce0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#19 0x00007f95aa33e415 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x2200250, item=0x2201cb0, painter=0x7fffd961f6f0, viewTransform=0x7fffd961f3c0, exposedRegion=0x2059438, widget=0x207cce0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4857
#20 0x00007f95aa33ec31 in QGraphicsScenePrivate::drawItems (this=0x2200250, painter=0x7fffd961f6f0, viewTransform=0x7fffd961f3c0, exposedRegion=0x2059438, widget=0x207cce0) at graphicsview/qgraphicsscene.cpp:4739
#21 0x00007f95aa3578b0 in QGraphicsView::paintEvent (this=0x2058f50, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#22 0x00007f95a9d6e0f6 in QWidget::event (this=0x2058f50, event=0x7fffd9620090) at kernel/qwidget.cpp:8508
#23 0x00007f95aa12e3f6 in QFrame::event (this=0x2058f50, e=0x7fffd9620090) at widgets/qframe.cpp:557
#24 0x00007f95aa358b6b in QGraphicsView::viewportEvent (this=0x2058f50, event=0x7fffd9620090) at graphicsview/qgraphicsview.cpp:2866
#25 0x00007f95aa99b028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x207cce0, event=0x7fffd9620090) at kernel/qcoreapplication.cpp:986
#26 0x00007f95a9d1d85f in notify_helper (e=0x7fffd9620090, receiver=0x207cce0, this=0x1f356b0) at kernel/qapplication.cpp:4555
#27 QApplicationPrivate::notify_helper (this=0x1f356b0, receiver=0x207cce0, e=0x7fffd9620090) at kernel/qapplication.cpp:4531
#28 0x00007f95a9d22713 in QApplication::notify (this=0x7fffd9621fd0, receiver=0x207cce0, e=0x7fffd9620090) at kernel/qapplication.cpp:4420
#29 0x00007f95ab4003f6 in KApplication::notify (this=0x7fffd9621fd0, receiver=0x207cce0, event=0x7fffd9620090) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00007f95aa99ae9c in QCoreApplication::notifyInternal (this=0x7fffd9621fd0, receiver=0x207cce0, event=0x7fffd9620090) at kernel/qcoreapplication.cpp:876
#31 0x00007f95a9d69d96 in sendSpontaneousEvent (event=0x7fffd9620090, receiver=0x207cce0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#32 QWidgetPrivate::drawWidget (this=0x207cd10, pdev=0x20827b0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5585
#33 0x00007f95a9d6aa0f in QWidgetPrivate::paintSiblingsRecursive (this=0x2058fb0, pdev=0x20827b0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5794
#34 0x00007f95a9d69acc in QWidgetPrivate::drawWidget (this=0x2058fb0, pdev=0x20827b0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5638
#35 0x00007f95a9d6aa0f in QWidgetPrivate::paintSiblingsRecursive (this=0x20243d0, pdev=0x20827b0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5794
#36 0x00007f95a9d6a797 in QWidgetPrivate::paintSiblingsRecursive (this=0x20243d0, pdev=0x20827b0, siblings=..., index=10, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5781
#37 0x00007f95a9d6a797 in QWidgetPrivate::paintSiblingsRecursive (this=0x20243d0, pdev=0x20827b0, siblings=..., index=12, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5781
#38 0x00007f95a9d6a797 in QWidgetPrivate::paintSiblingsRecursive (this=0x20243d0, pdev=0x20827b0, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5781
#39 0x00007f95a9d69acc in QWidgetPrivate::drawWidget (this=0x20243d0, pdev=0x20827b0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x2090290) at kernel/qwidget.cpp:5638
#40 0x00007f95a9f3ab98 in QWidgetBackingStore::sync (this=0x2090290) at painting/qbackingstore.cpp:1373
#41 0x00007f95a9f3af63 in QWidgetBackingStore::sync (this=0x2090290, exposedWidget=0x2024280, exposedRegion=...) at painting/qbackingstore.cpp:1161
#42 0x00007f95a9d9bdea in QETWidget::translatePaintEvent (this=0x2024280, event=<optimized out>) at kernel/qapplication_x11.cpp:5586
#43 0x00007f95a9d9cefb in QApplication::x11ProcessEvent (this=0x7fffd9621fd0, event=0x7fffd9621b20) at kernel/qapplication_x11.cpp:3634
#44 0x00007f95a9dc6112 in x11EventSourceDispatch (s=0x1f291b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#45 0x00007f95a5271d13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f95a5272060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f95a5272124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007f95aa9ca3cc in QEventDispatcherGlib::processEvents (this=0x1edd4b0, flags=...) at kernel/qeventdispatcher_glib.cpp:433
#49 0x00007f95a9dc5d9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x00007f95aa999c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#51 0x00007f95aa999ed7 in QEventLoop::exec (this=0x7fffd9621ec0, flags=...) at kernel/qeventloop.cpp:204
#52 0x00007f95aa99ef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#53 0x00000000004189ea in main (argc=3, argv=0x7fffd9622b58) at ../../kpat/main.cpp:325

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-03-22 06:07:54 UTC

*** This bug has been marked as a duplicate of bug 309824 ***