Bug 333523 - digicam crashes when automatic lensdingens is used
Summary: digicam crashes when automatic lensdingens is used
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Plugin-Editor-LensCorrection (show other bugs)
Version: 3.4.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-04-17 04:48 UTC by kde
Modified: 2021-08-26 16:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2014-04-17 04:48:25 UTC
Application: digikam (3.4.0)
KDE Platform Version: 4.11.5
Qt Version: 4.8.4
Operating System: Linux 3.11.0-19-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
is maybe a duplicate to this bug

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
[Current thread is 1 (Thread 0x7f5f9d969a80 (LWP 4677))]

Thread 8 (Thread 0x7f5f74195700 (LWP 4679)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5f980bb406 in wait (time=18446744073709551615, this=0x11fb760) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x11fb670, mutex=mutex@entry=0x11fb668, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d5c4e in Digikam::ScanController::run (this=0x11fb400) at /build/buildd/digikam-3.4.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007f5f980baf2f in QThreadPrivate::start (arg=0x11fb400) at thread/qthread_unix.cpp:338
#5  0x00007f5f92625f6e in start_thread (arg=0x7f5f74195700) at pthread_create.c:311
#6  0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 7 (Thread 0x7f5f73994700 (LWP 4680)):
#0  0x00007f5f92628055 in __GI___pthread_mutex_lock (mutex=0x7f5f64000a60) at pthread_mutex_lock.c:95
#1  0x00007f5f8fc383a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5f8fbf812c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5f8fbf863b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5f8fbf87ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5f981e7a76 in QEventDispatcherGlib::processEvents (this=0x7f5f640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f5f981b95ef in QEventLoop::processEvents (this=this@entry=0x7f5f73993ab0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f5f981b98e5 in QEventLoop::exec (this=this@entry=0x7f5f73993ab0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f5f980b888f in QThread::exec (this=this@entry=0x11fdca0) at thread/qthread.cpp:542
#9  0x00007f5f9819ad13 in QInotifyFileSystemWatcherEngine::run (this=0x11fdca0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f5f980baf2f in QThreadPrivate::start (arg=0x11fdca0) at thread/qthread_unix.cpp:338
#11 0x00007f5f92625f6e in start_thread (arg=0x7f5f73994700) at pthread_create.c:311
#12 0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 6 (Thread 0x7f5f73193700 (LWP 4700)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5f980bb406 in wait (time=18446744073709551615, this=0x11ac6a0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1513bc0, mutex=mutex@entry=0x1513bb8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5f9af3516a in Digikam::ParkingThread::run (this=0x1513ba0) at /build/buildd/digikam-3.4.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f5f980baf2f in QThreadPrivate::start (arg=0x1513ba0) at thread/qthread_unix.cpp:338
#5  0x00007f5f92625f6e in start_thread (arg=0x7f5f73193700) at pthread_create.c:311
#6  0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7f5f72221700 (LWP 4701)):
#0  __pthread_mutex_unlock_usercnt (mutex=0x7f5f5c000aa0, decr=1) at pthread_mutex_unlock.c:52
#1  0x00007f5f8fc383d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5f8fbf8699 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5f8fbf87ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5f981e7a76 in QEventDispatcherGlib::processEvents (this=0x7f5f5c000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f5f981b95ef in QEventLoop::processEvents (this=this@entry=0x7f5f72220ab0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f5f981b98e5 in QEventLoop::exec (this=this@entry=0x7f5f72220ab0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f5f980b888f in QThread::exec (this=this@entry=0x1a872e0) at thread/qthread.cpp:542
#8  0x00007f5f9819ad13 in QInotifyFileSystemWatcherEngine::run (this=0x1a872e0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f5f980baf2f in QThreadPrivate::start (arg=0x1a872e0) at thread/qthread_unix.cpp:338
#10 0x00007f5f92625f6e in start_thread (arg=0x7f5f72221700) at pthread_create.c:311
#11 0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f5f4ecdb700 (LWP 4780)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5f980bb406 in wait (time=18446744073709551615, this=0x2f4e7a0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2f1aca0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5f9b3865b1 in KDcrawIface::RActionThreadBase::run() () from /usr/lib/libkdcraw.so.22
#4  0x00007f5f980baf2f in QThreadPrivate::start (arg=0x2f4e4b0) at thread/qthread_unix.cpp:338
#5  0x00007f5f92625f6e in start_thread (arg=0x7f5f4ecdb700) at pthread_create.c:311
#6  0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f5f55fb9700 (LWP 4781)):
[KCrash Handler]
#6  setColor (sixteenBit=false, data=0x7f5fdf347f0c <Address 0x7f5fdf347f0c out of bounds>, this=<synthetic pointer>) at /build/buildd/digikam-3.4.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x7f5f55fb83f8, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.4.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007f5f9aea69db in Digikam::LensFunFilter::filterImage (this=0x7f5f55fb83b0) at /build/buildd/digikam-3.4.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#9  0x00007f5f9ad8982c in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x7f5f55fb83b0) at /build/buildd/digikam-3.4.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x0000000000718c05 in Digikam::BatchTool::applyFilter (this=this@entry=0x7f5f44048d30, filter=filter@entry=0x7f5f55fb83b0) at /build/buildd/digikam-3.4.0/core/utilities/queuemanager/manager/batchtool.cpp:446
#11 0x000000000073c28a in Digikam::LensAutoFix::toolOperations (this=0x7f5f44048d30) at /build/buildd/digikam-3.4.0/core/utilities/queuemanager/basetools/enhance/lensautofix.cpp:228
#12 0x0000000000719d4e in Digikam::BatchTool::apply (this=0x7f5f44048d30) at /build/buildd/digikam-3.4.0/core/utilities/queuemanager/manager/batchtool.cpp:441
#13 0x0000000000715d65 in Digikam::Task::run (this=0x5247070) at /build/buildd/digikam-3.4.0/core/utilities/queuemanager/manager/task.cpp:162
#14 0x00007f5f9bfe4cb2 in ThreadWeaver::JobRunHelper::runTheJob (this=this@entry=0x7f5f55fb8a90, th=th@entry=0x7f5f34022c60, job=job@entry=0x5247070) at ../../../threadweaver/Weaver/Job.cpp:106
#15 0x00007f5f9bfe4e6e in ThreadWeaver::Job::execute (this=0x5247070, th=0x7f5f34022c60) at ../../../threadweaver/Weaver/Job.cpp:135
#16 0x00007f5f9bfe690b in ThreadWeaver::JobCollectionJobRunner::execute (this=0x5327b50, t=0x7f5f34022c60) at ../../../threadweaver/Weaver/JobCollection.cpp:82
#17 0x00007f5f9bfe46bb in ThreadWeaver::Thread::run (this=0x7f5f34022c60) at ../../../threadweaver/Weaver/Thread.cpp:108
#18 0x00007f5f980baf2f in QThreadPrivate::start (arg=0x7f5f34022c60) at thread/qthread_unix.cpp:338
#19 0x00007f5f92625f6e in start_thread (arg=0x7f5f55fb9700) at pthread_create.c:311
#20 0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f5f4918b700 (LWP 4788)):
#0  0x00007f5f972ccf7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5f8fbf86a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5f8fbf87ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5f981e7a76 in QEventDispatcherGlib::processEvents (this=0x7f5f0c01ae10, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5f981b95ef in QEventLoop::processEvents (this=this@entry=0x7f5f4918aa80, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5f981b98e5 in QEventLoop::exec (this=this@entry=0x7f5f4918aa80, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5f9af34813 in Digikam::WorkerObjectRunnable::run (this=0x7f5f44058190) at /build/buildd/digikam-3.4.0/core/libs/threads/threadmanager.cpp:196
#7  0x00007f5f980ae7ae in QThreadPoolThread::run (this=0x2ffab50) at concurrent/qthreadpool.cpp:107
#8  0x00007f5f980baf2f in QThreadPrivate::start (arg=0x2ffab50) at thread/qthread_unix.cpp:338
#9  0x00007f5f92625f6e in start_thread (arg=0x7f5f4918b700) at pthread_create.c:311
#10 0x00007f5f972d99cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f5f9d969a80 (LWP 4677)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007f5f980b9a03 in _q_futex (val2=0, addr2=0x0, timeout=0x0, val=2, op=0, addr=0x11a2da0) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=this@entry=0x11a2da0, timeout=timeout@entry=-1) at thread/qmutex_unix.cpp:113
#3  0x00007f5f980b603d in QMutex::lock (this=<optimized out>) at thread/qmutex.cpp:164
#4  0x00007f5f9a8d8d59 in Digikam::DatabaseAccess::DatabaseAccess (this=<optimized out>) at /build/buildd/digikam-3.4.0/core/libs/database/databaseaccess.cpp:101
#5  0x00007f5f9a8f0693 in Digikam::ImageInfo::ImageInfo (this=0x7fff60100720, ID=9569) at /build/buildd/digikam-3.4.0/core/libs/database/imageinfo.cpp:293
#6  0x00000000005d20bb in Digikam::ScanControllerLoadingCacheFileWatch::slotImageChanged (this=0x12f85e0, changeset=...) at /build/buildd/digikam-3.4.0/core/digikam/database/scancontroller.cpp:1175
#7  0x00007f5f981d2dce in QObject::event (this=0x12f85e0, e=<optimized out>) at kernel/qobject.cpp:1194
#8  0x00007f5f98babdfc in QApplicationPrivate::notify_helper (this=this@entry=0x10167a0, receiver=receiver@entry=0x12f85e0, e=e@entry=0x7f5f0c05a2a0) at kernel/qapplication.cpp:4567
#9  0x00007f5f98bb2470 in QApplication::notify (this=this@entry=0x7fff601012e0, receiver=receiver@entry=0x12f85e0, e=e@entry=0x7f5f0c05a2a0) at kernel/qapplication.cpp:4353
#10 0x00007f5f998b5a6a in KApplication::notify (this=0x7fff601012e0, receiver=0x12f85e0, event=0x7f5f0c05a2a0) at ../../kdeui/kernel/kapplication.cpp:311
#11 0x00007f5f981ba8bd in QCoreApplication::notifyInternal (this=0x7fff601012e0, receiver=receiver@entry=0x12f85e0, event=event@entry=0x7f5f0c05a2a0) at kernel/qcoreapplication.cpp:946
#12 0x00007f5f981bde1f in sendEvent (event=0x7f5f0c05a2a0, receiver=0x12f85e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#13 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf8a910) at kernel/qcoreapplication.cpp:1570
#14 0x00007f5f981be2c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#15 0x00007f5f981e8073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=0x1009870) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007f5f8fbf83b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f5f8fbf8708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f5f8fbf87ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f5f981e7a55 in QEventDispatcherGlib::processEvents (this=0xf53b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007f5f98c4d9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#22 0x00007f5f981b95ef in QEventLoop::processEvents (this=this@entry=0x7fff60100dc0, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007f5f981b98e5 in QEventLoop::exec (this=this@entry=0x7fff60100dc0, flags=...) at kernel/qeventloop.cpp:204
#24 0x00007f5f981bee5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#25 0x00007f5f98baa34c in QApplication::exec () at kernel/qapplication.cpp:3828
#26 0x0000000000491ef3 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-3.4.0/core/digikam/main/main.cpp:235

The reporter indicates this bug may be a duplicate of or related to bug 319383.

Possible duplicates by query: bug 321517, bug 319383.

Reported using DrKonqi
Comment 1 caulier.gilles 2014-04-17 09:24:24 UTC

*** This bug has been marked as a duplicate of bug 319383 ***
Comment 2 caulier.gilles 2021-08-26 16:53:20 UTC
Fixed with #319383