Bug 319383 - Crash while applying lensfun distortion correction
Summary: Crash while applying lensfun distortion correction
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-LensCorrection (show other bugs)
Version: 4.2.0
Platform: Ubuntu Packages Linux
: NOR crash with 60 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-05 21:47 UTC by Matthias Adrian Mendler
Modified: 2016-07-01 09:22 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments
This makes lensfun crash. (3.83 MB, image/jpeg)
2013-05-05 21:53 UTC, Matthias Adrian Mendler
Details
New crash information added by DrKonqi (19.75 KB, text/plain)
2013-09-16 05:46 UTC, ramseycs
Details
New crash information added by DrKonqi (10.68 KB, text/plain)
2013-10-20 21:06 UTC, nodemaster
Details
New crash information added by DrKonqi (7.77 KB, text/plain)
2014-01-08 12:39 UTC, Matthias Adrian Mendler
Details
New crash information added by DrKonqi (16.27 KB, text/plain)
2014-06-01 12:26 UTC, luneandmer
Details
New crash information added by DrKonqi (12.32 KB, text/plain)
2014-07-03 01:20 UTC, Stephen Dunn
Details
attachment-23676-0.html (5.19 KB, text/html)
2014-09-02 15:50 UTC, Karl-Wilhelm Frommeyer
Details
attachment-6301-0.html (4.29 KB, text/html)
2014-12-10 18:48 UTC, Karl-Wilhelm Frommeyer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Adrian Mendler 2013-05-05 21:47:49 UTC
Application: digikam (3.1.0)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:
This one picture is always crashing digikam when applying lensfun distortion correction. While other pictures crasehd it several times before, only with this one it crashes every time. 
Digikam also crashes when applying lensfun distortion correction in a batch proccess - always, but not directly, just after starting for a few seconds. The same pictures don't crash it tough, when lensfun is applied manually.

Could this actually be a bug in ubuntus lensfun library?

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f0ae240ea80 (LWP 3647))]

Thread 6 (Thread 0x7f0ab9d4a700 (LWP 3648)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f0adcc6914b in wait (time=18446744073709551615, this=0x267d870) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x267d770, mutex=mutex@entry=0x267d768, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005ccce8 in Digikam::ScanController::run (this=0x267d500) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:705
#4  0x00007f0adcc68bec in QThreadPrivate::start (arg=0x267d500) at thread/qthread_unix.cpp:338
#5  0x00007f0ac506c3b4 in ?? () from /usr/lib/nvidia-310/libGL.so.1
#6  0x00007f0ad7195f8e in start_thread (arg=0x7f0ab9d4a700) at pthread_create.c:311
#7  0x00007f0adbe85e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7f0ab953e700 (LWP 3649)):
#0  0x00007f0ad49c5d40 in pthread_getspecific@plt () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0ad4a19390 in g_thread_self () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ad49f433e in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0ad49f50b4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0ad49f5304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0adcd94036 in QEventDispatcherGlib::processEvents (this=0x7f0aac0008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f0adcd6438f in QEventLoop::processEvents (this=this@entry=0x7f0ab953da10, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0adcd64618 in QEventLoop::exec (this=this@entry=0x7f0ab953da10, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0adcc66410 in QThread::exec (this=this@entry=0x267ffe0) at thread/qthread.cpp:542
#9  0x00007f0adcd45edf in QInotifyFileSystemWatcherEngine::run (this=0x267ffe0) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007f0adcc68bec in QThreadPrivate::start (arg=0x267ffe0) at thread/qthread_unix.cpp:338
#11 0x00007f0ac506c3b4 in ?? () from /usr/lib/nvidia-310/libGL.so.1
#12 0x00007f0ad7195f8e in start_thread (arg=0x7f0ab953e700) at pthread_create.c:311
#13 0x00007f0adbe85e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f0ab8d35700 (LWP 3652)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f0adcc6914b in wait (time=18446744073709551615, this=0x29fcef0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x29d6260, mutex=mutex@entry=0x29d6258, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f0adfcb40a9 in Digikam::ParkingThread::run (this=0x29d6240) at /build/buildd/digikam-3.1.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f0adcc68bec in QThreadPrivate::start (arg=0x29d6240) at thread/qthread_unix.cpp:338
#5  0x00007f0ac506c3b4 in ?? () from /usr/lib/nvidia-310/libGL.so.1
#6  0x00007f0ad7195f8e in start_thread (arg=0x7f0ab8d35700) at pthread_create.c:311
#7  0x00007f0adbe85e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f0a9a5b9700 (LWP 3738)):
#0  0x00007f0ad4a34359 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0ad4a345b9 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ad49f47d5 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0ad49f50fe in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0ad49f5304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0adcd94036 in QEventDispatcherGlib::processEvents (this=0x7f0a0c002880, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f0adcd6438f in QEventLoop::processEvents (this=this@entry=0x7f0a9a5b8aa0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0adcd64618 in QEventLoop::exec (this=this@entry=0x7f0a9a5b8aa0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0adfcb364b in Digikam::WorkerObjectRunnable::run (this=0x8e684d0) at /build/buildd/digikam-3.1.0/core/libs/threads/threadmanager.cpp:196
#9  0x00007f0adcc5c55d in QThreadPoolThread::run (this=0x3ef2da0) at concurrent/qthreadpool.cpp:107
#10 0x00007f0adcc68bec in QThreadPrivate::start (arg=0x3ef2da0) at thread/qthread_unix.cpp:338
#11 0x00007f0ad7195f8e in start_thread (arg=0x7f0a9a5b9700) at pthread_create.c:311
#12 0x00007f0adbe85e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f0a9f3b7700 (LWP 3847)):
[KCrash Handler]
#6  setColor (sixteenBit=true, data=0x7f0af74d73c8 <Address 0x7f0af74d73c8 out of bounds>, this=<synthetic pointer>) at /build/buildd/digikam-3.1.0/core/libs/dimg/dcolorpixelaccess.h:50
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x89abdf8, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.1.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007f0adfc2fd74 in Digikam::LensFunFilter::filterImage (this=0x89abdb0) at /build/buildd/digikam-3.1.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#9  0x00007f0adfb1d894 in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x89abdb0) at /build/buildd/digikam-3.1.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x00007f0adfcb60de in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x8576050) at /build/buildd/digikam-3.1.0/core/libs/threads/dynamicthread.cpp:186
#11 0x00007f0adcc5c55d in QThreadPoolThread::run (this=0x3ef0800) at concurrent/qthreadpool.cpp:107
#12 0x00007f0adcc68bec in QThreadPrivate::start (arg=0x3ef0800) at thread/qthread_unix.cpp:338
#13 0x00007f0ad7195f8e in start_thread (arg=0x7f0a9f3b7700) at pthread_create.c:311
#14 0x00007f0adbe85e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f0ae240ea80 (LWP 3647)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f0adcc6914b in wait (time=18446744073709551615, this=0x2ca3ad0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2c9a1c8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f0adfcb4394 in Digikam::WorkerObject::wait (this=0x2ca39e0) at /build/buildd/digikam-3.1.0/core/libs/threads/workerobject.cpp:95
#4  0x0000000000611ee3 in Digikam::FileActionMngr::shutDown (this=this@entry=0x2ca36b0) at /build/buildd/digikam-3.1.0/core/digikam/fileaction/fileactionmngr.cpp:110
#5  0x0000000000611f1d in Digikam::FileActionMngr::~FileActionMngr (this=0x2ca36b0, __in_chrg=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/fileaction/fileactionmngr.cpp:78
#6  0x0000000000611fa7 in ~FileActionMngrCreator (this=0x2ca36b0, __in_chrg=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/fileaction/fileactionmngr.cpp:52
#7  destroy () at /build/buildd/digikam-3.1.0/core/digikam/fileaction/fileactionmngr.cpp:59
#8  0x00007f0adbdc8121 in __run_exit_handlers (status=1, listp=0x7f0adc14d6a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#9  0x00007f0adbdc81a5 in __GI_exit (status=<optimized out>) at exit.c:99
#10 0x00007f0add7b8348 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#11 0x00007f0ade457888 in KApplication::xioErrhandler (this=0x7fffb6799970, dpy=0x25008f0) at ../../kdeui/kernel/kapplication.cpp:419
#12 0x00007f0ada3996de in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#13 0x00007f0ada39716d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#14 0x00007f0ada38875b in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007f0add7f3bdc in x11EventSourceCheck (s=0x24da4b0) at kernel/qguieventdispatcher_glib.cpp:85
#16 0x00007f0ad49f4c69 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007f0ad49f5175 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f0ad49f5304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f0adcd94016 in QEventDispatcherGlib::processEvents (this=0x2461ca0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#20 0x00007f0add7f41ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#21 0x00007f0adcd6438f in QEventLoop::processEvents (this=this@entry=0x7fffb6799360, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f0adcd64618 in QEventLoop::exec (this=this@entry=0x7fffb6799360, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f0adcd69cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#24 0x00007f0add74cffc in QApplication::exec () at kernel/qapplication.cpp:3828
#25 0x000000000048f9ab in main (argc=1, argv=0x7fffb6799ba8) at /build/buildd/digikam-3.1.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 277584.

Reported using DrKonqi
Comment 1 Matthias Adrian Mendler 2013-05-05 21:53:17 UTC
Created attachment 79724 [details]
This makes lensfun crash.
Comment 2 caulier.gilles 2013-05-06 05:40:17 UTC
Which liblenfun shared lib version you use ? Look into Help/Components Info for details.

Gilles Caulier
Comment 3 caulier.gilles 2013-05-07 11:50:28 UTC
*** Bug 319462 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Adrian Mendler 2013-05-12 16:22:55 UTC
The liblensfun Version is 0.2.7-0 

Sorry for the late answer.
Comment 5 Teemu Rytilahti 2013-06-14 13:45:24 UTC
I get the same crash, but only when chromatic aberration is enabled so I have left it disabled for the time being. This was tested with current git master and lensfun 0.2.7 from svn.

Full backtrace with symbols, from where you can see that getSubPixelColorFast is being called with negative values, crashes with 16-bit and without for the same image:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1f96ede980 (LWP 5622))]

Thread 18 (Thread 0x7f1f6a0dd700 (LWP 5623)):
#0  0x00007f1f8b40a8b4 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1f8b6961f6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00000000005fe887 in Digikam::ScanController::run (this=0x17db860) at /home/tpr/storage/kde/digikam-sc/core/digikam/database/scancontroller.cpp:713
#3  0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 17 (Thread 0x7f1f698dc700 (LWP 5624)):
#0  0x00007f1f8b409d8e in __pthread_mutex_unlock_usercnt () from /usr/lib/libpthread.so.0
#1  0x00007f1f8661d261 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#2  0x00007f1f865dd7d0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0x00007f1f865de053 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00007f1f865de23c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0x00007f1f8b7c28f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f1f8b79496f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f1f8b794c65 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x00007f1f8b69367f in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x00007f1f8b776113 in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#11 0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#12 0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 16 (Thread 0x7f1f690db700 (LWP 5626)):
#0  0x00007f1f8b40a8b4 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1f8b6961f6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1f938d28b1 in Digikam::ParkingThread::run (this=0x19ece00) at /home/tpr/storage/kde/digikam-sc/core/libs/threads/threadmanager.cpp:119
#3  0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 15 (Thread 0x7f1f09ffb700 (LWP 5711)):
#0  0x00007f1f865ddc10 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#1  0x00007f1f865de0cb in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f1f865de23c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f1f8b7c28f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f1f8b79496f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f1f8b794c65 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f1f938d1e20 in Digikam::WorkerObjectRunnable::run (this=0x5749a70) at /home/tpr/storage/kde/digikam-sc/core/libs/threads/threadmanager.cpp:196
#7  0x00007f1f8b68981e in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 14 (Thread 0x7f1edbfff700 (LWP 5712)):
#0  0x00007f1f8b40ac61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1f8b6961d4 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1f8b689915 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 13 (Thread 0x7f1f4e7fc700 (LWP 5721)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 12 (Thread 0x7f1f4dffb700 (LWP 5722)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 11 (Thread 0x7f1f4d7fa700 (LWP 5723)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 10 (Thread 0x7f1f0b7fe700 (LWP 5734)):
[KCrash Handler]
#5  0x00007f1f936bb7d1 in Digikam::DColor::setColor (this=0x7f1f0b7fd340, data=0x7f1fb61e5140 <Address 0x7f1fb61e5140 out of bounds>, sixteenBit=true) at /home/tpr/storage/kde/digikam-sc/core/libs/dimg/dcolorpixelaccess.h:50
#6  0x00007f1f936b3da7 in Digikam::DImg::getSubPixelColorFast (this=0x69fdb18, x=-2.05356741, y=-1.53913403) at /home/tpr/storage/kde/digikam-sc/core/libs/dimg/dimg.cpp:1391
#7  0x00007f1f93823e11 in Digikam::LensFunFilter::filterImage (this=0x69fdad0) at /home/tpr/storage/kde/digikam-sc/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#8  0x00007f1f936fc66e in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x69fdad0) at /home/tpr/storage/kde/digikam-sc/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#9  0x00007f1f936fc825 in Digikam::DImgThreadedFilter::run (this=0x69fdad0) at /home/tpr/storage/kde/digikam-sc/core/libs/dimg/filters/dimgthreadedfilter.cpp:215
#10 0x00007f1f938d4af2 in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x55daa70) at /home/tpr/storage/kde/digikam-sc/core/libs/threads/dynamicthread.cpp:186
#11 0x00007f1f8b68981e in ?? () from /usr/lib/libQtCore.so.4
#12 0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#13 0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#14 0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 9 (Thread 0x7f1f37fff700 (LWP 5735)):
#0  0x00007f1f8b40ac61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1f8b6961d4 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1f8b689915 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 8 (Thread 0x7f1f377fe700 (LWP 5736)):
#0  0x00007f1f8b40ac61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1f8b6961d4 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1f8b689915 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f1f8b695d1f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 7 (Thread 0x7f1f4cff9700 (LWP 5738)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f1f4f3a1700 (LWP 5739)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f1f36ffd700 (LWP 5740)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f1f4ffff700 (LWP 5741)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f1f367fc700 (LWP 5742)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f1f35ffb700 (LWP 5743)):
#0  0x00007f1f8a662b12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f1f8a66137e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f1f8b406dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f1f8a17bcdd in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f1f96ede980 (LWP 5622)):
#0  0x00007f1f8b40a8b4 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1f8b6961f6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1f938d3970 in Digikam::WorkerObject::wait (this=0x1b99ff0) at /home/tpr/storage/kde/digikam-sc/core/libs/threads/workerobject.cpp:95
#3  0x00000000006513b4 in Digikam::FileActionMngr::shutDown (this=0x1b99cc0) at /home/tpr/storage/kde/digikam-sc/core/digikam/fileaction/fileactionmngr.cpp:110
#4  0x0000000000651048 in Digikam::FileActionMngr::~FileActionMngr (this=0x1b99cc0, __in_chrg=<optimized out>) at /home/tpr/storage/kde/digikam-sc/core/digikam/fileaction/fileactionmngr.cpp:78
#5  0x0000000000652bc8 in Digikam::FileActionMngrCreator::~FileActionMngrCreator (this=0x1b99cc0, __in_chrg=<optimized out>) at /home/tpr/storage/kde/digikam-sc/core/digikam/fileaction/fileactionmngr.cpp:52
#6  0x0000000000650f25 in destroy () at /home/tpr/storage/kde/digikam-sc/core/digikam/fileaction/fileactionmngr.cpp:59
#7  0x00000000005d4941 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0xc446e8 <Digikam::._242::operator->()::cleanUpObject>, __in_chrg=<optimized out>) at /usr/include/kglobal.h:62
#8  0x00007f1f8a0cdc99 in __run_exit_handlers () from /usr/lib/libc.so.6
#9  0x00007f1f8a0cdce5 in exit () from /usr/lib/libc.so.6
#10 0x00007f1f8c4516c8 in ?? () from /usr/lib/libQtGui.so.4
#11 0x00007f1f8d10b460 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
#12 0x00007f1f88c42a1e in _XIOError () from /usr/lib/libX11.so.6
#13 0x00007f1f88c404bd in _XEventsQueued () from /usr/lib/libX11.so.6
#14 0x00007f1f88c31a7b in XEventsQueued () from /usr/lib/libX11.so.6
#15 0x00007f1f8c487adc in ?? () from /usr/lib/libQtGui.so.4
#16 0x00007f1f865ddbb1 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#17 0x00007f1f865de0cb in ?? () from /usr/lib/libglib-2.0.so.0
#18 0x00007f1f865de23c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#19 0x00007f1f8b7c28d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#20 0x00007f1f8c488066 in ?? () from /usr/lib/libQtGui.so.4
#21 0x00007f1f8b79496f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#22 0x00007f1f8b794c65 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#23 0x00007f1f8b799ccb in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#24 0x000000000070f660 in main (argc=1, argv=0x7fffa44db608) at /home/tpr/storage/kde/digikam-sc/core/digikam/main/main.cpp:235
Comment 6 caulier.gilles 2013-06-23 13:10:58 UTC
*** Bug 321517 has been marked as a duplicate of this bug. ***
Comment 7 ramseycs 2013-09-16 05:46:00 UTC
Created attachment 82332 [details]
New crash information added by DrKonqi

digikam (3.3.0) on KDE Platform 4.11.00 using Qt 4.8.3

- What I was doing when the application crashed: Applying Lens Auto-Correction via Batch Queue Manager; processing this same batch, with the same workflow, minus the Auto-Correction results in no crash.

-- Backtrace (Reduced):
#6  setColor (data=0x7f282ae96f0c <Address 0x7f282ae96f0c out of bounds>, this=<synthetic pointer>, sixteenBit=<optimized out>) at /build/buildd/digikam-3.3.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  setColor (sixteenBit=false, data=0x7f282ae96f0c <Address 0x7f282ae96f0c out of bounds>, this=<synthetic pointer>) at /build/buildd/digikam-3.3.0/core/libs/dimg/dimg.cpp:1379
#8  Digikam::DImg::getSubPixelColorFast (this=0x7f27f52b03d8, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.3.0/core/libs/dimg/dimg.cpp:1391
#9  0x00007f28357f1444 in Digikam::LensFunFilter::filterImage (this=0x7f27f52b0390) at /build/buildd/digikam-3.3.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#10 0x00007f28356e04f4 in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x7f27f52b0390) at /build/buildd/digikam-3.3.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
Comment 8 nodemaster 2013-10-20 21:06:42 UTC
Created attachment 82981 [details]
New crash information added by DrKonqi

digikam (3.4.0) on KDE Platform 4.11.2 using Qt 4.8.4

- What I was doing when the application crashed:

applying lens correction with CA correction enabled. The problem doesn't seem to happen if CA correction is disabled.

-- Backtrace (Reduced):
#6  setColor (sixteenBit=false, data=0x7f0c17a067cc <Address 0x7f0c17a067cc out of bounds>, this=<synthetic pointer>) at /build/buildd/digikam-3.4.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x6e51548, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.4.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007f0bdc074991 in Digikam::LensFunFilter::filterImage (this=0x6e51500) at /build/buildd/digikam-3.4.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:194
#9  0x00007f0bdbf5782c in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x6e51500) at /build/buildd/digikam-3.4.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x00007f0bdc104fae in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x6dd5db0) at /build/buildd/digikam-3.4.0/core/libs/threads/dynamicthread.cpp:186
Comment 9 nodemaster 2013-10-20 21:08:42 UTC
For me it's also 0.2.7-0
Comment 10 nodemaster 2013-10-20 21:18:01 UTC
(In reply to comment #8)
> Created attachment 82981 [details]
> New crash information added by DrKonqi
> 
> digikam (3.4.0) on KDE Platform 4.11.2 using Qt 4.8.4
> 
> - What I was doing when the application crashed:
> 
> applying lens correction with CA correction enabled. The problem doesn't
> seem to happen if CA correction is disabled.
> 
> -- Backtrace (Reduced):
> #6  setColor (sixteenBit=false, data=0x7f0c17a067cc <Address 0x7f0c17a067cc
> out of bounds>, this=<synthetic pointer>) at
> /build/buildd/digikam-3.4.0/core/libs/dimg/dcolorpixelaccess.h:42
> #7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x6e51548,
> x=<optimized out>, y=<optimized out>) at
> /build/buildd/digikam-3.4.0/core/libs/dimg/dimg.cpp:1391
> #8  0x00007f0bdc074991 in Digikam::LensFunFilter::filterImage
> (this=0x6e51500) at
> /build/buildd/digikam-3.4.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:194
> #9  0x00007f0bdbf5782c in Digikam::DImgThreadedFilter::startFilterDirectly
> (this=0x6e51500) at
> /build/buildd/digikam-3.4.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
> #10 0x00007f0bdc104fae in Digikam::DynamicThread::DynamicThreadPriv::run
> (this=0x6dd5db0) at
> /build/buildd/digikam-3.4.0/core/libs/threads/dynamicthread.cpp:186

A RAW File is too big to upload. But with this Panasonic RAW File you can reproduce the bug by applying lens correction with the matched lens from EXIF data. digiKam will crash, if you enable CA correction. If CA corretion is disabled, it won't crash.

https://cloud.kossin.info/public.php?service=files&t=cee32b0161cd38802e89a6079724fbeb
Comment 11 Matthias Adrian Mendler 2014-01-08 12:39:32 UTC
Created attachment 84514 [details]
New crash information added by DrKonqi

digikam (3.4.0) on KDE Platform 4.11.3 using Qt 4.8.4

- What I was doing when the application crashed:

Applying distortion correction to tiff file - preview works, applying crashes digikam immediately after pressing apply button.

-- Backtrace (Reduced):
#6  setColor (sixteenBit=false, data=0x7f60d6392c10 <Address 0x7f60d6392c10 out of bounds>, this=<synthetic pointer>) at /build/buildd/digikam-3.4.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x5646c18, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.4.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007f60c46529db in Digikam::LensFunFilter::filterImage (this=0x5646bd0) at /build/buildd/digikam-3.4.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#9  0x00007f60c453582c in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x5646bd0) at /build/buildd/digikam-3.4.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x00007f60c46e2fae in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x557f690) at /build/buildd/digikam-3.4.0/core/libs/threads/dynamicthread.cpp:186
Comment 12 Matthias Adrian Mendler 2014-01-08 12:45:00 UTC
Also here it seems to be the CA correction that crashes digikam. Still liblensfun0.2.7-0.
Comment 13 caulier.gilles 2014-04-17 09:24:24 UTC
*** Bug 333523 has been marked as a duplicate of this bug. ***
Comment 14 caulier.gilles 2014-05-16 07:33:31 UTC
digiKam 4.0.0 is out :

http://www.digikam.org/node/713

Please check if this entry still valid with this new version.

Thanks in advance

Gilles Caulier
Comment 15 Kanwar Plaha 2014-05-18 08:44:27 UTC
The bug persists in 4.0.0 version too.
Comment 16 luneandmer 2014-06-01 12:26:48 UTC
Created attachment 86940 [details]
New crash information added by DrKonqi

digikam (3.5.0) on KDE Platform 4.13.0 using Qt 4.8.6

- What I was doing when the application crashed:

Digikam auto-lense correction is always crashing on the same image but works well on others.

I am using Kubuntu 14.04 LTS with KDE 4.13 and digikam 3.5.0

-- Backtrace (Reduced):
#6  setColor (sixteenBit=false, data=0x7ff84fac879c <error: Cannot access memory at address 0x7ff84fac879c>, this=<synthetic pointer>) at /build/buildd/digikam-3.5.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x5b56fe8, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.5.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007ff7f672ca9b in Digikam::LensFunFilter::filterImage (this=0x5b56fa0) at /build/buildd/digikam-3.5.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#9  0x00007ff7f660fb6c in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x5b56fa0) at /build/buildd/digikam-3.5.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x00007ff7f67bc5de in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x101e9d40) at /build/buildd/digikam-3.5.0/core/libs/threads/dynamicthread.cpp:186
Comment 17 Stephen Dunn 2014-07-03 01:14:59 UTC
Persists in Digikam 4.1 lensfun 2.8
Comment 18 Stephen Dunn 2014-07-03 01:20:35 UTC
Created attachment 87523 [details]
New crash information added by DrKonqi

digikam (4.1.0) on KDE Platform 4.13.2 using Qt 4.8.6

- What I was doing when the application crashed

In editing a photo I used the menu item Edit>Lens>Auto-correction.

This crash occurs with maybe one in ten photos. An affected photo crashes everytime auto-correction is applied.

-- Backtrace (Reduced):
#5  setColor (sixteenBit=false, data=0x7fe7a2e96f0c <Address 0x7fe7a2e96f0c out of bounds>, this=<synthetic pointer>) at /usr/src/debug/digikam-4.1.0/core/libs/dimg/dcolorpixelaccess.h:42
#6  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x17dd2d38, x=<optimized out>, y=<optimized out>) at /usr/src/debug/digikam-4.1.0/core/libs/dimg/dimg.cpp:1391
#7  0x00007fe782212deb in Digikam::LensFunFilter::filterImage (this=0x17dd2cf0) at /usr/src/debug/digikam-4.1.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#8  0x00007fe7820f3709 in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x17dd2cf0) at /usr/src/debug/digikam-4.1.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:197
#9  0x00007fe78229f30e in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x3e90280) at /usr/src/debug/digikam-4.1.0/core/libs/threads/dynamicthread.cpp:186
Comment 19 caulier.gilles 2014-09-02 15:08:07 UTC
Git commit 2ad23dae290c64c293d9c3d3ae2c8734c99f902b by Gilles Caulier.
Committed on 02/09/2014 at 15:06.
Pushed by cgilles into branch 'master'.

Make digiKam ready to use next Lensfun API where CII correction have been removed.
Related: bug 331523, bug 333540
FIXED-IN: 4.3.0

M  +1    -2    imageplugins/enhance/lensautofixtool.cpp
M  +1    -1    imageplugins/enhance/lensautofixtool.h
M  +3    -12   libs/dimg/filters/lens/lensfunfilter.cpp
M  +3    -5    libs/dimg/filters/lens/lensfunfilter.h
M  +3    -6    libs/dimg/filters/lens/lensfuniface.cpp
M  +0    -1    libs/dimg/filters/lens/lensfuniface.h
M  +1    -26   libs/dimg/filters/lens/lensfunsettings.cpp
M  +1    -2    libs/dimg/filters/lens/lensfunsettings.h
M  +8    -13   utilities/queuemanager/basetools/enhance/lensautofix.cpp
M  +1    -1    utilities/queuemanager/basetools/enhance/lensautofix.h

http://commits.kde.org/digikam/2ad23dae290c64c293d9c3d3ae2c8734c99f902b
Comment 20 caulier.gilles 2014-09-02 15:11:36 UTC
Mathias,

With current implementation from git/master (next digiKam 4.3.0), CCI correction have been removed from digiKam because Lensfun team have dropped this feature for next 0.2.9 release.

Can you test if crash still reproducible with current implementation ?

Thanks in advance

Gilles Caulier
Comment 21 Karl-Wilhelm Frommeyer 2014-09-02 15:50:43 UTC
Created attachment 88529 [details]
attachment-23676-0.html

Dear Gilles
I tested the function with digikam 4.2 on kubuntu 14.04. When using the lens correction function digikam crashes but not with the first image. Only with the second or third. But unfortunately than it crashes.
Instead of digikam I use darktable that works fine in the same os.
Thank you for all your effort you took to give us users an improvement!!!!!!!!!
Kind regards Karl-Wilhelm
Comment 22 caulier.gilles 2014-09-02 17:13:37 UTC
Can you share a set of images where you can reproduce the crash to check on my computer.

Thanks in advance

Gilles Caulier
Comment 23 caulier.gilles 2014-12-10 17:55:00 UTC
digiKam 4.5.0 have been released.

Crash still reproducible with this release ?

Gilles Caulier
Comment 24 Karl-Wilhelm Frommeyer 2014-12-10 18:48:14 UTC
Created attachment 89912 [details]
attachment-6301-0.html

Dear Gilles
shortly I updated kubuntu to 14.10. So now I can use digikam 4.2. But that version has still the same bug.
At the moment I do not know how to upgrade safe digikam to 4.5.
Despite the bug with the lens correction digikam 4.2 is very stable and I love this program-package. It's great.
Thank you so much for all the effort and I'm happy because of the outstanding result.
Kind regards Karl-Wilhelm
Comment 25 Georg Schilling 2015-01-15 04:12:11 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-44-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

It seems that there is a correlation betwenn crash and lens-type. Using lenscorrection on pictures of my old Sony-Cam are functioning properly. Usind the Canon EOS 650D whith "default" 18-55 lens will resukt in the crash.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fc5f4bb3ac0 (LWP 16126))]

Thread 6 (Thread 0x7fc5d0248700 (LWP 16128)):
#0  0x00007fc5ee5c9cbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc5d4df3248 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007fc5e9859182 in start_thread (arg=0x7fc5d0248700) at pthread_create.c:312
#3  0x00007fc5ee5d700d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7fc5c97af700 (LWP 16129)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fc5ef3b8816 in wait (time=18446744073709551615, this=0x261f060) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x261ef70, mutex=mutex@entry=0x261ef68, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d5ede in Digikam::ScanController::run (this=0x261ece0) at /build/buildd/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007fc5ef3b832f in QThreadPrivate::start (arg=0x261ece0) at thread/qthread_unix.cpp:349
#5  0x00007fc5e9859182 in start_thread (arg=0x7fc5c97af700) at pthread_create.c:312
#6  0x00007fc5ee5d700d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7fc5c8fae700 (LWP 16130)):
#0  0x00007fc5e70c261a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc5e70c29a9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc5e7080f91 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc5e70810ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc5ef4e77be in QEventDispatcherGlib::processEvents (this=0x7fc5bc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007fc5ef4b90af in QEventLoop::processEvents (this=this@entry=0x7fc5c8fadae0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fc5ef4b93a5 in QEventLoop::exec (this=this@entry=0x7fc5c8fadae0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fc5ef3b5c5f in QThread::exec (this=this@entry=0x252ef80) at thread/qthread.cpp:537
#8  0x00007fc5ef49a823 in QInotifyFileSystemWatcherEngine::run (this=0x252ef80) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007fc5ef3b832f in QThreadPrivate::start (arg=0x252ef80) at thread/qthread_unix.cpp:349
#10 0x00007fc5e9859182 in start_thread (arg=0x7fc5c8fae700) at pthread_create.c:312
#11 0x00007fc5ee5d700d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fc5b6b2e700 (LWP 16226)):
#0  idleTimerSourceCheck (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:230
#1  0x00007fc5e7080a61 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc5e7080f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc5e70810ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc5ef4e77be in QEventDispatcherGlib::processEvents (this=0x7fc5b00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007fc5ef4b90af in QEventLoop::processEvents (this=this@entry=0x7fc5b6b2dae0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fc5ef4b93a5 in QEventLoop::exec (this=this@entry=0x7fc5b6b2dae0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fc5ef3b5c5f in QThread::exec (this=this@entry=0x2e7d5d0) at thread/qthread.cpp:537
#8  0x00007fc5ef49a823 in QInotifyFileSystemWatcherEngine::run (this=0x2e7d5d0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007fc5ef3b832f in QThreadPrivate::start (arg=0x2e7d5d0) at thread/qthread_unix.cpp:349
#10 0x00007fc5e9859182 in start_thread (arg=0x7fc5b6b2e700) at pthread_create.c:312
#11 0x00007fc5ee5d700d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fc5a951c700 (LWP 16627)):
[KCrash Handler]
#6  setColor (sixteenBit=false, data=0x7fc61e34ef0c <error: Cannot access memory at address 0x7fc61e34ef0c>, this=<synthetic pointer>) at /build/buildd/digikam-3.5.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x6d61e38, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.5.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007fc5f21a3a9b in Digikam::LensFunFilter::filterImage (this=0x6d61df0) at /build/buildd/digikam-3.5.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#9  0x00007fc5f2086b6c in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x6d61df0) at /build/buildd/digikam-3.5.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x00007fc5f22335de in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x6d17c40) at /build/buildd/digikam-3.5.0/core/libs/threads/dynamicthread.cpp:186
#11 0x00007fc5ef3abfee in QThreadPoolThread::run (this=0x416c3c0) at concurrent/qthreadpool.cpp:108
#12 0x00007fc5ef3b832f in QThreadPrivate::start (arg=0x416c3c0) at thread/qthread_unix.cpp:349
#13 0x00007fc5e9859182 in start_thread (arg=0x7fc5a951c700) at pthread_create.c:312
#14 0x00007fc5ee5d700d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fc5f4bb3ac0 (LWP 16126)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fc5ef3b8816 in wait (time=18446744073709551615, this=0x29e3660) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2c83400, mutex=mutex@entry=0x2c833d8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fc5ef3ab242 in QThreadPoolPrivate::waitForDone (this=0x2c83350, msecs=msecs@entry=-1) at concurrent/qthreadpool.cpp:295
#4  0x00007fc5ef3ac6b5 in QThreadPool::~QThreadPool (this=0x29e8500, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:438
#5  0x00007fc5ef3ac6e9 in QThreadPool::~QThreadPool (this=0x29e8500, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:440
#6  0x00007fc5ef4d1168 in QObjectPrivate::deleteChildren (this=this@entry=0x28b3a50) at kernel/qobject.cpp:1907
#7  0x00007fc5ef4d36ff in QObject::~QObject (this=0x29e24d0, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#8  0x00007fc5f2230737 in ~ThreadManagerCreator (this=0x29e24d0, __in_chrg=<optimized out>) at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:236
#9  destroy () at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:241
#10 0x00007fc5ee518259 in __run_exit_handlers (status=1, listp=0x7fc5ee89b6c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#11 0x00007fc5ee5182a5 in __GI_exit (status=<optimized out>) at exit.c:104
#12 0x00007fc5eff13878 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:783
#13 0x00007fc5f0bb68d0 in KApplication::xioErrhandler (this=0x7fff49daef40, dpy=0x2465aa0) at ../../kdeui/kernel/kapplication.cpp:419
#14 0x00007fc5ecace5ee in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007fc5ecacbfed in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#16 0x00007fc5ecabe0db in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#17 0x00007fc5eff4e687 in x11EventSourcePrepare (s=0x2464670, timeout=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:77
#18 0x00007fc5e708068d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fc5e7080f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fc5e70810ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fc5ef4e77a1 in QEventDispatcherGlib::processEvents (this=0x238caa0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#22 0x00007fc5eff4ebb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fc5ef4b90af in QEventLoop::processEvents (this=this@entry=0x7fff49daea20, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fc5ef4b93a5 in QEventLoop::exec (this=this@entry=0x7fff49daea20, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fc5ef4beb79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#26 0x00007fc5efeab37c in QApplication::exec () at kernel/qapplication.cpp:3828
#27 0x0000000000492023 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 333523.

An https://bugs.kde.org/ berichten
Comment 26 Georg Schilling 2015-01-15 04:31:51 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-44-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
The flash seems not to be the difference betwenn the picture. At least, I have no clue!

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7ffa96926ac0 (LWP 18656))]

Thread 6 (Thread 0x7ffa71fbb700 (LWP 18658)):
#0  0x00007ffa9033ccbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ffa76b66248 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007ffa8b5cc182 in start_thread (arg=0x7ffa71fbb700) at pthread_create.c:312
#3  0x00007ffa9034a00d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7ffa6b522700 (LWP 18659)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007ffa9112b816 in wait (time=18446744073709551615, this=0x2581a90) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x25819a0, mutex=mutex@entry=0x2581998, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d5ede in Digikam::ScanController::run (this=0x2581710) at /build/buildd/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007ffa9112b32f in QThreadPrivate::start (arg=0x2581710) at thread/qthread_unix.cpp:349
#5  0x00007ffa8b5cc182 in start_thread (arg=0x7ffa6b522700) at pthread_create.c:312
#6  0x00007ffa9034a00d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7ffa6ad21700 (LWP 18660)):
#0  0x00007ffa88df3860 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ffa88df3f52 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffa88df40ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffa9125a7be in QEventDispatcherGlib::processEvents (this=0x7ffa5c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007ffa9122c0af in QEventLoop::processEvents (this=this@entry=0x7ffa6ad20ae0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffa9122c3a5 in QEventLoop::exec (this=this@entry=0x7ffa6ad20ae0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ffa91128c5f in QThread::exec (this=this@entry=0x26936f0) at thread/qthread.cpp:537
#7  0x00007ffa9120d823 in QInotifyFileSystemWatcherEngine::run (this=0x26936f0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007ffa9112b32f in QThreadPrivate::start (arg=0x26936f0) at thread/qthread_unix.cpp:349
#9  0x00007ffa8b5cc182 in start_thread (arg=0x7ffa6ad21700) at pthread_create.c:312
#10 0x00007ffa9034a00d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7ffa58853700 (LWP 18770)):
#0  0x00007ffa9033ccbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ffa88df3fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffa88df40ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffa9125a7be in QEventDispatcherGlib::processEvents (this=0x7ffa540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007ffa9122c0af in QEventLoop::processEvents (this=this@entry=0x7ffa58852ae0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffa9122c3a5 in QEventLoop::exec (this=this@entry=0x7ffa58852ae0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ffa91128c5f in QThread::exec (this=this@entry=0x2ed0ed0) at thread/qthread.cpp:537
#7  0x00007ffa9120d823 in QInotifyFileSystemWatcherEngine::run (this=0x2ed0ed0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007ffa9112b32f in QThreadPrivate::start (arg=0x2ed0ed0) at thread/qthread_unix.cpp:349
#9  0x00007ffa8b5cc182 in start_thread (arg=0x7ffa58853700) at pthread_create.c:312
#10 0x00007ffa9034a00d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7ffa46cdb700 (LWP 19011)):
[KCrash Handler]
#6  setColor (sixteenBit=false, data=0x7ffaa72eff0c <error: Cannot access memory at address 0x7ffaa72eff0c>, this=<synthetic pointer>) at /build/buildd/digikam-3.5.0/core/libs/dimg/dcolorpixelaccess.h:42
#7  Digikam::DImg::getSubPixelColorFast (this=this@entry=0x7005468, x=<optimized out>, y=<optimized out>) at /build/buildd/digikam-3.5.0/core/libs/dimg/dimg.cpp:1391
#8  0x00007ffa93f16a9b in Digikam::LensFunFilter::filterImage (this=0x7005420) at /build/buildd/digikam-3.5.0/core/libs/dimg/filters/lens/lensfunfilter.cpp:196
#9  0x00007ffa93df9b6c in Digikam::DImgThreadedFilter::startFilterDirectly (this=0x7005420) at /build/buildd/digikam-3.5.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:194
#10 0x00007ffa93fa65de in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x6bfec30) at /build/buildd/digikam-3.5.0/core/libs/threads/dynamicthread.cpp:186
#11 0x00007ffa9111efee in QThreadPoolThread::run (this=0x41c1ac0) at concurrent/qthreadpool.cpp:108
#12 0x00007ffa9112b32f in QThreadPrivate::start (arg=0x41c1ac0) at thread/qthread_unix.cpp:349
#13 0x00007ffa8b5cc182 in start_thread (arg=0x7ffa46cdb700) at pthread_create.c:312
#14 0x00007ffa9034a00d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7ffa96926ac0 (LWP 18656)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007ffa9112b816 in wait (time=18446744073709551615, this=0x2931a60) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2cd7940, mutex=mutex@entry=0x2cd7918, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ffa9111e242 in QThreadPoolPrivate::waitForDone (this=0x2cd7890, msecs=msecs@entry=-1) at concurrent/qthreadpool.cpp:295
#4  0x00007ffa9111f6b5 in QThreadPool::~QThreadPool (this=0x2906050, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:438
#5  0x00007ffa9111f6e9 in QThreadPool::~QThreadPool (this=0x2906050, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:440
#6  0x00007ffa91244168 in QObjectPrivate::deleteChildren (this=this@entry=0x2a36cd0) at kernel/qobject.cpp:1907
#7  0x00007ffa912466ff in QObject::~QObject (this=0x2cd84f0, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#8  0x00007ffa93fa3737 in ~ThreadManagerCreator (this=0x2cd84f0, __in_chrg=<optimized out>) at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:236
#9  destroy () at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:241
#10 0x00007ffa9028b259 in __run_exit_handlers (status=1, listp=0x7ffa9060e6c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#11 0x00007ffa9028b2a5 in __GI_exit (status=<optimized out>) at exit.c:104
#12 0x00007ffa91c86878 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:783
#13 0x00007ffa929298d0 in KApplication::xioErrhandler (this=0x7fffeec44750, dpy=0x24b9aa0) at ../../kdeui/kernel/kapplication.cpp:419
#14 0x00007ffa8e8415ee in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007ffa8e83efed in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#16 0x00007ffa8e8310db in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#17 0x00007ffa91cc162c in x11EventSourceCheck (s=0x24b8670) at kernel/qguieventdispatcher_glib.cpp:85
#18 0x00007ffa88df3a61 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007ffa88df3f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007ffa88df40ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007ffa9125a7a1 in QEventDispatcherGlib::processEvents (this=0x23e0aa0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#22 0x00007ffa91cc1bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007ffa9122c0af in QEventLoop::processEvents (this=this@entry=0x7fffeec44230, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007ffa9122c3a5 in QEventLoop::exec (this=this@entry=0x7fffeec44230, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007ffa91231b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#26 0x00007ffa91c1e37c in QApplication::exec () at kernel/qapplication.cpp:3828
#27 0x0000000000492023 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 333523.

An https://bugs.kde.org/ berichten
Comment 27 caulier.gilles 2015-03-15 22:26:40 UTC
Git commit a0ea63613faf5062e6891eb12d53b334b1babc4a by Gilles Caulier.
Committed on 15/03/2015 at 23:21.
Pushed by cgilles into branch 'master'.

Apply patch # 91573 from Maik Qualmann to wrap image pixel positions to image sizes when Lens Corrections are applied by LensFun.
Related: bug 333540, bug 345168
FIXED-IN: 4.9.0

M  +4    -1    NEWS
M  +22   -13   libs/dimg/dimg.cpp

http://commits.kde.org/digikam/a0ea63613faf5062e6891eb12d53b334b1babc4a
Comment 28 caulier.gilles 2015-03-15 22:49:08 UTC
Git commit 53fd2de987febf552103de3ecc910a4d9c94c0d2 by Gilles Caulier.
Committed on 15/03/2015 at 22:47.
Pushed by cgilles into branch 'frameworks'.

backport commit #a0ea63613faf5062e6891eb12d53b334b1babc4a from git/master to frameworks branch
Related: bug 333540, bug 345168

M  +16   -7    libs/dimg/dimg.cpp

http://commits.kde.org/digikam/53fd2de987febf552103de3ecc910a4d9c94c0d2