Bug 332689 - Dolphin crashed when i trying to delete a_file.c
Summary: Dolphin crashed when i trying to delete a_file.c
Status: RESOLVED DUPLICATE of bug 278431
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.5
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-03-27 14:56 UTC by Louis
Modified: 2014-03-27 15:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Louis 2014-03-27 14:56:17 UTC
Application: dolphin (4.11.5)
KDE Platform Version: 4.11.5
Qt Version: 4.8.4
Operating System: Linux 3.11.0-18-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
When i tried to delete a file.c Dolphin just crashed.

THX4 ALL

The crash does not seem to be reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb122b740 (LWP 3095))]

Thread 3 (Thread 0xadd35b40 (LWP 3099)):
#0  0xb4c3c86e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4c3cbe8 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4bf954f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4bf9afa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4bf9ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb599b8df in QEventDispatcherGlib::processEvents (this=0xad400468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb596a9f3 in QEventLoop::processEvents (this=this@entry=0xadd35228, flags=...) at kernel/qeventloop.cpp:149
#7  0xb596ad19 in QEventLoop::exec (this=this@entry=0xadd35228, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5859e3d in QThread::exec (this=this@entry=0x92f3aa0) at thread/qthread.cpp:542
#9  0xb594ae14 in QInotifyFileSystemWatcherEngine::run (this=0x92f3aa0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb585c72f in QThreadPrivate::start (arg=0x92f3aa0) at thread/qthread_unix.cpp:338
#11 0xb4cd7d78 in start_thread (arg=0xadd35b40) at pthread_create.c:311
#12 0xb765a01e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 2 (Thread 0xad2b0b40 (LWP 3100)):
#0  0xb77ce424 in __kernel_vsyscall ()
#1  0xb766d4d2 in clock_gettime (clock_id=1, tp=0xad2affc8) at ../sysdeps/unix/clock_gettime.c:115
#2  0xb58b73ec in do_gettime (frac=0xad2affc0, sec=0xad2affb8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0xb599cfd2 in updateCurrentTime (this=0xac902074) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0xac902074, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0xb599b67b in timerSourcePrepareHelper (src=<optimized out>, timeout=0xad2b00bc) at kernel/qeventdispatcher_glib.cpp:136
#7  0xb599b70d in timerSourcePrepare (source=0xac902040, timeout=0xad2b00bc) at kernel/qeventdispatcher_glib.cpp:169
#8  0xb4bf9143 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb4bf9a5f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb4bf9ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb599b8df in QEventDispatcherGlib::processEvents (this=0xac900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0xb596a9f3 in QEventLoop::processEvents (this=this@entry=0xad2b0228, flags=...) at kernel/qeventloop.cpp:149
#13 0xb596ad19 in QEventLoop::exec (this=this@entry=0xad2b0228, flags=...) at kernel/qeventloop.cpp:204
#14 0xb5859e3d in QThread::exec (this=this@entry=0x9548710) at thread/qthread.cpp:542
#15 0xb594ae14 in QInotifyFileSystemWatcherEngine::run (this=0x9548710) at io/qfilesystemwatcher_inotify.cpp:265
#16 0xb585c72f in QThreadPrivate::start (arg=0x9548710) at thread/qthread_unix.cpp:338
#17 0xb4cd7d78 in start_thread (arg=0xad2b0b40) at pthread_create.c:311
#18 0xb765a01e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xb122b740 (LWP 3095)):
[KCrash Handler]
#7  QList (l=..., this=0xbf9fc7a0) at /usr/include/qt4/QtCore/qlist.h:122
#8  QForeachContainer (t=..., this=0xbf9fc7a0) at /usr/include/qt4/QtCore/qglobal.h:2367
#9  KDirLister::Private::cachedItemsJobForUrl (this=0x0, url=...) at ../../kio/kio/kdirlister.cpp:281
#10 0xb6d7fe21 in KDirListerCache::updateDirectory (this=0x91478d8, _dir=...) at ../../kio/kio/kdirlister.cpp:694
#11 0xb6d81057 in KDirListerCache::slotFilesAdded (this=0x91478d8, dir=...) at ../../kio/kio/kdirlister.cpp:866
#12 0xb6d8361f in KDirListerCache::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbf9fc9e8, _c=<optimized out>) at ./kdirlister_p.moc:74
#13 0xb5980fc7 in QMetaObject::activate (sender=sender@entry=0x932fd90, m=m@entry=0xb6f1fab8 <OrgKdeKDirNotifyInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0xbf9fc9e8) at kernel/qobject.cpp:3539
#14 0xb6d8ff95 in OrgKdeKDirNotifyInterface::FilesAdded (this=this@entry=0x932fd90, _t1=...) at ./kdirnotify.moc:131
#15 0xb6d90187 in OrgKdeKDirNotifyInterface::qt_static_metacall (_o=_o@entry=0x932fd90, _id=_id@entry=2, _a=_a@entry=0xbf9fcb0c, _c=QMetaObject::InvokeMetaMethod) at ./kdirnotify.moc:64
#16 0xb6d90763 in qt_static_metacall (_a=0xbf9fcb0c, _id=2, _c=QMetaObject::InvokeMetaMethod, _o=0x932fd90) at ./kdirnotify.moc:106
#17 OrgKdeKDirNotifyInterface::qt_metacall (this=0x932fd90, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf9fcb0c) at ./kdirnotify.moc:107
#18 0xb5798ebe in QDBusConnectionPrivate::deliverCall (this=0x918c2a8, object=object@entry=0x932fd90, msg=..., metaTypes=..., slotIdx=7) at qdbusintegrator.cpp:951
#19 0xb57a1f3d in QDBusCallDeliveryEvent::placeMetaCall (this=0x987f448, object=0x932fd90) at qdbusintegrator_p.h:103
#20 0xb598558b in QObject::event (this=0x932fd90, e=0x987f448) at kernel/qobject.cpp:1194
#21 0xb5ec7744 in QApplicationPrivate::notify_helper (this=0x9148188, receiver=0x932fd90, e=0x987f448) at kernel/qapplication.cpp:4567
#22 0xb5ece223 in QApplication::notify (this=0xbf9fd1b0, receiver=receiver@entry=0x932fd90, e=e@entry=0x987f448) at kernel/qapplication.cpp:4353
#23 0xb6a15ff4 in KApplication::notify (this=0xbf9fd1b0, receiver=0x932fd90, event=0x987f448) at ../../kdeui/kernel/kapplication.cpp:311
#24 0xb596beda in QCoreApplication::notifyInternal (this=0xbf9fd1b0, receiver=receiver@entry=0x932fd90, event=event@entry=0x987f448) at kernel/qcoreapplication.cpp:946
#25 0xb596f6ad in sendEvent (event=0x987f448, receiver=0x932fd90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x911f018) at kernel/qcoreapplication.cpp:1570
#27 0xb596fbbc in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#28 0xb599bf6e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#29 postEventSourceDispatch (s=0x9147e18) at kernel/qeventdispatcher_glib.cpp:279
#30 0xb4bf983e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb4bf9be8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb4bf9ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb599b8bf in QEventDispatcherGlib::processEvents (this=this@entry=0x911fd88, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0xb5f7c32e in QGuiEventDispatcherGlib::processEvents (this=0x911fd88, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0xb596a9f3 in QEventLoop::processEvents (this=this@entry=0xbf9fd0d8, flags=...) at kernel/qeventloop.cpp:149
#36 0xb596ad19 in QEventLoop::exec (this=this@entry=0xbf9fd0d8, flags=...) at kernel/qeventloop.cpp:204
#37 0xb597089e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#38 0xb5ec5974 in QApplication::exec () at kernel/qapplication.cpp:3828
#39 0xb7774c3a in kdemain (argc=5, argv=0xbf9fd294) at ../../../dolphin/src/main.cpp:93
#40 0x0804855b in main (argc=5, argv=0xbf9fd294) at dolphin_dummy.cpp:3

The reporter indicates this bug may be a duplicate of or related to bug 329482.

Possible duplicates by query: bug 331684, bug 329482, bug 326697, bug 325757, bug 322130.

Reported using DrKonqi
Comment 1 Emmanuel Pescosta 2014-03-27 15:01:04 UTC
Thanks for the bug report!

There are already bugs reported, which have a similar backtrace, so I'll mark this report as a duplicate.

*** This bug has been marked as a duplicate of bug 278431 ***