Bug 278431 - KDirListerCache crash when trashing a file and the trash is empty
Summary: KDirListerCache crash when trashing a file and the trash is empty
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9.0
Platform: Ubuntu Packages Linux
: NOR crash with 40 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 273010 282237 285062 287396 287939 291576 294830 300797 305035 311055 311237 314807 315800 316953 317431 317840 320664 320734 321634 321635 322130 322658 324353 325757 326697 329482 329517 331684 332387 332689 333473 334208 334519 335507 335856 336284 337677 345902 347475 347742 348065 348094 348237 349563 350369 350879 354859 363908 366404 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-25 00:37 UTC by Dan
Modified: 2016-12-25 11:23 UTC (History)
47 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.14.17


Attachments
New crash information added by DrKonqi (12.13 KB, text/plain)
2012-05-23 23:32 UTC, D3v3L0per212
Details
New crash information added by DrKonqi (8.48 KB, text/plain)
2012-10-21 10:49 UTC, Krzysiek
Details
Valgrind trace (11.41 KB, text/plain)
2013-10-13 19:53 UTC, mathieu.beliveau.1
Details
New crash information added by DrKonqi (14.52 KB, text/plain)
2014-04-22 04:08 UTC, Zach
Details
New crash information added by DrKonqi (10.82 KB, text/plain)
2014-04-25 16:00 UTC, antonio
Details
New crash information added by DrKonqi (10.38 KB, text/plain)
2015-08-16 19:02 UTC, Koraq
Details
New crash information added by DrKonqi (27.24 KB, text/plain)
2015-08-28 13:29 UTC, Koraq
Details
New crash information added by DrKonqi (5.49 KB, text/plain)
2015-09-19 17:37 UTC, contact
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2011-07-25 00:37:53 UTC
Application: dolphin (1.6.1)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Linux Mint 11 Katya

-- Information about the crash:
- What I was doing when the application crashed:
Opened Dolphin
Opened Shares
Opened Windows Server
Selected volume and folder
Clicked on a file and dragged it to the Trash icon on the left panel
Kaboom!

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5d8c296780 (LWP 7082))]

Thread 3 (Thread 0x7f5d7dba4700 (LWP 7083)):
#0  0x00007f5d8bb87f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5d84322104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5d843229f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5d7e503c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f5d843493e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5d847edd8c in start_thread (arg=0x7f5d7dba4700) at pthread_create.c:304
#6  0x00007f5d8bb9504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5d6b79e700 (LWP 7089)):
#0  0x00007f5d847f1d9d in __pthread_mutex_unlock_usercnt (mutex=0x7f5d78008128) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f5d78008128) at pthread_mutex_unlock.c:290
#2  0x00007f5d84321094 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5d84321f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5d84322639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5d88009446 in QEventDispatcherGlib::processEvents (this=0x7f5d78005ae0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f5d87fdd882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f5d87fddabc in QEventLoop::exec (this=0x7f5d6b79ddd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f5d87ef4924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#9  0x00007f5d87fbfc2f in QInotifyFileSystemWatcherEngine::run (this=0x1578380) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f5d87ef7175 in QThreadPrivate::start (arg=0x1578380) at thread/qthread_unix.cpp:320
#11 0x00007f5d847edd8c in start_thread (arg=0x7f5d6b79e700) at pthread_create.c:304
#12 0x00007f5d8bb9504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5d8c296780 (LWP 7082)):
[KCrash Handler]
#6  QList (this=0x50, url=...) at /usr/include/qt4/QtCore/qlist.h:118
#7  QForeachContainer (this=0x50, url=...) at /usr/include/qt4/QtCore/qglobal.h:2250
#8  KDirLister::Private::cachedItemsJobForUrl (this=0x50, url=...) at ../../kio/kio/kdirlister.cpp:281
#9  0x00007f5d89bf92b7 in KDirListerCache::updateDirectory (this=0x159f7f0, _dir=...) at ../../kio/kio/kdirlister.cpp:675
#10 0x00007f5d89bfad6d in KDirListerCache::slotFilesAdded (this=0x159f7f0, dir=<value optimized out>) at ../../kio/kio/kdirlister.cpp:844
#11 0x00007f5d89bfeab0 in KDirListerCache::qt_metacall (this=0x159f7f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffce559c0) at ./kdirlister_p.moc:97
#12 0x00007f5d87ff35f8 in QMetaObject::activate (sender=0x15929f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffce559c0) at kernel/qobject.cpp:3287
#13 0x00007f5d89c0b4a5 in OrgKdeKDirNotifyInterface::FilesAdded (this=<value optimized out>, _t1=<value optimized out>) at ./kdirnotify.moc:117
#14 0x00007f5d89c0b650 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x15929f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffce55b90) at ./kdirnotify.moc:87
#15 0x00007f5d87c2c9fa in QDBusConnectionPrivate::deliverCall (this=0x12e2fc0, object=0x15929f0, msg=..., metaTypes=..., slotIdx=7) at qdbusintegrator.cpp:942
#16 0x00007f5d87c36e4f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#17 0x00007f5d87ff249a in QObject::event (this=0x15929f0, e=<value optimized out>) at kernel/qobject.cpp:1226
#18 0x00007f5d8899d9f4 in QApplicationPrivate::notify_helper (this=0x12f04f0, receiver=0x15929f0, e=0x19ad240) at kernel/qapplication.cpp:4462
#19 0x00007f5d889a23ba in QApplication::notify (this=<value optimized out>, receiver=0x15929f0, e=0x19ad240) at kernel/qapplication.cpp:4341
#20 0x00007f5d896c0866 in KApplication::notify (this=0x7ffffce565e0, receiver=0x15929f0, event=0x19ad240) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007f5d87fde49c in QCoreApplication::notifyInternal (this=0x7ffffce565e0, receiver=0x15929f0, event=0x19ad240) at kernel/qcoreapplication.cpp:731
#22 0x00007f5d87fe1c25 in sendEvent (receiver=0x0, event_type=0, data=0x12a25d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x12a25d0) at kernel/qcoreapplication.cpp:1372
#24 0x00007f5d88009253 in sendPostedEvents (s=0x12f2e30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0x12f2e30) at kernel/qeventdispatcher_glib.cpp:277
#26 0x00007f5d84321bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f5d843223a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f5d84322639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f5d880093ef in QEventDispatcherGlib::processEvents (this=0x12a1db0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007f5d88a474de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f5d87fdd882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f5d87fddabc in QEventLoop::exec (this=0x7ffffce56570, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f5d87fe1ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#34 0x00007f5d8be85995 in kdemain (argc=3, argv=0x7ffffce56b08) at ../../../dolphin/src/main.cpp:98
#35 0x00007f5d8bacdeff in __libc_start_main (main=0x400730 <main(int, char**)>, argc=3, ubp_av=0x7ffffce56b08, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7ffffce56af8) at libc-start.c:226
#36 0x0000000000400659 in _start ()

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-09-18 19:38:53 UTC
*** Bug 282237 has been marked as a duplicate of this bug. ***
Comment 2 Myriam Schweingruber 2011-09-18 19:39:34 UTC
Changing status to NEW, confirmed by duplicate.
Comment 3 Jekyll Wu 2011-11-23 23:06:24 UTC
*** Bug 287396 has been marked as a duplicate of this bug. ***
Comment 4 Myriam Schweingruber 2011-12-07 13:25:29 UTC
*** Bug 287939 has been marked as a duplicate of this bug. ***
Comment 5 Jekyll Wu 2011-12-10 03:44:51 UTC
*** Bug 285062 has been marked as a duplicate of this bug. ***
Comment 6 Thijs 2011-12-13 17:48:07 UTC
*** Bug 273010 has been marked as a duplicate of this bug. ***
Comment 7 Dawit Alemayehu 2012-01-28 20:15:54 UTC
*** Bug 291576 has been marked as a duplicate of this bug. ***
Comment 8 D3v3L0per212 2012-05-23 23:32:59 UTC
Created attachment 71331 [details]
New crash information added by DrKonqi

krunner (0.1) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

Application: Run Command Interface (krunner), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xafddca40 (LWP 2282))]

Thread 2 (Thread 0xad818b40 (LWP 2291)):
#0  0xb2b8edcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb5b6d315 in do_gettime (frac=0xad817f00, sec=0xad817ef8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb5c57226 in QTimerInfoList::updateCurrentTime (this=0xacf0207c) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb5c5757a in QTimerInfoList::timerWait (this=0xacf0207c, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb5c55e23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xad81800c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb5c55ebd in timerSourcePrepare (source=0xacf02048, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2d52762 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2d52f6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2d531c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb5c568e7 in QEventDispatcherGlib::processEvents (this=0xacf00480, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb5c2250d in QEventLoop::processEvents (this=0xad818190, flags=...) at kernel/qeventloop.cpp:149
#12 0xb5c227a9 in QEventLoop::exec (this=0xad818190, flags=...) at kernel/qeventloop.cpp:204
#13 0xb5b0b94c in QThread::exec (this=0x8f98830) at thread/qthread.cpp:501
#14 0xb5bffb5d in QInotifyFileSystemWatcherEngine::run (this=0x8f98830) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb5b0ede0 in QThreadPrivate::start (arg=0x8f98830) at thread/qthread_unix.cpp:298
#16 0xb2278a11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#17 0x5c8b0824 in ?? ()
#18 0xbab80424 in ?? ()
#19 0x65000000 in ?? ()
#20 0x001015ff in ?? ()
#21 0xd3890000 in ?? ()
#22 0xfff0013d in ?? ()
#23 0xc30173ff in ?? ()
#24 0x0f8122e8 in ?? ()
#25 0x9fc18100 in ?? ()
#26 0x8b001724 in ?? ()
#27 0xffff0889 in ?? ()
#28 0x29d231ff in ?? ()
#29 0x0d0365c2 in ?? ()
#30 0x00000000 in ?? ()

Thread 1 (Thread 0xafddca40 (LWP 2282)):
[KCrash Handler]
#7  QList (this=0xbf9e6418, l=...) at /usr/include/qt4/QtCore/qlist.h:122
#8  QForeachContainer (t=..., this=0xbf9e6418) at /usr/include/qt4/QtCore/qglobal.h:2340
#9  KDirLister::Private::cachedItemsJobForUrl (this=0x10, url=...) at ../../kio/kio/kdirlister.cpp:277
#10 0xb5431bb0 in KDirListerCache::updateDirectory (this=0x933bf18, _dir=...) at ../../kio/kio/kdirlister.cpp:680
#11 0xb5437154 in KDirListerCache::slotFilesAdded (this=0x933bf18, dir=...) at ../../kio/kio/kdirlister.cpp:849
#12 0xb5c3a6b1 in QMetaObject::activate (sender=0x9357ae0, m=0xb55e7a98, local_signal_index=2, argv=0xbf9e6758) at kernel/qobject.cpp:3547
#13 0xb5445425 in OrgKdeKDirNotifyInterface::FilesAdded (this=0x9357ae0, _t1=...) at ./kdirnotify.moc:131
#14 0xb5445607 in qt_static_metacall (_a=0xbf9e689c, _id=2, _o=0x9357ae0, _c=<optimized out>) at ./kdirnotify.moc:64
#15 OrgKdeKDirNotifyInterface::qt_static_metacall (_o=0x9357ae0, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf9e689c) at ./kdirnotify.moc:56
#16 0xb54456fc in OrgKdeKDirNotifyInterface::qt_metacall (this=0x9357ae0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e689c) at ./kdirnotify.moc:107
#17 0xb5a46a38 in QDBusConnectionPrivate::deliverCall (this=0x8f83cd0, object=0x9357ae0, msg=..., metaTypes=..., slotIdx=16) at qdbusintegrator.cpp:947
#18 0xb5a50c8d in QDBusCallDeliveryEvent::placeMetaCall (this=0x93b1158, object=0x9357ae0) at qdbusintegrator_p.h:103
#19 0xb5c3ec7b in QObject::event (this=0x9357ae0, e=0x93b1158) at kernel/qobject.cpp:1195
#20 0xb618bed4 in notify_helper (e=0x93b1158, receiver=0x9357ae0, this=0x8f931c0) at kernel/qapplication.cpp:4559
#21 QApplicationPrivate::notify_helper (this=0x8f931c0, receiver=0x9357ae0, e=0x93b1158) at kernel/qapplication.cpp:4531
#22 0xb619130d in QApplication::notify (this=0x93b1158, receiver=0x9357ae0, e=0x93b1158) at kernel/qapplication.cpp:4288
#23 0xb6ee6b21 in KApplication::notify (this=0x8f8a0b0, receiver=0x9357ae0, event=0x93b1158) at ../../kdeui/kernel/kapplication.cpp:311
#24 0xb5c2397e in QCoreApplication::notifyInternal (this=0x8f8a0b0, receiver=0x9357ae0, event=0x93b1158) at kernel/qcoreapplication.cpp:876
#25 0xb5c27ad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8f04130) at kernel/qcoreapplication.cpp:1500
#27 0xb5c27e0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#28 0xb5c56494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#29 postEventSourceDispatch (s=0x8f93f80) at kernel/qeventdispatcher_glib.cpp:279
#30 0xb2d52cda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb2d530e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb2d531c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb5c56887 in QEventDispatcherGlib::processEvents (this=0x8f04ea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0xb6244aaa in QGuiEventDispatcherGlib::processEvents (this=0x8f04ea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0xb5c2250d in QEventLoop::processEvents (this=0xbf9e7044, flags=...) at kernel/qeventloop.cpp:149
#36 0xb5c227a9 in QEventLoop::exec (this=0xbf9e7044, flags=...) at kernel/qeventloop.cpp:204
#37 0xb5c27eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#38 0xb6189a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#39 0xb76b75b6 in kdemain (argc=1, argv=0xbf9e71f4) at ../../krunner/main.cpp:66
#40 0x0804850b in main (argc=1, argv=0xbf9e71f4) at krunner_dummy.cpp:3

-- Backtrace (Reduced):
#7  QList (this=0xbf9e6418, l=...) at /usr/include/qt4/QtCore/qlist.h:122
#8  QForeachContainer (t=..., this=0xbf9e6418) at /usr/include/qt4/QtCore/qglobal.h:2340
#9  KDirLister::Private::cachedItemsJobForUrl (this=0x10, url=...) at ../../kio/kio/kdirlister.cpp:277
#10 0xb5431bb0 in KDirListerCache::updateDirectory (this=0x933bf18, _dir=...) at ../../kio/kio/kdirlister.cpp:680
#11 0xb5437154 in KDirListerCache::slotFilesAdded (this=0x933bf18, dir=...) at ../../kio/kio/kdirlister.cpp:849
Comment 9 Peter Penz 2012-05-29 10:49:57 UTC
*** Bug 300797 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2012-08-20 05:19:43 UTC
*** Bug 294830 has been marked as a duplicate of this bug. ***
Comment 11 Jekyll Wu 2012-08-20 05:20:14 UTC
*** Bug 305035 has been marked as a duplicate of this bug. ***
Comment 12 Krzysiek 2012-10-21 10:49:09 UTC
Created attachment 74690 [details]
New crash information added by DrKonqi

dolphin (2.1) on KDE Platform 4.9.2 using Qt 4.8.2

- What I was doing when the application crashed:

I've mounted memory card
Tried to remove some files by delete key
Nothing was happening
Tried remove by move to trash
Kaboom?

-- Backtrace (Reduced):
#7  0x44be1c77 in QList (l=..., this=0xbfe500a0) at /usr/include/QtCore/qlist.h:122
#8  QForeachContainer (t=..., this=0xbfe500a0) at /usr/include/QtCore/qglobal.h:2344
#9  KDirLister::Private::cachedItemsJobForUrl (this=0x200072, url=...) at /usr/src/debug/kdelibs-4.9.2/kio/kio/kdirlister.cpp:277
#10 0x44be8fd8 in KDirListerCache::updateDirectory (this=this@entry=0x878a998, _dir=...) at /usr/src/debug/kdelibs-4.9.2/kio/kio/kdirlister.cpp:680
#11 0x44bebf28 in KDirListerCache::slotFilesAdded (this=0x878a998, dir=...) at /usr/src/debug/kdelibs-4.9.2/kio/kio/kdirlister.cpp:849
Comment 13 Frank Reininghaus 2012-12-03 09:20:02 UTC
*** Bug 311055 has been marked as a duplicate of this bug. ***
Comment 14 Frank Reininghaus 2012-12-03 09:21:01 UTC
According to the information provided in some of the duplicates, this crash happens if the maximum capacity of the Trash has been reached.
Comment 15 Frank Reininghaus 2012-12-06 06:49:29 UTC
*** Bug 311237 has been marked as a duplicate of this bug. ***
Comment 16 Jekyll Wu 2013-02-10 07:17:15 UTC
*** Bug 314807 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2013-02-28 14:09:02 UTC
*** Bug 315800 has been marked as a duplicate of this bug. ***
Comment 18 Frank Reininghaus 2013-03-18 13:24:07 UTC
*** Bug 316953 has been marked as a duplicate of this bug. ***
Comment 19 Frank Reininghaus 2013-03-28 09:00:18 UTC
*** Bug 317431 has been marked as a duplicate of this bug. ***
Comment 20 Frank Reininghaus 2013-04-05 07:53:45 UTC
*** Bug 317840 has been marked as a duplicate of this bug. ***
Comment 21 Frank Reininghaus 2013-06-03 16:01:28 UTC
*** Bug 320664 has been marked as a duplicate of this bug. ***
Comment 22 Frank Reininghaus 2013-06-03 16:10:22 UTC
*** Bug 320664 has been marked as a duplicate of this bug. ***
Comment 23 Jekyll Wu 2013-06-05 01:56:19 UTC
*** Bug 320734 has been marked as a duplicate of this bug. ***
Comment 24 Jekyll Wu 2013-06-26 14:33:09 UTC
*** Bug 321634 has been marked as a duplicate of this bug. ***
Comment 25 Jekyll Wu 2013-06-26 14:33:24 UTC
*** Bug 321635 has been marked as a duplicate of this bug. ***
Comment 26 Frank Reininghaus 2013-07-09 07:52:39 UTC
*** Bug 322130 has been marked as a duplicate of this bug. ***
Comment 27 Frank Reininghaus 2013-09-03 11:34:26 UTC
*** Bug 324353 has been marked as a duplicate of this bug. ***
Comment 28 Frank Reininghaus 2013-10-08 07:41:16 UTC
*** Bug 325757 has been marked as a duplicate of this bug. ***
Comment 29 Frank Reininghaus 2013-10-08 07:49:32 UTC
I'm not quite sure (because I'm not really familiar with the KDirListerCache code), but looks like the root cause of the crash is not visible in the backtrace because it happened earlier. In that case, maybe it would help if anyone who can reproduce the crash reliably and who has debugging packages installed, such that line numbers appear in the backtrace, like the "680" at the end of the line

#10 0xb5431bb0 in KDirListerCache::updateDirectory (this=0x933bf18, _dir=...) at ../../kio/kio/kdirlister.cpp:680,

could try to get a Valgrind log and attach it here. See

http://community.kde.org/Dolphin/FAQ/Crashes

further information. Thanks for your help!
Comment 30 mathieu.beliveau.1 2013-10-13 19:53:20 UTC
Created attachment 82834 [details]
Valgrind trace

I can consistently reproduce this bug, here are the steps:

- Used autofs to create a mounted share at: /home/my_user/nas
- In dolphin: empty the trash then delete a file or directory within /home/my_user/ (any location within my home folder will do - NOT ONLY the cifs share.)

Result: dolphin crashes.

Note that the crash does not happend if either the trash is not empty or is autofs has been stopped.

Attached is the valgrind trace of the bug.

Hope it helps!
Comment 31 Frank Reininghaus 2013-10-16 21:11:51 UTC
(In reply to comment #30)
> Created attachment 82834 [details]
> Valgrind trace

Thanks!

==18474== Invalid read of size 8
==18474==    at 0x7422BD0: KDirListerCache::updateDirectory(KUrl const&) (kdirlister.cpp:694)
==18474==    by 0x7423BEA: KDirListerCache::slotFilesAdded(QString const&) (kdirlister.cpp:866)
==18474==    by 0x9344A57: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (in /usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.4)
==18474==    by 0x7431B64: OrgKdeKDirNotifyInterface::FilesAdded(QString const&) (kdirnotify.moc:131)
==18474==    by 0x74321C2: OrgKdeKDirNotifyInterface::qt_metacall(QMetaObject::Call, int, void**) (kdirnotify.moc:106)
==18474==    by 0x96BAE35: QDBusConnectionPrivate::deliverCall(QObject*, int, QDBusMessage const&, QList<int> const&, int) (in /usr/lib/x86_64-linux-gnu/libQtDBus.so.4.8.4)
==18474==    by 0x9348DCD: QObject::event(QEvent*) (in /usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.4)
==18474==    by 0x820CDFB: QApplicationPrivate::notify_helper(QObject*, QEvent*) (in /usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.4)
==18474==    by 0x821346F: QApplication::notify(QObject*, QEvent*) (in /usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.4)
==18474==    by 0x7C1DA69: KApplication::notify(QObject*, QEvent*) (kapplication.cpp:311)
==18474==    by 0x93308BC: QCoreApplication::notifyInternal(QObject*, QEvent*) (in /usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.4)
==18474==    by 0x9333E1E: QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (in /usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.4)
==18474==  Address 0x1923dc00 is not stack'd, malloc'd or (recently) free'd

This invalid read happens just before the crash. The information that the address is "not stack'd, malloc'd or (recently) free'd" at least tells us that we don't access a dangling pointer.

I'm afraid I can't say much more about this issue now - help from someone with good knowledge of KDirListerCache might be helpful.
Comment 32 Frank Reininghaus 2013-10-27 07:51:33 UTC
*** Bug 326697 has been marked as a duplicate of this bug. ***
Comment 33 Myriam Schweingruber 2014-01-03 01:24:35 UTC
*** Bug 329517 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2014-02-08 20:54:01 UTC
*** Bug 322658 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2014-02-08 20:55:46 UTC
*** Bug 329482 has been marked as a duplicate of this bug. ***
Comment 36 Frank Reininghaus 2014-03-03 09:04:29 UTC
*** Bug 331684 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2014-03-22 19:46:16 UTC
*** Bug 332387 has been marked as a duplicate of this bug. ***
Comment 38 Emmanuel Pescosta 2014-03-27 15:01:04 UTC
*** Bug 332689 has been marked as a duplicate of this bug. ***
Comment 39 Zach 2014-04-22 04:08:52 UTC
Created attachment 86205 [details]
New crash information added by DrKonqi

krunner (4.11.5) on KDE Platform 4.11.5 using Qt 4.8.5

- What I was doing when the application crashed: Trying to delete a faily large file appears to cause KDE to crash. Small text files work fine though.

-- Backtrace (Reduced):
#7  QList (l=..., this=0xbf86bce0) at /usr/include/QtCore/qlist.h:122
#8  QForeachContainer (t=..., this=0xbf86bce0) at /usr/include/QtCore/qglobal.h:2368
#9  KDirLister::Private::cachedItemsJobForUrl (this=0x10, url=...) at /usr/src/debug/kdelibs-4.11.5/kio/kio/kdirlister.cpp:281
#10 0xb3894551 in KDirListerCache::updateDirectory (this=0x8398a00, _dir=...) at /usr/src/debug/kdelibs-4.11.5/kio/kio/kdirlister.cpp:694
#11 0xb38956e7 in KDirListerCache::slotFilesAdded (this=0x8398a00, dir=...) at /usr/src/debug/kdelibs-4.11.5/kio/kio/kdirlister.cpp:866
Comment 40 antonio 2014-04-25 16:00:59 UTC
Created attachment 86265 [details]
New crash information added by DrKonqi

dolphin (4.13.0) on KDE Platform 4.13.0 using Qt 4.8.6

- What I was doing when the application crashed:
with dolphin delete file. trash don't work. Trash segnaled full.its impossibile.
italiano:
cancellando con dolphin un file  si è verificato il crash.Segnalo che il cestino(Trash) segnalava di essere pieno ed ho avuto problemi per riuscire a svuotarlo.

-- Backtrace (Reduced):
#6  QList (l=..., this=0x7fffe469ee60) at /usr/include/qt4/QtCore/qlist.h:122
#7  QForeachContainer (t=..., this=0x7fffe469ee60) at /usr/include/qt4/QtCore/qglobal.h:2377
#8  KDirLister::Private::cachedItemsJobForUrl (this=0x20, url=...) at ../../kio/kio/kdirlister.cpp:281
#9  0x00007f047bd0c169 in KDirListerCache::updateDirectory (this=this@entry=0x2060410, _dir=...) at ../../kio/kio/kdirlister.cpp:694
#10 0x00007f047bd0d17b in KDirListerCache::slotFilesAdded (this=0x2060410, dir=...) at ../../kio/kio/kdirlister.cpp:866
Comment 41 Christoph Feck 2014-04-29 10:32:35 UTC
*** Bug 333473 has been marked as a duplicate of this bug. ***
Comment 42 Frank Reininghaus 2014-05-02 13:23:28 UTC
*** Bug 334208 has been marked as a duplicate of this bug. ***
Comment 43 Frank Reininghaus 2014-05-08 15:28:12 UTC
*** Bug 334519 has been marked as a duplicate of this bug. ***
Comment 44 Christoph Feck 2014-05-29 10:46:32 UTC
*** Bug 335507 has been marked as a duplicate of this bug. ***
Comment 45 edsw 2014-05-29 15:06:38 UTC
wie oft bekomme ich diese mail noch???
habe sie fast 10x bekommen.

how often do i get this email?
i received it about 10 time


Am 29.05.2014 10:46, schrieb Christoph Feck:
> https://bugs.kde.org/show_bug.cgi?id=278431
>
> Christoph Feck <christoph@maxiom.de> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |p.daniels1982@gmail.com
>
> --- Comment #44 from Christoph Feck <christoph@maxiom.de> ---
> *** Bug 335507 has been marked as a duplicate of this bug. ***
>
Comment 46 Christoph Feck 2014-05-29 16:01:30 UTC
Until you remove yourself from the CC list.
Comment 47 Christoph Feck 2014-06-06 09:18:59 UTC
*** Bug 335856 has been marked as a duplicate of this bug. ***
Comment 48 Jekyll Wu 2014-06-16 00:51:52 UTC
*** Bug 336284 has been marked as a duplicate of this bug. ***
Comment 49 Christoph Feck 2014-07-22 03:57:42 UTC
*** Bug 337677 has been marked as a duplicate of this bug. ***
Comment 50 Arjun AK 2014-12-27 13:26:18 UTC
One way to reproduce this is to:
1. Empty your trash.
2. Create a duplicate trash ("trash:/") entry in dolphin's places panel.
3. Delete a file

Possibly related: https://bugs.kde.org/show_bug.cgi?id=252483
Comment 51 Axel Krebs 2014-12-28 07:38:10 UTC
thank you for information :-) !

Am 27.12.2014 um 14:26 schrieb Arjun AK:
> https://bugs.kde.org/show_bug.cgi?id=278431
>
> Arjun AK <arjunak234@gmail.com> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |arjunak234@gmail.com
>
> --- Comment #50 from Arjun AK <arjunak234@gmail.com> ---
> One way to reproduce this is to:
> 1. Empty your trash.
> 2. Create a duplicate trash ("trash:/") entry in dolphin's places panel.
> 3. Delete a file
>
> Possibly related: https://bugs.kde.org/show_bug.cgi?id=252483
>
Comment 52 Christoph Feck 2015-04-16 19:50:46 UTC
*** Bug 345902 has been marked as a duplicate of this bug. ***
Comment 53 Frank Reininghaus 2015-05-10 08:01:21 UTC
*** Bug 347475 has been marked as a duplicate of this bug. ***
Comment 54 Frank Reininghaus 2015-05-15 15:23:36 UTC
*** Bug 347742 has been marked as a duplicate of this bug. ***
Comment 55 edsw 2015-05-18 06:24:25 UTC
how often do iget this message?
	1000 ...00 times

Am 15.05.2015 um 17:23 schrieb Frank Reininghaus:
> https://bugs.kde.org/show_bug.cgi?id=278431
>
> Frank Reininghaus <frank78ac@googlemail.com> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |jim.odayinst@gmail.com
>
> --- Comment #54 from Frank Reininghaus <frank78ac@googlemail.com> ---
> *** Bug 347742 has been marked as a duplicate of this bug. ***
>
Comment 56 Christoph Feck 2015-05-18 08:11:45 UTC
If you are not interested in following this bug, remove yourself from the CC list and from the vote list.
Comment 57 Emmanuel Pescosta 2015-05-21 16:13:58 UTC
*** Bug 348065 has been marked as a duplicate of this bug. ***
Comment 58 Emmanuel Pescosta 2015-05-22 09:44:04 UTC
*** Bug 348094 has been marked as a duplicate of this bug. ***
Comment 59 Christoph Feck 2015-05-30 01:29:58 UTC
*** Bug 348237 has been marked as a duplicate of this bug. ***
Comment 60 Frank Reininghaus 2015-06-24 19:26:26 UTC
*** Bug 349563 has been marked as a duplicate of this bug. ***
Comment 61 Christoph Feck 2015-07-28 13:24:17 UTC
*** Bug 350369 has been marked as a duplicate of this bug. ***
Comment 62 Christoph Feck 2015-07-28 13:26:31 UTC
*** Bug 349563 has been marked as a duplicate of this bug. ***
Comment 63 Frank Reininghaus 2015-08-09 13:50:44 UTC
*** Bug 350879 has been marked as a duplicate of this bug. ***
Comment 64 Koraq 2015-08-16 19:02:16 UTC
Created attachment 94064 [details]
New crash information added by DrKonqi

kded4 (4.14.9) on KDE Platform 4.14.9 using Qt 4.8.6

I selected a file in dolphin, and pressed Delete. It happens everytime.

-- Backtrace (Reduced):
#6  QList (l=..., this=0x7fff5b79ef50) at /usr/include/QtCore/qlist.h:122
#7  QForeachContainer (t=..., this=0x7fff5b79ef50) at /usr/include/QtCore/qglobal.h:2375
#8  KDirLister::Private::cachedItemsJobForUrl (this=0x202020200a3e2f22, url=...) at /usr/src/debug/kdelibs-4.14.9/kio/kio/kdirlister.cpp:281
#9  0x00007fd8dfcdd141 in KDirListerCache::updateDirectory (this=this@entry=0xa74030, _dir=...) at /usr/src/debug/kdelibs-4.14.9/kio/kio/kdirlister.cpp:694
#10 0x00007fd8dfcddefb in KDirListerCache::slotFilesAdded (this=0xa74030, dir=...) at /usr/src/debug/kdelibs-4.14.9/kio/kio/kdirlister.cpp:866
Comment 65 Koraq 2015-08-28 13:29:24 UTC
Created attachment 94259 [details]
New crash information added by DrKonqi

krunner (4.11.18) on KDE Platform 4.14.9 using Qt 4.8.6

Marked a file and pressed Delete. Happens as well when I right click and move to trash.

-- Backtrace (Reduced):
#6  QList (l=..., this=0x7ffe261a45e0) at /usr/include/QtCore/qlist.h:122
#7  QForeachContainer (t=..., this=0x7ffe261a45e0) at /usr/include/QtCore/qglobal.h:2375
#8  KDirLister::Private::cachedItemsJobForUrl (this=0x0, url=...) at /usr/src/debug/kdelibs-4.14.9/kio/kio/kdirlister.cpp:281
#9  0x00007fad6200e141 in KDirListerCache::updateDirectory (this=this@entry=0x29a2c20, _dir=...) at /usr/src/debug/kdelibs-4.14.9/kio/kio/kdirlister.cpp:694
#10 0x00007fad6200eefb in KDirListerCache::slotFilesAdded (this=0x29a2c20, dir=...) at /usr/src/debug/kdelibs-4.14.9/kio/kio/kdirlister.cpp:866
Comment 66 contact 2015-09-19 17:37:59 UTC
Created attachment 94649 [details]
New crash information added by DrKonqi

plasma-desktop (4.11.18) on KDE Platform 4.14.9 using Qt 4.8.6

- What I was doing when the application crashed:

I've just created a file named `report.lyx`, and deleted it. Then kde-panel crashed.

-- Backtrace (Reduced):
#6  0x0000003578b21e3f in KDirLister::Private::cachedItemsJobForUrl(KUrl const&) const () at /lib64/libkio.so.5
#7  0x0000003578b27141 in KDirListerCache::updateDirectory(KUrl const&) () at /lib64/libkio.so.5
#8  0x0000003578b27efb in KDirListerCache::slotFilesAdded(QString const&) () at /lib64/libkio.so.5
[...]
#10 0x0000003578b3bc85 in OrgKdeKDirNotifyInterface::FilesAdded(QString const&) () at /lib64/libkio.so.5
#11 0x0000003578b3c453 in OrgKdeKDirNotifyInterface::qt_metacall(QMetaObject::Call, int, void**) () at /lib64/libkio.so.5
Comment 67 Christoph Feck 2015-11-04 22:05:11 UTC
*** Bug 354859 has been marked as a duplicate of this bug. ***
Comment 68 Koraq 2015-11-22 20:14:32 UTC
I'd REALLY like this bug to get some priority, as it's totally killing Dolphin, making it practically useless for me. If there are ANY test I can do to nail down the problem, let me know!
Comment 69 marsianer 2015-11-24 20:17:55 UTC
The crash was reported 2011 first time and now we have 2015.
Is there really no workaround available?
Comment 70 David Faure 2016-01-30 09:29:45 UTC
Thanks for comment 30 (mathieu.beliveau) for the precise instructions on how to trigger the crash. Everything I tried from the other comments didn't trigger the crash, but the autofs mount did. This kills my hopes to be able to write a unittest for this though :-)
Fix coming up.
Comment 71 David Faure 2016-01-30 10:32:10 UTC
Git commit 725523993e6037b94a99348fc3879a4070c3dc7d by David Faure.
Committed on 30/01/2016 at 10:31.
Pushed by dfaure into branch 'KDE/4.14'.

Fix KDirListerCache crash with two listers for an empty dir in the cache.

The wrong optimization if (!itemU->lstItems.isEmpty()) meant that if
the cached dir is empty, we didn't create a CachedItemsJob. If there is
also no ListJob happening, then the lister would just be forever in the
listersCurrentlyListing list, which would lead to crashes later on.

The user-visible bug was hard to trigger (needed autofs enabled, I suppose to
trigger [1], although not sure why it's related), but after enabling DEBUG_CACHE,
simply clicking on the trash place entry in dolphin would trigger an assert.

[1] "KDirListerCache::forgetDirs: Not adding a watch on "file:///" because it contains a manually mounted subdir"
FIXED-IN: 4.14.17

M  +9    -7    kio/kio/kdirlister.cpp
M  +31   -0    kio/tests/kdirlistertest.cpp
M  +1    -0    kio/tests/kdirlistertest.h

http://commits.kde.org/kdelibs/725523993e6037b94a99348fc3879a4070c3dc7d
Comment 72 Alivema4ever 2016-10-21 09:46:54 UTC
It hasn't been completely fixed yet.

Crashes still occur when moving file to trash. #362459
Comment 73 Elvis Angelaccio 2016-12-25 11:22:42 UTC
*** Bug 363908 has been marked as a duplicate of this bug. ***
Comment 74 Elvis Angelaccio 2016-12-25 11:23:10 UTC
*** Bug 366404 has been marked as a duplicate of this bug. ***