Bug 332453 - selection of columns displayed (Installed-Size, Version, Available-Version)
Summary: selection of columns displayed (Installed-Size, Version, Available-Version)
Status: RESOLVED FIXED
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: 2.1.70
Platform: Ubuntu Packages Linux
: VLO wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
: 261227 332309 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-22 20:53 UTC by J
Modified: 2016-07-14 18:35 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J 2014-03-22 20:53:13 UTC
Synaptic is able to provide the installed size while listing packages in "installed" status.

I think it would be usefull in muon as well.

Reproducible: Always
Comment 1 Harald Sitter 2014-03-24 08:37:42 UTC
I fear this is a bit of a more complicated and general.

What needs to happen is that the view exposes a number of package properties as additional possible columns. Such that you can right click on the view header and select Installed-Size as property.
Comment 2 Harald Sitter 2014-03-28 08:38:06 UTC
*** Bug 332309 has been marked as a duplicate of this bug. ***
Comment 3 Harald Sitter 2014-03-28 08:39:50 UTC
As per bug 332309 expanding scope of this wish to at the very least include Installed-Size, Version, Available-Version.
Comment 4 Carlo Vanini 2016-02-22 23:26:48 UTC
*** Bug 261227 has been marked as a duplicate of this bug. ***
Comment 5 Carlo Vanini 2016-07-14 18:35:05 UTC
Git commit 6dc5c12d31831695aa2e3d6d2b1f8ad4e393c6bc by Carlo Vanini.
Committed on 14/07/2016 at 18:23.
Pushed by vanini into branch 'master'.

add columns for Installed-Size, Version, Available-Version

Add more columns to the list of packages and in the "preview changes"
tab.  The additional columns are hidden by default and can be shown
through the context menu by right-clicking on the list header.

Testing Done:
* start muon
* right-click on the list header
* a context menu appears, select/deselect columns to show

REVIEW: 126388

M  +1    -0    src/CMakeLists.txt
M  +8    -0    src/ManagerWidget.cpp
M  +1    -0    src/ManagerWidget.h
M  +27   -0    src/PackageModel/PackageDelegate.cpp
M  +17   -1    src/PackageModel/PackageModel.cpp
M  +4    -1    src/PackageModel/PackageModel.h
M  +4    -2    src/PackageModel/PackageView.cpp
C  +36   -31   src/PackageModel/PackageViewHeader.cpp [from: src/PackageModel/PackageView.cpp - 052% similarity]
C  +19   -20   src/PackageModel/PackageViewHeader.h [from: src/ManagerWidget.h - 074% similarity]
M  +14   -1    src/PackageModel/PackageWidget.cpp
M  +2    -0    src/PackageModel/PackageWidget.h
M  +4    -0    src/config/muon.kcfg

http://commits.kde.org/muon/6dc5c12d31831695aa2e3d6d2b1f8ad4e393c6bc