Bug 330947 - Icons for protected/unprotected pictures too similar on import
Summary: Icons for protected/unprotected pictures too similar on import
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-IconView (show other bugs)
Version: 3.5.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-09 11:06 UTC by Johannes Nieß
Modified: 2017-08-17 16:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Nieß 2014-02-09 11:06:38 UTC
Protected pictures result from a first grading on the camera. These potentially good pictures should be easy to spot.The icon for picures protected against deletion by the camera is a closed padlock.

The icon for unprotected picutores is an open padlock. The difference is just a few pixels. This is too slow and too dificult to differentiate.

The icon for unprotected pictures should be removed or made inivisible as this is the default case (approx. 90% for me). 

Reproducible: Always
Comment 1 Christoph Feck 2014-02-10 00:17:58 UTC
Duplicate of bug 244542 ?
Comment 2 caulier.gilles 2014-02-10 06:19:50 UTC
I think no.

Lock/unlock icons must be size changed accordingly with thumbnails sizes from icon view...

Gilles Caulier
Comment 3 Johannes Nieß 2014-02-10 18:27:44 UTC
Bug 244542 shows the same problem for inkscape as an example. I'll suggest an alternative icon there.

Given the age of that bug I'm not sure if that will help. I can't estimate if an specific solution for digikam is viable and if this bug should remain open.
Comment 4 Teemu Rytilahti 2014-02-12 21:10:30 UTC
I commited a change earlier this year, should be already part of the 4.0.0 beta2 by hiding the lock icon when the file is not locked. Is that any better?

commit 14c2779ae8b84a61711d4cc917df0d82d6574c65
Author: Teemu Rytilahti <tpr@iki.fi>
Date:   Mon Jan 6 15:32:17 2014 +0100

    ImportUI: Use better icons plus clean-up the overlays. Show lock icon only when the item is locked.
Comment 5 caulier.gilles 2014-02-12 21:28:05 UTC
Teemu,

For me this commit solve this issue because there is no confusion now between locked and unlocked icons.

I close this file now.

Gilles Caulier