Bug 330904 - Digikam crash during maintenance
Summary: Digikam crash during maintenance
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Maintenance-Thumbs (show other bugs)
Version: 3.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-08 05:30 UTC by julien.t43+kde
Modified: 2019-08-15 08:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments
New crash information added by DrKonqi (8.31 KB, text/plain)
2014-02-08 05:39 UTC, julien.t43+kde
Details
New crash information added by DrKonqi (8.47 KB, text/plain)
2014-02-08 06:25 UTC, julien.t43+kde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description julien.t43+kde 2014-02-08 05:30:12 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-14-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
Digikam 3.5 compiled from source tar.gz on lubuntu 13.10
after starting, all album folders were seen at 0 count images
I launched a maintenance with scan new/update thumbnails/fingerprint/duplicates and at the end of first phase (scan new) it crashed.

Console got the following messages:
[...]
QPixmap::scaled: Pixmap is a null pixmap
digikam(3839)/digikam (core) Digikam::MaintenanceMngr::setSettings:
wholeAlbums         : true
wholeTags           : true
Albums              : 523
Tags                : 158
useMutiCoreCPU      : false
newItems            : true
thumbnails          : true
scanThumbs          : true
fingerPrints        : true
scanFingerPrints    : true
duplicates          : true
similarity          : 90
faceManagement      : false
faceScannedHandling : 0
metadataSync        : false
syncDirection       : 0

digikam(3839)/digikam (core) Digikam::MaintenanceMngr::stage1: stage1
digikam(3839)/digikam (core) Digikam::NewItemsFinder::slotStart: scan mode: CompleteCollectionScan
digikam(3839)/digikam (core) Digikam::NewItemsFinder::slotTotalFilesToScan: total scan value :  149969
digikam(3839)/digikam (core): No DB action defined for "deleteAlbumRoot" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemIDsInTag" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemIDsInTag" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core) Digikam::CollectionScanner::completeHistoryScanning: items to tag ()
digikam(3839)/digikam (core) Digikam::CollectionScanner::completeScan: Complete scan took: 29618 msecs.
digikam(3839)/digikam (core) Digikam::NewItemsFinder::slotTotalFilesToScan: total scan value :  149969
digikam(3839)/digikam (core): No DB action defined for "deleteAlbumRoot" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core) Digikam::CollectionScanner::completeScan: Complete scan (file scanning deferred) took: 28773 msecs.
digikam(3839)/digikam (core) Digikam::MaintenanceMngr::stage2: stage2
digikam(3839)/digikam (core): No DB action defined for "getItemURLsInAlbumNoItemSorting" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemURLsInAlbumNoItemSorting" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemURLsInAlbumNoItemSorting" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemURLsInAlbumNoItemSorting" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemURLsInAlbumNoItemSorting" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
digikam(3839)/digikam (core): No DB action defined for "getItemURLsInAlbumNoItemSorting" ! Implementation missing for this database type.
digikam(3839)/digikam (core): Attempt to execute null action
[...]

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xab01a900 (LWP 3839))]

Thread 5 (Thread 0xaaff1b40 (LWP 3841)):
#0  0xb77ad424 in __kernel_vsyscall ()
#1  0xb49eea0b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xada5b392 in ?? () from /lib/i386-linux-gnu/libusb-1.0.so.0
#3  0xb3187d78 in start_thread (arg=0xaaff1b40) at pthread_create.c:311
#4  0xb49fe01e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 4 (Thread 0xa7d91b40 (LWP 3842)):
#0  0xb77ad424 in __kernel_vsyscall ()
#1  0xb318b84b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb4a0b9bc in __pthread_cond_wait (cond=0x9b76af8, mutex=0x9b76ae0) at forward.c:149
#3  0xb4cedca5 in wait (time=4294967295, this=0x9b76ae0) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9b76a54, mutex=0x9b76a50, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x082016f2 in Digikam::ScanController::run (this=0x9b762b8) at /opt/tmp/build-digikam/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#6  0xb4ced72f in QThreadPrivate::start (arg=0x9b762b8) at thread/qthread_unix.cpp:338
#7  0xb3187d78 in start_thread (arg=0xa7d91b40) at pthread_create.c:311
#8  0xb49fe01e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 3 (Thread 0xa73ffb40 (LWP 3843)):
#0  0xb2dadb90 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2d6aa35 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2d6aca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4e2c8df in QEventDispatcherGlib::processEvents (this=0xa6a00480, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0xb4dfb9f3 in QEventLoop::processEvents (this=this@entry=0xa73ff068, flags=...) at kernel/qeventloop.cpp:149
#5  0xb4dfbd19 in QEventLoop::exec (this=this@entry=0xa73ff068, flags=...) at kernel/qeventloop.cpp:204
#6  0xb4ceae3d in QThread::exec (this=this@entry=0x9b77eb8) at thread/qthread.cpp:542
#7  0xb4ddbe14 in QInotifyFileSystemWatcherEngine::run (this=0x9b77eb8) at io/qfilesystemwatcher_inotify.cpp:265
#8  0xb4ced72f in QThreadPrivate::start (arg=0x9b77eb8) at thread/qthread_unix.cpp:338
#9  0xb3187d78 in start_thread (arg=0xa73ffb40) at pthread_create.c:311
#10 0xb49fe01e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 2 (Thread 0xa69ffb40 (LWP 3857)):
#0  0xb77ad424 in __kernel_vsyscall ()
#1  0xb318b84b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb4a0b9bc in __pthread_cond_wait (cond=0x9b9beb0, mutex=0x9b9be98) at forward.c:149
#3  0xb4cedca5 in wait (time=4294967295, this=0x9b9be98) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9d03670, mutex=0x9d0366c, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6951814 in Digikam::ParkingThread::run (this=0x9d03660) at /opt/tmp/build-digikam/digikam-3.5.0/core/libs/threads/threadmanager.cpp:119
#6  0xb4ced72f in QThreadPrivate::start (arg=0x9d03660) at thread/qthread_unix.cpp:338
#7  0xb3187d78 in start_thread (arg=0xa69ffb40) at pthread_create.c:311
#8  0xb49fe01e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xab01a900 (LWP 3839)):
[KCrash Handler]
#7  0xb77ad424 in __kernel_vsyscall ()
#8  0xb493aaff in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb493e083 in __GI_abort () at abort.c:90
#10 0xb4ce2993 in qt_message_output (msgType=QtFatalMsg, buf=0x268bf478 "ASSERT: \"d\" in file /opt/tmp/build-digikam/digikam-3.5.0/core/libs/database/core/thumbnaildatabaseaccess.cpp, line 86") at global/qglobal.cpp:2347
#11 0xb4ce2d47 in qt_message (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0xb4e64aec "ASSERT: \"%s\" in file %s, line %d", ap=ap@entry=0xbfa2ab34 "\271n\255\266`n\255\266V") at global/qglobal.cpp:2393
#12 0xb4ce3278 in qFatal (msg=msg@entry=0xb4e64aec "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2576
#13 0xb4ce32f5 in qt_assert (assertion=0xb6ad6eb9 "d", file=0xb6ad6e60 "/opt/tmp/build-digikam/digikam-3.5.0/core/libs/database/core/thumbnaildatabaseaccess.cpp", line=86) at global/qglobal.cpp:2021
#14 0xb691e9dc in Digikam::ThumbnailDatabaseAccess::ThumbnailDatabaseAccess (this=0xbfa2ab87) at /opt/tmp/build-digikam/digikam-3.5.0/core/libs/database/core/thumbnaildatabaseaccess.cpp:86
#15 0x08145129 in Digikam::ThumbsGenerator::slotStart (this=0x9d60a10) at /opt/tmp/build-digikam/digikam-3.5.0/core/utilities/maintenance/thumbsgenerator.cpp:146
#16 0x08144aa9 in Digikam::ThumbsGenerator::qt_static_metacall (_o=0x9d60a10, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xae19e78) at /opt/tmp/build-digikam/digikam-3.5.0/build/core/digikam/thumbsgenerator.moc:52
#17 0xb4e0e77a in QMetaCallEvent::placeMetaCall (this=0x268bf7e8, object=0x9d60a10) at kernel/qobject.cpp:524
#18 0xb4e1658b in QObject::event (this=0x9d60a10, e=0x268bf7e8) at kernel/qobject.cpp:1194
#19 0xb5357744 in QApplicationPrivate::notify_helper (this=0x997e2a8, receiver=0x9d60a10, e=0x268bf7e8) at kernel/qapplication.cpp:4567
#20 0xb535e223 in QApplication::notify (this=0xbfa2b358, receiver=receiver@entry=0x9d60a10, e=e@entry=0x268bf7e8) at kernel/qapplication.cpp:4353
#21 0xb5ea4ff4 in KApplication::notify (this=0xbfa2b358, receiver=0x9d60a10, event=0x268bf7e8) at ../../kdeui/kernel/kapplication.cpp:311
#22 0xb4dfceda in QCoreApplication::notifyInternal (this=0xbfa2b358, receiver=receiver@entry=0x9d60a10, event=event@entry=0x268bf7e8) at kernel/qcoreapplication.cpp:946
#23 0xb4e006ad in sendEvent (event=0x268bf7e8, receiver=0x9d60a10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x9918860) at kernel/qcoreapplication.cpp:1570
#25 0xb4e00bbc in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#26 0xb4e2cf6e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#27 postEventSourceDispatch (s=0x997e3a8) at kernel/qeventdispatcher_glib.cpp:279
#28 0xb2d6a83e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb2d6abe8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb2d6aca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb4e2c8bf in QEventDispatcherGlib::processEvents (this=this@entry=0x98f6098, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0xb540c32e in QGuiEventDispatcherGlib::processEvents (this=0x98f6098, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb4dfb9f3 in QEventLoop::processEvents (this=this@entry=0xbfa2b168, flags=...) at kernel/qeventloop.cpp:149
#34 0xb4dfbd19 in QEventLoop::exec (this=this@entry=0xbfa2b168, flags=...) at kernel/qeventloop.cpp:204
#35 0xb4e0189e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#36 0xb5355974 in QApplication::exec () at kernel/qapplication.cpp:3828
#37 0x082f2424 in main (argc=1, argv=0xbfa2b494) at /opt/tmp/build-digikam/digikam-3.5.0/core/digikam/main/main.cpp:235

The reporter indicates this bug may be a duplicate of or related to bug 309061.

Possible duplicates by query: bug 330637, bug 329162, bug 324432, bug 321758, bug 316495.

Reported using DrKonqi
Comment 1 julien.t43+kde 2014-02-08 05:39:22 UTC
Created attachment 85038 [details]
New crash information added by DrKonqi

digikam (3.5.0) on KDE Platform 4.11.3 using Qt 4.8.4

- What I was doing when the application crashed:
2nd time try in the same conditions. will try w 4.0 beta from git

-- Backtrace (Reduced):
#8  0xb48dbaff in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb48df083 in __GI_abort () at abort.c:90
[...]
#13 0xb4c842f5 in qt_assert (assertion=0xb6a77eb9 "d", file=0xb6a77e60 "/opt/tmp/build-digikam/digikam-3.5.0/core/libs/database/core/thumbnaildatabaseaccess.cpp", line=86) at global/qglobal.cpp:2021
#14 0xb68bf9dc in Digikam::ThumbnailDatabaseAccess::ThumbnailDatabaseAccess (this=0xbffe9c87) at /opt/tmp/build-digikam/digikam-3.5.0/core/libs/database/core/thumbnaildatabaseaccess.cpp:86
#15 0x08145129 in Digikam::ThumbsGenerator::slotStart (this=0xa793570) at /opt/tmp/build-digikam/digikam-3.5.0/core/utilities/maintenance/thumbsgenerator.cpp:146
Comment 2 caulier.gilles 2014-02-08 05:40:54 UTC

*** This bug has been marked as a duplicate of bug 326959 ***
Comment 3 julien.t43+kde 2014-02-08 06:25:11 UTC
Created attachment 85040 [details]
New crash information added by DrKonqi

digikam (4.0.0-beta3) on KDE Platform 4.11.3 using Qt 4.8.4

- What I was doing when the application crashed:
same test than for 3.5 but w 4.0 from git/head.
still crashing after maintenance

-- Backtrace (Reduced):
#8  0xb43fdaff in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb4401083 in __GI_abort () at abort.c:90
[...]
#13 0xb47a62f5 in qt_assert (assertion=0xb6a34108 "d", file=0xb6a340a0 "/opt/tmp/build-digikam/digikam-software-compilation/core/libs/database/core/thumbnaildatabaseaccess.cpp", line=86) at global/qglobal.cpp:2021
#14 0xb688655c in Digikam::ThumbnailDatabaseAccess::ThumbnailDatabaseAccess (this=0xbfc81d07) at /opt/tmp/build-digikam/digikam-software-compilation/core/libs/database/core/thumbnaildatabaseaccess.cpp:86
#15 0x0814c351 in Digikam::ThumbsGenerator::slotStart (this=0x2712c768) at /opt/tmp/build-digikam/digikam-software-compilation/core/utilities/maintenance/thumbsgenerator.cpp:146
Comment 4 caulier.gilles 2019-08-15 08:06:43 UTC
Fixed with bug #326959