Bug 330637 - Imap resource crashes after moving messages
Summary: Imap resource crashes after moving messages
Status: RESOLVED DUPLICATE of bug 326242
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: 4.12
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-01 17:23 UTC by Luis Silva
Modified: 2014-02-02 11:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Silva 2014-02-01 17:23:50 UTC
Application: akonadi_imap_resource (4.12)
KDE Platform Version: 4.12.0 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
I moved a few e-mail between two imap accounts. The resource responsible for the receiving account started crashing after that. Note that the receiving account is an Outlook web access account mimicing imap.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Glasgow Uni of type IMAP E-Mail Server (akonadi_imap_resource), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4938740 (LWP 14901))]

Thread 2 (Thread 0xb1fd5b40 (LWP 14987)):
#0  0xb7701424 in __kernel_vsyscall ()
#1  0xb56e64d2 in clock_gettime (clock_id=1, tp=0xb1fd4ff8) at ../sysdeps/unix/clock_gettime.c:115
#2  0xb718d3ec in do_gettime (frac=0xb1fd4ff0, sec=0xb1fd4fe8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0xb7272fd2 in updateCurrentTime (this=0xb1602074) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0xb1602074, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0xb727167b in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb1fd50ec) at kernel/qeventdispatcher_glib.cpp:136
#7  0xb727170d in timerSourcePrepare (source=0xb1602040, timeout=0xb1fd50ec) at kernel/qeventdispatcher_glib.cpp:169
#8  0xb53d8143 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb53d8a5f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb53d8ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb72718df in QEventDispatcherGlib::processEvents (this=0xb1600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0xb72409f3 in QEventLoop::processEvents (this=this@entry=0xb1fd5258, flags=...) at kernel/qeventloop.cpp:149
#13 0xb7240d19 in QEventLoop::exec (this=this@entry=0xb1fd5258, flags=...) at kernel/qeventloop.cpp:204
#14 0xb712fe3d in QThread::exec (this=this@entry=0x8bbc818) at thread/qthread.cpp:542
#15 0xb712ff8b in QThread::run (this=0x8bbc818) at thread/qthread.cpp:609
#16 0xb713272f in QThreadPrivate::start (arg=0x8bbc818) at thread/qthread_unix.cpp:338
#17 0xb5507d78 in start_thread (arg=0xb1fd5b40) at pthread_create.c:311
#18 0xb56d301e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xb4938740 (LWP 14901)):
[KCrash Handler]
#7  0xb7701424 in __kernel_vsyscall ()
#8  0xb560faff in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb5613083 in __GI_abort () at abort.c:90
#10 0xb7127993 in qt_message_output (msgType=QtFatalMsg, buf=0x8cb7048 "ASSERT: \"!isEmpty()\" in file /usr/include/qt4/QtCore/qlist.h, line 284") at global/qglobal.cpp:2347
#11 0xb7127d47 in qt_message (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0xb72a9aec "ASSERT: \"%s\" in file %s, line %d", ap=ap@entry=0xbfccc6e4 "db\v\b$b\v\b\034\001") at global/qglobal.cpp:2393
#12 0xb7128278 in qFatal (msg=msg@entry=0xb72a9aec "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2576
#13 0xb71282f5 in qt_assert (assertion=0x80b6264 "!isEmpty()", file=0x80b6224 "/usr/include/qt4/QtCore/qlist.h", line=284) at global/qglobal.cpp:2021
#14 0x0808d8c5 in QList<long long>::last (this=0x8c869a0) at /usr/include/qt4/QtCore/qlist.h:284
#15 0x0808d17a in MoveItemsTask::recordNewUid (this=0x8c86978) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/resources/imap/moveitemstask.cpp:290
#16 0x0808cdc4 in MoveItemsTask::onSearchDone (this=0x8c86978, job=0x8cb2620) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/resources/imap/moveitemstask.cpp:242
#17 0x080a6784 in MoveItemsTask::qt_static_metacall (_o=_o@entry=0x8c86978, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfccc8e8) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/BUILD-DEBUG/resources/imap/moc_moveitemstask.cpp:60
#18 0xb7256fc7 in QMetaObject::activate (sender=sender@entry=0x8cb2620, m=m@entry=0xb5b464cc <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0xbfccc8e8) at kernel/qobject.cpp:3539
#19 0xb59a21e5 in KJob::result (this=this@entry=0x8cb2620, _t1=_t1@entry=0x8cb2620) at ./kjob.moc:208
#20 0xb59a2232 in KJob::emitResult (this=0x8cb2620) at ../../kdecore/jobs/kjob.cpp:318
#21 0xb6475c55 in KIMAP::Job::handleErrorReplies (this=0x8cb2620, response=...) at /home/lacsilva/Development/kdepim.d/kdepimlibs/kimap/job.cpp:90
#22 0xb64991e5 in KIMAP::SearchJob::handleResponse (this=0x8cb2620, response=...) at /home/lacsilva/Development/kdepim.d/kdepimlibs/kimap/searchjob.cpp:161
#23 0xb648dd1d in KIMAP::SessionPrivate::responseReceived (this=0x8bbc638, response=...) at /home/lacsilva/Development/kdepim.d/kdepimlibs/kimap/session.cpp:300
#24 0xb648f055 in KIMAP::SessionPrivate::qt_static_metacall (_o=0x8bbc638, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xb1603470) at /home/lacsilva/Development/kdepim.d/kdepimlibs/BUILD-DEBUG/kimap/moc_session_p.cpp:78
#25 0xb725377a in QMetaCallEvent::placeMetaCall (this=0xb16794f0, object=0x8bbc638) at kernel/qobject.cpp:524
#26 0xb725b58b in QObject::event (this=0x8bbc638, e=0xb16794f0) at kernel/qobject.cpp:1194
#27 0xb6753744 in QApplicationPrivate::notify_helper (this=0x8989be8, receiver=0x8bbc638, e=0xb16794f0) at kernel/qapplication.cpp:4567
#28 0xb675a223 in QApplication::notify (this=0xbfccd084, receiver=receiver@entry=0x8bbc638, e=e@entry=0xb16794f0) at kernel/qapplication.cpp:4353
#29 0xb5d23164 in KApplication::notify (this=0xbfccd084, receiver=0x8bbc638, event=0xb16794f0) at ../../kdeui/kernel/kapplication.cpp:311
#30 0xb7241eda in QCoreApplication::notifyInternal (this=0xbfccd084, receiver=receiver@entry=0x8bbc638, event=event@entry=0xb16794f0) at kernel/qcoreapplication.cpp:946
#31 0xb72456ad in sendEvent (event=0xb16794f0, receiver=0x8bbc638) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x8964fd8) at kernel/qcoreapplication.cpp:1570
#33 0xb7245bbc in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#34 0xb7271f6e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#35 postEventSourceDispatch (s=0x89876e0) at kernel/qeventdispatcher_glib.cpp:279
#36 0xb53d883e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0xb53d8be8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb53d8ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb72718bf in QEventDispatcherGlib::processEvents (this=this@entry=0x8965b60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0xb680832e in QGuiEventDispatcherGlib::processEvents (this=0x8965b60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0xb72409f3 in QEventLoop::processEvents (this=this@entry=0xbfcccfe8, flags=...) at kernel/qeventloop.cpp:149
#42 0xb7240d19 in QEventLoop::exec (this=this@entry=0xbfcccfe8, flags=...) at kernel/qeventloop.cpp:204
#43 0xb724689e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#44 0xb6751974 in QApplication::exec () at kernel/qapplication.cpp:3828
#45 0xb756f7e3 in Akonadi::ResourceBase::init (r=0x8ada1f0) at /home/lacsilva/Development/kdepim.d/kdepimlibs/akonadi/resourcebase.cpp:504
#46 0x080630fa in Akonadi::ResourceBase::init<ImapResource> (argc=3, argv=0xbfccd154) at /usr/include/akonadi/resourcebase.h:192
#47 0x08060bc5 in main (argc=3, argv=0xbfccd154) at /home/lacsilva/Development/kdepim.d/kdepim-runtime/resources/imap/imapresource.cpp:809

The reporter indicates this bug may be a duplicate of or related to bug 328601.

Possible duplicates by query: bug 329162, bug 324432, bug 321758, bug 316495.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-02 11:07:50 UTC

*** This bug has been marked as a duplicate of bug 326242 ***