Bug 330901 - The contacts list crashes when I was clicking on a contact
Summary: The contacts list crashes when I was clicking on a contact
Status: RESOLVED DUPLICATE of bug 325679
Alias: None
Product: telepathy
Classification: Unclassified
Component: contactlist (show other bugs)
Version: 0.7.0
Platform: Chakra Linux
: NOR crash
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-08 01:29 UTC by Joshua Dunamis
Modified: 2014-02-08 02:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Dunamis 2014-02-08 01:29:03 UTC
Application: ktp-contactlist (0.7.0)
KDE Platform Version: 4.12.1
Qt Version: 4.8.5
Operating System: Linux 3.12.6-1-CHAKRA x86_64
Distribution: "Chakra Linux"

-- Information about the crash:
I was opening a contact for a conversation. The chat window opened but the man Contacts list crashed.

-- Backtrace:
Application: Lista dei contatti di Telepathy KDE (ktp-contactlist), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#5  0x00007fbd84a263d9 in raise () from /lib/libc.so.6
#6  0x00007fbd84a277d8 in abort () from /lib/libc.so.6
#7  0x00007fbd865c80cf in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#8  0x00007fbd865c8259 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007fbd865c8a64 in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#10 0x00007fbd857d9ec7 in QIdentityProxyModel::rowCount(QModelIndex const&) const () from /usr/lib/libQtGui.so.4
#11 0x00007fbd8892b1bc in KTp::AbstractGroupingProxyModel::addProxyNode(QModelIndex const&, QStandardItem*) () from /usr/lib/libktpmodelsprivate.so.6
#12 0x00007fbd8892cc12 in KTp::AbstractGroupingProxyModel::onDataChanged(QModelIndex const&, QModelIndex const&) () from /usr/lib/libktpmodelsprivate.so.6
#13 0x00007fbd866f42c8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007fbd86742a67 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&) () from /usr/lib/libQtCore.so.4
#15 0x00007fbd8893eb1b in KTp::TextChannelWatcherProxyModel::onChannelMessagesChanged() () from /usr/lib/libktpmodelsprivate.so.6
#16 0x00007fbd866f42c8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#17 0x00007fbd866f8dae in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x00007fbd8527f1d1 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x00007fbd8528609d in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x00007fbd880a498a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#21 0x00007fbd866deb5d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#22 0x00007fbd866e2041 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#23 0x00007fbd8670ef83 in ?? () from /usr/lib/libQtCore.so.4
#24 0x00007fbd80854375 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x00007fbd808546a8 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x00007fbd80854764 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0x00007fbd8670e735 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007fbd85328ed6 in ?? () from /usr/lib/libQtGui.so.4
#29 0x00007fbd866dcf7f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0x00007fbd866dd215 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x00007fbd866e30e9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#32 0x000000000041df43 in ?? ()
#33 0x00007fbd84a12bc5 in __libc_start_main () from /lib/libc.so.6
#34 0x000000000041dfb1 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 325679.

Possible duplicates by query: bug 325789, bug 325679.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-08 02:24:28 UTC
Try 0.7.1

*** This bug has been marked as a duplicate of bug 325679 ***