Bug 325789 - ktp contactlist crashes when opening new chat
Summary: ktp contactlist crashes when opening new chat
Status: RESOLVED DUPLICATE of bug 325329
Alias: None
Product: telepathy
Classification: Unclassified
Component: contactlist (show other bugs)
Version: 0.6.80
Platform: unspecified Linux
: NOR crash
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-08 18:03 UTC by Bernd Buschinski
Modified: 2013-10-09 09:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Buschinski 2013-10-08 18:03:34 UTC
have Qt build with asserts enabled.
(depending on build type and stuff ktp contactlist too)

Reproducible: Always

Steps to Reproduce:
1. open the contactlist
2. double click a contact you want to chat with

Actual Results:  
it crashes, asserts




Expected Results:  
it should not crash

ASSERT: "parent.isValid() ? parent.model() == this : true" in file itemviews/qidentityproxymodel.cpp, line 317

///----------------

Application: KDE-Telepathy-Kontaktliste (ktp-contactlist), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f0a59a0d955 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f0a59a0edc7 in __GI_abort () at abort.c:90
#8  0x00007f0a5b5ed324 in qt_message_output (msgType=<optimized out>, msgType@entry=QtFatalMsg, buf=<optimized out>) at global/qglobal.cpp:2323
#9  0x00007f0a5b5ed480 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f0a5b769698 "ASSERT: \"%s\" in file %s, line %d", ap=ap@entry=0x7fff9dae7178) at global/qglobal.cpp:2369
#10 0x00007f0a5b5ed5f4 in qFatal (msg=msg@entry=0x7f0a5b769698 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2552
#11 0x00007f0a5b5ed636 in qt_assert (assertion=assertion@entry=0x7f0a5a9be3f8 "parent.isValid() ? parent.model() == this : true", file=file@entry=0x7f0a5a9be3a0 "itemviews/qidentityproxymodel.cpp", line=line@entry=317) at global/qglobal.cpp:2018
#12 0x00007f0a5a7ea363 in QIdentityProxyModel::rowCount (this=0x2467890, parent=...) at itemviews/qidentityproxymodel.cpp:317
#13 0x00007f0a5d90dfb8 in KTp::AbstractGroupingProxyModel::addProxyNode (this=this@entry=0x247e940, sourceIndex=..., parent=parent@entry=0x24669f0) at /var/tmp/portage/net-im/ktp-common-internals-0.6.80/work/ktp-common-internals-0.6.80/KTp/Models/abstract-grouping-proxy-model.cpp:223
#14 0x00007f0a5d90faac in KTp::AbstractGroupingProxyModel::onDataChanged (this=0x247e940, sourceTopLeft=..., sourceBottomRight=...) at /var/tmp/portage/net-im/ktp-common-internals-0.6.80/work/ktp-common-internals-0.6.80/KTp/Models/abstract-grouping-proxy-model.cpp:320
#15 0x00007f0a5b7164df in QMetaObject::activate (sender=sender@entry=0x2467890, m=m@entry=0x7f0a5ba6f5c0 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff9dae7670) at kernel/qobject.cpp:3547
#16 0x00007f0a5b764f67 in QAbstractItemModel::dataChanged (this=this@entry=0x2467890, _t1=..., _t2=...) at .moc/debug-shared/moc_qabstractitemmodel.cpp:163
#17 0x00007f0a5d920e46 in KTp::TextChannelWatcherProxyModel::onChannelMessagesChanged (this=0x2467890) at /var/tmp/portage/net-im/ktp-common-internals-0.6.80/work/ktp-common-internals-0.6.80/KTp/Models/text-channel-watcher-proxy-model.cpp:224
#18 0x00007f0a5b7164df in QMetaObject::activate (sender=0x25f0680, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#19 0x00007f0a5b71ba1e in QObject::event (this=0x25f0680, e=<optimized out>) at kernel/qobject.cpp:1194
#20 0x00007f0a5a26c0d1 in QApplicationPrivate::notify_helper (this=this@entry=0x21373c0, receiver=receiver@entry=0x25f0680, e=e@entry=0x220bcb0) at kernel/qapplication.cpp:4562
#21 0x00007f0a5a26e7a8 in QApplication::notify (this=this@entry=0x7fff9dae8250, receiver=receiver@entry=0x25f0680, e=e@entry=0x220bcb0) at kernel/qapplication.cpp:4423
#22 0x00007f0a5d07db48 in KApplication::notify (this=0x7fff9dae8250, receiver=0x25f0680, event=0x220bcb0) at /var/tmp/portage/kde-base/kdelibs-4.11.2-r1/work/kdelibs-4.11.2/kdeui/kernel/kapplication.cpp:311
#23 0x00007f0a5b6fffad in QCoreApplication::notifyInternal (this=0x7fff9dae8250, receiver=receiver@entry=0x25f0680, event=event@entry=0x220bcb0) at kernel/qcoreapplication.cpp:949
#24 0x00007f0a5b70348f in sendEvent (event=0x220bcb0, receiver=0x25f0680) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x206e710) at kernel/qcoreapplication.cpp:1573
#26 0x00007f0a5b7038e5 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#27 0x00007f0a5b730db3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x2122020) at kernel/qeventdispatcher_glib.cpp:280
#29 0x00007f0a55c61914 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f0a55c61c84 in g_main_context_iterate.isra.22 () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f0a55c61d4c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f0a5b730f24 in QEventDispatcherGlib::processEvents (this=0x21220a0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#33 0x00007f0a5a31a526 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f0a5b6fe44f in QEventLoop::processEvents (this=this@entry=0x7fff9dae8130, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f0a5b6fe708 in QEventLoop::exec (this=this@entry=0x7fff9dae8130, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f0a5b7045c6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#37 0x00007f0a5a26a3bc in QApplication::exec () at kernel/qapplication.cpp:3823
#38 0x00000000004209b1 in main (argc=1, argv=0x7fff9dae8398) at /var/tmp/portage/net-im/ktp-contact-list-0.6.80/work/ktp-contact-list-0.6.80/main.cpp:63
Comment 1 David Edmundson 2013-10-09 09:58:03 UTC
Fixed already.
Thanks for the report.

*** This bug has been marked as a duplicate of bug 325329 ***