Bug 330560 - kmail2 crashes when forward inline mail with images
Summary: kmail2 crashes when forward inline mail with images
Status: RESOLVED DUPLICATE of bug 312302
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-29 22:21 UTC by Pablo
Modified: 2014-01-30 02:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo 2014-01-29 22:21:09 UTC
Application: kmail (4.11.3)
KDE Platform Version: 4.11.3
Qt Version: 4.8.6
Operating System: Linux 3.12-1-amd64 x86_64
Distribution: Debian GNU/Linux testing (jessie)

-- Information about the crash:
Kmail2 crashes whenever I forward inline a mail with two JPEG images. If I select "forward as attachement" there's no fail.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f25c43a4780 (LWP 6284))]

Thread 3 (Thread 0x7f259b9ae700 (LWP 6290)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f25b62b07d2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f25b62b0809 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f25befc5e0e in start_thread (arg=0x7f259b9ae700) at pthread_create.c:311
#4  0x00007f25c16f50fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f259b0ad700 (LWP 6291)):
#0  0x00007f25c16e995d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f25b95b4194 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f25b95b429c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f25c2d257d6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f25c2cf703f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f25c2cf7335 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f25c2bf3c1f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f25c2bf62ef in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f25befc5e0e in start_thread (arg=0x7f259b0ad700) at pthread_create.c:311
#9  0x00007f25c16f50fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f25c43a4780 (LWP 6284)):
[KCrash Handler]
#5  0x00007f25be2640e4 in KMime::Content::parent() const () from /usr/lib/libkmime.so.4
#6  0x00007f25be268bd7 in KMime::Content::addContent(KMime::Content*, bool) () from /usr/lib/libkmime.so.4
#7  0x00007f25bcb08dee in TemplateParser::TemplateParser::createMultipartMixed(MessageCore::AttachmentCollector const&, KMime::Content*) const () from /usr/lib/libtemplateparser.so.4
#8  0x00007f25bcb0bf2f in TemplateParser::TemplateParser::addProcessedBodyToMessage(QString const&, QString const&) const () from /usr/lib/libtemplateparser.so.4
#9  0x00007f25bcb0db16 in TemplateParser::TemplateParser::processWithTemplate(QString const&) () from /usr/lib/libtemplateparser.so.4
#10 0x00007f25bcb0a9fa in TemplateParser::TemplateParser::process(boost::shared_ptr<KMime::Message> const&, Akonadi::Collection const&) () from /usr/lib/libtemplateparser.so.4
#11 0x00007f25bd654d1f in MessageComposer::MessageFactory::createForward() () from /usr/lib/libmessagecomposer.so.4
#12 0x00007f25c316ee0d in KMForwardCommand::createComposer(Akonadi::Item const&) () from /usr/lib/libkmailprivate.so.4
#13 0x00007f25c316fa88 in KMForwardCommand::execute() () from /usr/lib/libkmailprivate.so.4
#14 0x00007f25c31690b1 in KMCommand::slotPostTransfer(KMCommand::Result) () from /usr/lib/libkmailprivate.so.4
#15 0x00007f25c2d0c7f8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#16 0x00007f25c3168fee in KMCommand::messagesTransfered(KMCommand::Result) () from /usr/lib/libkmailprivate.so.4
#17 0x00007f25c316a5f3 in KMCommand::slotJobFinished() () from /usr/lib/libkmailprivate.so.4
#18 0x00007f25c2d0c7f8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007f25c37e44a2 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#20 0x00007f25c37e44e0 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#21 0x00007f25c2d10b9e in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#22 0x00007f25c20996cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#23 0x00007f25c209fd40 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#24 0x00007f25c3dc749a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#25 0x00007f25c2cf846d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#26 0x00007f25c2cfbacd in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007f25c2d25ef3 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x00007f25b95b3ea6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f25b95b41f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f25b95b429c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f25c2d257b5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#32 0x00007f25c2137766 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#33 0x00007f25c2cf703f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#34 0x00007f25c2cf7335 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#35 0x00007f25c2cfcb09 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#36 0x0000000000402d1a in ?? ()
#37 0x00007f25c162d995 in __libc_start_main (main=0x402280, argc=3, ubp_av=0x7fff0d312f68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0d312f58) at libc-start.c:276
#38 0x00000000004031ee in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 312302.

Possible duplicates by query: bug 312302.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-30 02:39:14 UTC

*** This bug has been marked as a duplicate of bug 312302 ***