Bug 330484 - Moun package manager crashed when running along with Moun Update manager.
Summary: Moun package manager crashed when running along with Moun Update manager.
Status: RESOLVED DUPLICATE of bug 327544
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-27 20:38 UTC by Matt
Modified: 2016-03-02 13:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt 2014-01-27 20:38:24 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Netrunner 13.12 (Enigma-II)

-- Information about the crash:
- What I was doing when the application crashed:
Moun package manager crashed when running with Moun Update manager.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fae7462a7c0 (LWP 2242))]

Thread 2 (Thread 0x7fae61618700 (LWP 2243)):
#0  0x00007fae71c86f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fae6f0116a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fae6f0117ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fae7240ca76 in QEventDispatcherGlib::processEvents (this=0x7fae5c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fae723de5ef in QEventLoop::processEvents (this=this@entry=0x7fae61617d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fae723de8e5 in QEventLoop::exec (this=this@entry=0x7fae61617d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fae722dd88f in QThread::exec (this=this@entry=0x124abb0) at thread/qthread.cpp:542
#7  0x00007fae723bfd13 in QInotifyFileSystemWatcherEngine::run (this=0x124abb0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007fae722dff2f in QThreadPrivate::start (arg=0x124abb0) at thread/qthread_unix.cpp:338
#9  0x00007fae6f4e9f6e in start_thread (arg=0x7fae61618700) at pthread_create.c:311
#10 0x00007fae71c939cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fae7462a7c0 (LWP 2242)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0x1263f90, resources=...) at /build/buildd/muon-2.1.2/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x126b7b0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x126b7b0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007fae723f3a58 in QMetaObject::activate (sender=0x11c8b60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007fae723f3a58 in QMetaObject::activate (sender=sender@entry=0x105afc0, m=m@entry=0x7fae744434c0 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff3bd459a0) at kernel/qobject.cpp:3539
#12 0x00007fae7421c602 in AbstractBackendUpdater::progressingChanged (this=this@entry=0x105afc0, _t1=false) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#13 0x00007fae6011203c in ApplicationUpdates::setProgressing (this=0x105afc0, progressing=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#14 0x00007fae723f3a58 in QMetaObject::activate (sender=sender@entry=0x13bae70, m=m@entry=0x7fae74443180 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#15 0x00007fae7421d040 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x13bae70) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#16 0x00007fae60104e33 in ApplicationBackend::setFetching (this=0x13bae70, f=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#17 0x00007fae60107463 in ApplicationBackend::reload (this=0x13bae70) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#18 0x00007fae601120f4 in ApplicationUpdates::transactionFinished (this=0x105afc0) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#19 0x00007fae723f3a58 in QMetaObject::activate (sender=0x1115180, m=m@entry=0x7fae5b1ac9c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff3bd45c60) at kernel/qobject.cpp:3539
#20 0x00007fae5af97441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#21 0x00007fae5af8a1af in QApt::Transaction::updateProperty (this=0x1115180, type=0, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#22 0x00007fae5af97974 in QApt::Transaction::qt_static_metacall (_o=0x1115180, _c=<optimized out>, _id=<optimized out>, _a=0x7fff3bd45e80) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#23 0x00007fae723f3a58 in QMetaObject::activate (sender=sender@entry=0x2c020d0, m=m@entry=0x7fae5b1acaa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff3bd45e80) at kernel/qobject.cpp:3539
#24 0x00007fae5af983d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x2c020d0, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#25 0x00007fae5af9877c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x2c020d0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff3bd46140) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#26 0x00007fae5af990f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x2c020d0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff3bd46140) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#27 0x00007fae7148ee36 in QDBusConnectionPrivate::deliverCall (this=0x12c8710, object=0x2c020d0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#28 0x00007fae723f7dce in QObject::event (this=0x2c020d0, e=<optimized out>) at kernel/qobject.cpp:1194
#29 0x00007fae72dd0dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1070dd0, receiver=receiver@entry=0x2c020d0, e=e@entry=0x2c2d810) at kernel/qapplication.cpp:4567
#30 0x00007fae72dd7470 in QApplication::notify (this=this@entry=0x7fff3bd468f0, receiver=receiver@entry=0x2c020d0, e=e@entry=0x2c2d810) at kernel/qapplication.cpp:4353
#31 0x00007fae73adaa6a in KApplication::notify (this=0x7fff3bd468f0, receiver=0x2c020d0, event=0x2c2d810) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007fae723df8bd in QCoreApplication::notifyInternal (this=0x7fff3bd468f0, receiver=receiver@entry=0x2c020d0, event=event@entry=0x2c2d810) at kernel/qcoreapplication.cpp:946
#33 0x00007fae723e2e1f in sendEvent (event=0x2c2d810, receiver=0x2c020d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x103f500) at kernel/qcoreapplication.cpp:1570
#35 0x00007fae723e32c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#36 0x00007fae7240d073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0x106d340) at kernel/qeventdispatcher_glib.cpp:279
#38 0x00007fae6f0113b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007fae6f011708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007fae6f0117ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fae7240ca55 in QEventDispatcherGlib::processEvents (this=0x1040de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#42 0x00007fae72e729d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007fae723de5ef in QEventLoop::processEvents (this=this@entry=0x7fff3bd467f0, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007fae723de8e5 in QEventLoop::exec (this=this@entry=0x7fff3bd467f0, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007fae723e3e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#46 0x00007fae72dcf34c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040ce11 in main (argc=5, argv=0x7fff3bd46a28) at /build/buildd/muon-2.1.2/updater/main.cpp:59

Possible duplicates by query: bug 330421, bug 329760, bug 329755, bug 329725, bug 329614.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-28 02:08:12 UTC

*** This bug has been marked as a duplicate of bug 327544 ***