Bug 330421 - Muon Update manager crashed automatically
Summary: Muon Update manager crashed automatically
Status: RESOLVED DUPLICATE of bug 327544
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-26 10:28 UTC by ARVIND RATHORE
Modified: 2016-03-02 13:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ARVIND RATHORE 2014-01-26 10:28:43 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.12.1
Qt Version: 4.8.6
Operating System: Linux 3.13.0-5-generic x86_64
Distribution: Ubuntu Trusty Tahr (development branch)

-- Information about the crash:
Laptop was running on battery, checked for updates by using ctrl+R. Showed 70 updates available. And all of sudden received the crash msg.. Was using mozilla firefox when the msg appeared.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0bd60807c0 (LWP 3461))]

Thread 2 (Thread 0x7f0bc2c69700 (LWP 3462)):
#0  0x00007f0bd36dde4d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0bd0a99950 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0bd0a59864 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bd0a59ccb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0bd0a59e3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0bd3e67836 in QEventDispatcherGlib::processEvents (this=0x7f0bbc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007f0bd3e3909f in QEventLoop::processEvents (this=this@entry=0x7f0bc2c68de0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0bd3e39395 in QEventLoop::exec (this=this@entry=0x7f0bc2c68de0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0bd3d35c4f in QThread::exec (this=this@entry=0xee5180) at thread/qthread.cpp:537
#9  0x00007f0bd3e1a813 in QInotifyFileSystemWatcherEngine::run (this=0xee5180) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f0bd3d3831f in QThreadPrivate::start (arg=0xee5180) at thread/qthread_unix.cpp:349
#11 0x00007f0bd0f33182 in start_thread (arg=0x7f0bc2c69700) at pthread_create.c:312
#12 0x00007f0bd36ecb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f0bd60807c0 (LWP 3461)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0xf096d0, resources=...) at /build/buildd/muon-2.1.2/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0xf3d9a0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0xf3d9a0) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007f0bd3e4e868 in QMetaObject::activate (sender=0xe8d270, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007f0bd3e4e868 in QMetaObject::activate (sender=sender@entry=0x1270f00, m=m@entry=0x7f0bd5ea24c0 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff861b7b00) at kernel/qobject.cpp:3539
#12 0x00007f0bd5c7b602 in AbstractBackendUpdater::progressingChanged (this=this@entry=0x1270f00, _t1=false) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#13 0x00007f0bc0ed700c in ApplicationUpdates::setProgressing (this=0x1270f00, progressing=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#14 0x00007f0bd3e4e868 in QMetaObject::activate (sender=sender@entry=0x126d330, m=m@entry=0x7f0bd5ea2180 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#15 0x00007f0bd5c7c040 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x126d330) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#16 0x00007f0bc0ec9e33 in ApplicationBackend::setFetching (this=0x126d330, f=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#17 0x00007f0bc0ecc461 in ApplicationBackend::reload (this=0x126d330) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#18 0x00007f0bc0ed70c4 in ApplicationUpdates::transactionFinished (this=0x1270f00) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#19 0x00007f0bd3e4e868 in QMetaObject::activate (sender=0x2640450, m=m@entry=0x7f0bc08639c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff861b7dc0) at kernel/qobject.cpp:3539
#20 0x00007f0bc064e441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#21 0x00007f0bc06411af in QApt::Transaction::updateProperty (this=0x2640450, type=0, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#22 0x00007f0bc064e974 in QApt::Transaction::qt_static_metacall (_o=0x2640450, _c=<optimized out>, _id=<optimized out>, _a=0x7fff861b7fe0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#23 0x00007f0bd3e4e868 in QMetaObject::activate (sender=sender@entry=0x253abb0, m=m@entry=0x7f0bc0863aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff861b7fe0) at kernel/qobject.cpp:3539
#24 0x00007f0bc064f3d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x253abb0, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#25 0x00007f0bc064f77c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x253abb0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff861b82a0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#26 0x00007f0bc06500f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x253abb0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff861b82a0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#27 0x00007f0bd2ede1f6 in QDBusConnectionPrivate::deliverCall (this=0xeec3e0, object=0x253abb0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#28 0x00007f0bd3e52c0e in QObject::event (this=0x253abb0, e=<optimized out>) at kernel/qobject.cpp:1194
#29 0x00007f0bd482ce2c in QApplicationPrivate::notify_helper (this=this@entry=0xd156a0, receiver=receiver@entry=0x253abb0, e=e@entry=0x1e63b80) at kernel/qapplication.cpp:4567
#30 0x00007f0bd48334a0 in QApplication::notify (this=this@entry=0x7fff861b8a40, receiver=receiver@entry=0x253abb0, e=e@entry=0x1e63b80) at kernel/qapplication.cpp:4353
#31 0x00007f0bd5539aaa in KApplication::notify (this=0x7fff861b8a40, receiver=0x253abb0, event=0x1e63b80) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f0bd3e3a4cd in QCoreApplication::notifyInternal (this=0x7fff861b8a40, receiver=receiver@entry=0x253abb0, event=event@entry=0x1e63b80) at kernel/qcoreapplication.cpp:953
#33 0x00007f0bd3e3db2d in sendEvent (event=0x1e63b80, receiver=0x253abb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xce8500) at kernel/qcoreapplication.cpp:1577
#35 0x00007f0bd3e3dfd3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#36 0x00007f0bd3e67f53 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0xd1b850) at kernel/qeventdispatcher_glib.cpp:280
#38 0x00007f0bd0a59b54 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f0bd0a59d98 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f0bd0a59e3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f0bd3e67815 in QEventDispatcherGlib::processEvents (this=0xce9e00, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#42 0x00007f0bd48cebb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f0bd3e3909f in QEventLoop::processEvents (this=this@entry=0x7fff861b8940, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f0bd3e39395 in QEventLoop::exec (this=this@entry=0x7fff861b8940, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f0bd3e3eb69 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#46 0x00007f0bd482b37c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040ce11 in main (argc=5, argv=0x7fff861b8b78) at /build/buildd/muon-2.1.2/updater/main.cpp:59

Possible duplicates by query: bug 329760, bug 329755, bug 329725, bug 329614, bug 328931.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-27 01:29:38 UTC

*** This bug has been marked as a duplicate of bug 327544 ***