Bug 330420 - kontact, 2 events but 0 event displayed in the list
Summary: kontact, 2 events but 0 event displayed in the list
Status: RESOLVED DUPLICATE of bug 327256
Alias: None
Product: kontact
Classification: Applications
Component: summary (show other bugs)
Version: 4.12.1
Platform: OpenSUSE Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-26 10:12 UTC by Philippe ROUBACH
Modified: 2014-08-05 09:37 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
0 event in the event list of the summary in the delay of 7 days (78.54 KB, image/png)
2014-01-26 10:13 UTC, Philippe ROUBACH
Details
2 events in the delay of 7 days (102.39 KB, image/png)
2014-01-26 10:14 UTC, Philippe ROUBACH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2014-01-26 10:12:10 UTC
kontact is set to display events of the next 7 days
randomly but 99 % of the time nothing is displayed in the summary .

i have this phenomenon with akonadi kde calendar or akonadi google calendar .

procedure to experiment this pb :

open a kde session
kontact is launched (the last one)
summary is displayed
nothing in the event list

if i relaunch kontact during kde session then same pb

same pb for mail list

i assume :
- a bad synchro between the time when kontact summary gets data and akonadi is ready to serve data during kde session opening
 - kontact does not renew its summary during kde session


Reproducible: Always
Comment 1 Philippe ROUBACH 2014-01-26 10:13:52 UTC
Created attachment 84848 [details]
0 event in the event list of the summary in the delay of 7 days
Comment 2 Philippe ROUBACH 2014-01-26 10:14:38 UTC
Created attachment 84849 [details]
2 events in the delay of 7 days
Comment 3 Mark Shelby 2014-02-05 23:25:29 UTC
Same problem here. Chakra-Linux system. Latest kde upgrades 4.12.2-1
Comment 4 Stan Tontas 2014-02-11 23:11:22 UTC
I came here to report this same bug, (still) present in 4.12.2
Comment 5 Brallan Aguilar 2014-03-20 19:11:22 UTC
May be related with https://bugs.kde.org/show_bug.cgi?id=327256
Comment 6 szymon.pysz@gmail.com 2014-03-30 17:45:43 UTC
Hi all!

I have the same problem. KDE 4.12.3.  This problem occur a very long time. :-(

Best Regards,
Simon
Comment 7 Philippe ROUBACH 2014-04-29 13:24:45 UTC
more info :

precisely if the delay for an event is exactly 7 days from the current day then it is displayed but
if the delay < 7 days it is not displayed
Comment 8 Philippe ROUBACH 2014-05-02 11:51:12 UTC
if the delay is 0 then the event is displayed

to sum up :

if 0 < delay < 7 then the event is not displayed
Comment 9 Cor Blom 2014-05-23 21:46:15 UTC
on opensuse 13.1 with kde 4.13.1 I think I have the same problem. In summary view only those events are shown that are today or on that day that is after the number of days set in the configuration minus 1. Example: if I set a period of 14 days to show the upcoming events, the events of today and day 13 are shown.

Bug 278956 has a patch (in comment #12) which solves this bug for me. (My calendar is in owncloud).
Comment 10 Stephan Karacson 2014-05-25 14:06:03 UTC
Gentoo kontact 4.12.5 exact the same problem.
Comment 11 Wolfgang Bauer 2014-08-05 09:37:19 UTC
(In reply to Brallan Aguilar from comment #5)
> May be related with https://bugs.kde.org/show_bug.cgi?id=327256

I agree, IMHO this does indeed sound like the same problem.
I'm marking this report as duplicate, as the other one is older.

Please feel free to reopen if you disagree.

*** This bug has been marked as a duplicate of bug 327256 ***