Bug 327256 - Summary doesn't show upcoming events
Summary: Summary doesn't show upcoming events
Status: RESOLVED FIXED
Alias: None
Product: kontact
Classification: Applications
Component: summary (show other bugs)
Version: 4.13.2
Platform: Fedora RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 316143 324964 330420 334145 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-07 04:17 UTC by Brallan Aguilar
Modified: 2015-04-15 10:57 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.14.1


Attachments
Upcoming Events Summary Setup in Kontact (76.33 KB, image/jpeg)
2014-04-30 05:19 UTC, Brallan Aguilar
Details
Existence of an event in the calendar (95.18 KB, image/jpeg)
2014-04-30 05:21 UTC, Brallan Aguilar
Details
Kontact Summary showing no events (70.75 KB, image/jpeg)
2014-04-30 05:23 UTC, Brallan Aguilar
Details
attachment-14958-0.html (3.02 KB, text/html)
2015-04-14 22:55 UTC, Paul Bennett
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brallan Aguilar 2013-11-07 04:17:40 UTC
I have some events in my calendar. The problem is showing upcoming events in Kontact/Summary. If there are a birthday, anniversary within period specified in settings or at least one event today , these ones are showed in "Upcoming events", only these cases. So, if there is at least one event (excluding birthdays or anniversaries) within the same period, this one aren't showed by "Upcoming events".

Reproducible: Always

Steps to Reproduce:
1. Add a new event (neither birthdays nor anniversaries, within specified period in Kontact settings to show events)
Actual Results:  
The event doesn't appear in "Upcoming events"

Expected Results:  
All events within valid period must be showed in "Upcoming events"

I added new calendars (I'm using iCal files) and put new events, but exhibit same behavior.
Comment 1 Roman Fietze 2013-11-08 17:08:25 UTC
I can reproduce that on an openSUSE 12.3 using KDE 4.11.3 from the openSUSE repos.

Could not yet find out why this happens.
Comment 2 Stan Tontas 2014-02-11 23:12:50 UTC
Might be the same as this:
https://bugs.kde.org/show_bug.cgi?id=330420
Comment 3 Paul Bennett 2014-02-12 15:36:25 UTC
My version of Kontact is:- Platform Version 4.11.4
I am, likewise not seeing my up and coming events and meetings in the Summary Creen on Kontact. I am using the standard calendar product that came with the Kontact package. This has only been a problem since upgrading from Mageia 3 to Mageia 4, when I presume the KDE package was also updated.
Have tried re-adjusting the settings to no avail.
Comment 4 Brallan Aguilar 2014-03-06 20:06:50 UTC
It's present on KDE 4.12.3 ;(
Comment 5 Brallan Aguilar 2014-04-18 17:27:15 UTC
Still present in KDE 4.12.4
Comment 6 Brallan Aguilar 2014-04-30 05:19:20 UTC
Created attachment 86360 [details]
Upcoming Events Summary Setup in Kontact
Comment 7 Brallan Aguilar 2014-04-30 05:21:46 UTC
Created attachment 86361 [details]
Existence of an event in the calendar
Comment 8 Brallan Aguilar 2014-04-30 05:23:04 UTC
Created attachment 86362 [details]
Kontact Summary showing no events
Comment 9 Brallan Aguilar 2014-06-16 06:59:54 UTC
The problem persists in KDE 4.12.5
Comment 10 Roman Fietze 2014-06-23 08:53:25 UTC
The problem persists in KDE 4.13.1
Comment 11 Brallan Aguilar 2014-07-24 05:44:56 UTC
It continues in KDE 4.13.3
Comment 12 Wolfgang Bauer 2014-08-05 09:37:19 UTC
*** Bug 330420 has been marked as a duplicate of this bug. ***
Comment 13 Wolfgang Bauer 2014-08-05 09:38:44 UTC
*** Bug 334145 has been marked as a duplicate of this bug. ***
Comment 14 Wolfgang Bauer 2014-08-05 10:02:15 UTC
I had a look at this, and it seems to me that the check whether an event is in the specified interval is totally broken for non-recurring events.

Proposed fix:
https://git.reviewboard.kde.org/r/119614/
Comment 15 Wolfgang Bauer 2014-08-05 10:14:31 UTC
*** Bug 316143 has been marked as a duplicate of this bug. ***
Comment 16 Wolfgang Bauer 2014-09-10 19:28:45 UTC
Git commit e49a406b4224b5790f4e7a70bda879598152825e by Wolfgang Bauer.
Committed on 10/09/2014 at 19:23.
Pushed by wbauer into branch 'KDE/4.14'.

Fix range check for non-recurring events

The check whether an event is in the selected interval (in
SummaryEventInfo::eventsForRange()) was totally broken for non-recurring
events.
This patch should fix it, and also adds a unit test.
FIXED-IN: 4.14.1
REVIEW: 119614

M  +2    -2    kontact/plugins/korganizer/summaryeventinfo.cpp
M  +34   -0    kontact/plugins/korganizer/tests/summaryeventtest.cpp
M  +3    -0    kontact/plugins/korganizer/tests/summaryeventtest.h

http://commits.kde.org/kdepim/e49a406b4224b5790f4e7a70bda879598152825e
Comment 17 Wolfgang Bauer 2014-09-10 19:43:11 UTC
*** Bug 324964 has been marked as a duplicate of this bug. ***
Comment 18 Paul Bennett 2015-04-14 09:52:53 UTC
Some new information.

I have noticed that when hitting the APPLY button during the creation of an event that it will appear in the upcoming events list in Summary. I have since gone back to some other events that were not shown and made a small edit in order to be able to hit the Apply buton and these then appear in the Summary List as well. Those that are merely saved on the OK button do not appear.
Comment 19 Wolfgang Bauer 2015-04-14 18:31:23 UTC
(In reply to Paul Bennett from comment #18)
> Some new information.
New information?
This bug is fixed since over half a year (Kontact 4.14.1)...

> I have noticed that when hitting the APPLY button during the creation of an
> event that it will appear in the upcoming events list in Summary. I have
> since gone back to some other events that were not shown and made a small
> edit in order to be able to hit the Apply buton and these then appear in the
> Summary List as well. Those that are merely saved on the OK button do not
> appear.
Hm? I cannot reproduce that here at all with the latest 4.14.6. They appear just fine if I only click on OK.
Do they get saved in the calendar at all when you don't hit Apply? Are they shown in KOrganizer?
If not, you're seeing a completely different bug, and should report it separately.

On second thought, if the issue you mention is reproducible, you should open a new bug report in any case. I don't think that's in any way related to this one, and this one is marked as fixed (and it is fixed for me and also other people).

You should probably also specify which Kontact version you are using (if it's not the latest one, you should try to update and see whether the problem persists), and probably some more information like what kind of calendars have that problem, explicit steps to reproduce,...
Comment 20 Paul Bennett 2015-04-14 22:55:22 UTC
Created attachment 92033 [details]
attachment-14958-0.html

On 14/04/2015 at 7:31 PM, "Wolfgang Bauer" 
wrote:https://bugs.kde.org/show_bug.cgi?id=327256

--- Comment #19 from Wolfgang Bauer  ---
(In reply to Paul Bennett from comment #18)
> Some new information.
New information?
This bug is fixed since over half a year (Kontact 4.14.1)...

> I have noticed that when hitting the APPLY button during the
creation of an
> event that it will appear in the upcoming events list in Summary. I
have
> since gone back to some other events that were not shown and made a
small
> edit in order to be able to hit the Apply buton and these then
appear in the
> Summary List as well. Those that are merely saved on the OK button
do not
> appear.
Hm? I cannot reproduce that here at all with the latest 4.14.6. They
appear
just fine if I only click on OK.
Do they get saved in the calendar at all when you don't hit Apply? Are
they
shown in KOrganizer?
If not, you're seeing a completely different bug, and should report it
separately.

On second thought, if the issue you mention is reproducible, you
should open a
new bug report in any case. I don't think that's in any way related to
this
one, and this one is marked as fixed (and it is fixed for me and also
other
people).

You should probably also specify which Kontact version you are using
(if it's
not the latest one, you should try to update and see whether the
problem
persists), and probably some more information like what kind of
calendars have
that problem, explicit steps to reproduce,...
Comment 21 Wolfgang Bauer 2015-04-15 10:57:09 UTC
(In reply to Paul Bennett from comment #20)
> Created attachment 92033 [details]
> attachment-14958-0.html
Something seems to have gone wrong with your comment...
Did you write it by replying to an automatic email you got from bugzilla maybe?

Anyway, you write:
> The version I have is 4.12.5 (sorry for omission when I posted).
Yes, that bug was still present in 4.12.5.
IIRC, it got broken in 4.11, and I fixed it in 4.14.1.
Unfortunately we cannot fix/modify already released software, and there won't be any update to the 4.12 branch any more (which is obsolete/abandoned since a year when 4.13.0 was released).

If you are using distribution packages, you could ask your distribution to add the fix to their 4.12.5 packages though. The fix is available from the link in comment 16, and should apply cleanly on 4.12 too IIRC.

Still, the discrepancy between OK and Apply sounds strange to me. Maybe just a coincidency or wrong perception?
The check whether an event is in the specified interval (i.e. whether it should be shown) was broken completely, but it did work by luck for some events (e.g. events from today were correctly displayed).
It also worked for repeating events, so if you changed the repetition and clicked Apply, the event would be shown, but in this case it would have been "fixed" by just clicking OK too.