Bug 330414 - Kontact crashes on exit with KDE 4.12.0, Qt 4.8.4, application data not saved
Summary: Kontact crashes on exit with KDE 4.12.0, Qt 4.8.4, application data not saved
Status: RESOLVED DUPLICATE of bug 328755
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.12
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-26 00:31 UTC by Kirchkamp
Modified: 2014-01-26 01:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirchkamp 2014-01-26 00:31:11 UTC
Application: kontact (4.12)
KDE Platform Version: 4.12.0
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
Kontact always crashes on exit. Application data is not saved.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f58b62f77c0 (LWP 12211))]

Thread 5 (Thread 0x7f58975b3700 (LWP 12212)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f58b10ce1cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f58b10ce209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f58ad7f3f6e in start_thread (arg=0x7f58975b3700) at pthread_create.c:311
#4  0x00007f58b38699cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f5856ca0700 (LWP 12213)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f58b0e0ebbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f58b10fda76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f58ad7f3f6e in start_thread (arg=0x7f5856ca0700) at pthread_create.c:311
#4  0x00007f58b38699cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f584135e700 (LWP 12263)):
#0  0x00007fff489fea2f in clock_gettime ()
#1  0x00007f58b387e96d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f58b3f0a757 in do_gettime (frac=0x7f584135db40, sec=0x7f584135db38) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f58b3fe3fe5 in updateCurrentTime (this=0x7f5834002860) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x7f5834002860, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x00007f58b3fe282c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f584135dbf4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f58b3fe28d5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f58ad31ad4d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f58ad31b5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f58ad31b7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f58b3fe2a76 in QEventDispatcherGlib::processEvents (this=0x7f58340008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f58b3fb45ef in QEventLoop::processEvents (this=this@entry=0x7f584135ddb0, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f58b3fb48e5 in QEventLoop::exec (this=this@entry=0x7f584135ddb0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f58b3eb388f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#15 0x00007f58b3eb5f2f in QThreadPrivate::start (arg=0x162d7b0) at thread/qthread_unix.cpp:338
#16 0x00007f58ad7f3f6e in start_thread (arg=0x7f584135e700) at pthread_create.c:311
#17 0x00007f58b38699cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f583b65f700 (LWP 12313)):
#0  0x00007f58ad35b0ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f58ad35b399 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58ad31ad59 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58ad31b5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f58ad31b7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f58b3fe2a76 in QEventDispatcherGlib::processEvents (this=0x7f58300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f58b3fb45ef in QEventLoop::processEvents (this=this@entry=0x7f583b65ed70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f58b3fb48e5 in QEventLoop::exec (this=this@entry=0x7f583b65ed70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f58b3eb388f in QThread::exec (this=this@entry=0x2796b70) at thread/qthread.cpp:542
#9  0x00007f58b3f95d13 in QInotifyFileSystemWatcherEngine::run (this=0x2796b70) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f58b3eb5f2f in QThreadPrivate::start (arg=0x2796b70) at thread/qthread_unix.cpp:338
#11 0x00007f58ad7f3f6e in start_thread (arg=0x7f583b65f700) at pthread_create.c:311
#12 0x00007f58b38699cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f58b62f77c0 (LWP 12211)):
[KCrash Handler]
#6  0x00007f58b4d5ae54 in QAbstractSlider::maximum (this=0x7fff48907820) at widgets/qabstractslider.cpp:366
#7  0x00007f58b56812af in restoreScrollBarState (this=0x1a003a0) at ../../kdeui/itemviews/kviewstatesaver.cpp:64
#8  KViewStateSaver::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./kviewstatesaver.moc:53
#9  0x00007f58b3fcddce in QObject::event (this=0x1d85510, e=<optimized out>) at kernel/qobject.cpp:1194
#10 0x00007f58b49a6dfc in QApplicationPrivate::notify_helper (this=this@entry=0x13acca0, receiver=receiver@entry=0x1d85510, e=e@entry=0x1bd5310) at kernel/qapplication.cpp:4567
#11 0x00007f58b49ad470 in QApplication::notify (this=this@entry=0x7fff48909920, receiver=receiver@entry=0x1d85510, e=e@entry=0x1bd5310) at kernel/qapplication.cpp:4353
#12 0x00007f58b56b0c6a in KApplication::notify (this=0x7fff48909920, receiver=0x1d85510, event=0x1bd5310) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f58b3fb58bd in QCoreApplication::notifyInternal (this=0x7fff48909920, receiver=receiver@entry=0x1d85510, event=event@entry=0x1bd5310) at kernel/qcoreapplication.cpp:946
#14 0x00007f58b3fb8e1f in sendEvent (event=0x1bd5310, receiver=0x1d85510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x136b1d0) at kernel/qcoreapplication.cpp:1570
#16 0x00007f58b3fb92c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#17 0x00007f58b3fe3073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=0x1399390) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007f58ad31b3b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f58ad31b708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f58ad31b7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f58b3fe2a55 in QEventDispatcherGlib::processEvents (this=0x1399210, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007f58b4a489d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f58b3fb45ef in QEventLoop::processEvents (this=this@entry=0x7fff48909820, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f58b3fb48e5 in QEventLoop::exec (this=this@entry=0x7fff48909820, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007f58b3fb9e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#27 0x00007f58b49a534c in QApplication::exec () at kernel/qapplication.cpp:3828
#28 0x0000000000403660 in main (argc=1, argv=0x7fff48909a68) at ../../../kontact/src/main.cpp:219

Possible duplicates by query: bug 329828, bug 328755.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-26 01:22:21 UTC

*** This bug has been marked as a duplicate of bug 328755 ***