Bug 329828 - Kontact crashes on exit
Summary: Kontact crashes on exit
Status: RESOLVED DUPLICATE of bug 328755
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.12
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-10 22:45 UTC by Kirchkamp
Modified: 2014-01-11 05:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirchkamp 2014-01-10 22:45:40 UTC
Application: kontact (4.12)
KDE Platform Version: 4.12.0
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
Always when kontact exits, after a little while (1-60 seconds) the application crashes. 
It is, thus, impossible to save colours with calendars. Interestingly, the application does remember calendars between crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff7c45137c0 (LWP 2571))]

Thread 6 (Thread 0x7ff7a57cf700 (LWP 2572)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007ff7bf2ea1cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007ff7bf2ea209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007ff7bba0ff6e in start_thread (arg=0x7ff7a57cf700) at pthread_create.c:311
#4  0x00007ff7c1a859cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7ff764ebc700 (LWP 2573)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007ff7bf02abbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007ff7bf319a76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007ff7bba0ff6e in start_thread (arg=0x7ff764ebc700) at pthread_create.c:311
#4  0x00007ff7c1a859cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7ff74fcb5700 (LWP 2578)):
#0  0x00007ff7c1a78f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ff7bb5376a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff7bb5377ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff7c21fea76 in QEventDispatcherGlib::processEvents (this=0x7ff7480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff7c21d05ef in QEventLoop::processEvents (this=this@entry=0x7ff74fcb4db0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff7c21d08e5 in QEventLoop::exec (this=this@entry=0x7ff74fcb4db0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff7c20cf88f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007ff7c20d1f2f in QThreadPrivate::start (arg=0xe868e0) at thread/qthread_unix.cpp:338
#8  0x00007ff7bba0ff6e in start_thread (arg=0x7ff74fcb5700) at pthread_create.c:311
#9  0x00007ff7c1a859cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7ff74de52700 (LWP 2583)):
#0  0x00007ff7bb536ecc in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff7bb5375c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff7bb5377ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff7c21fea76 in QEventDispatcherGlib::processEvents (this=0x7ff7400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff7c21d05ef in QEventLoop::processEvents (this=this@entry=0x7ff74de51d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff7c21d08e5 in QEventLoop::exec (this=this@entry=0x7ff74de51d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff7c20cf88f in QThread::exec (this=this@entry=0x356c0b0) at thread/qthread.cpp:542
#7  0x00007ff7c21b1d13 in QInotifyFileSystemWatcherEngine::run (this=0x356c0b0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007ff7c20d1f2f in QThreadPrivate::start (arg=0x356c0b0) at thread/qthread_unix.cpp:338
#9  0x00007ff7bba0ff6e in start_thread (arg=0x7ff74de52700) at pthread_create.c:311
#10 0x00007ff7c1a859cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7ff755bcf700 (LWP 7225)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007ff75c3e506b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007ff75c3e50a9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007ff7bba0ff6e in start_thread (arg=0x7ff755bcf700) at pthread_create.c:311
#4  0x00007ff7c1a859cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7ff7c45137c0 (LWP 2571)):
[KCrash Handler]
#6  QAbstractSlider::maximum (this=0x0) at widgets/qabstractslider.cpp:366
#7  0x00007ff7c389d2af in restoreScrollBarState (this=0x1b09c50) at ../../kdeui/itemviews/kviewstatesaver.cpp:64
#8  KViewStateSaver::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./kviewstatesaver.moc:53
#9  0x00007ff7c21e9dce in QObject::event (this=0x674efe0, e=<optimized out>) at kernel/qobject.cpp:1194
#10 0x00007ff7c2bc2dfc in QApplicationPrivate::notify_helper (this=this@entry=0xc03c40, receiver=receiver@entry=0x674efe0, e=e@entry=0x9ce0680) at kernel/qapplication.cpp:4567
#11 0x00007ff7c2bc9470 in QApplication::notify (this=this@entry=0x7fff67985820, receiver=receiver@entry=0x674efe0, e=e@entry=0x9ce0680) at kernel/qapplication.cpp:4353
#12 0x00007ff7c38ccc6a in KApplication::notify (this=0x7fff67985820, receiver=0x674efe0, event=0x9ce0680) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007ff7c21d18bd in QCoreApplication::notifyInternal (this=0x7fff67985820, receiver=receiver@entry=0x674efe0, event=event@entry=0x9ce0680) at kernel/qcoreapplication.cpp:946
#14 0x00007ff7c21d4e1f in sendEvent (event=0x9ce0680, receiver=0x674efe0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xbc31d0) at kernel/qcoreapplication.cpp:1570
#16 0x00007ff7c21d52c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#17 0x00007ff7c21ff073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=0xbfd810) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007ff7bb5373b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007ff7bb537708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007ff7bb5377ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007ff7c21fea55 in QEventDispatcherGlib::processEvents (this=0xbf1210, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007ff7c2c649d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007ff7c21d05ef in QEventLoop::processEvents (this=this@entry=0x7fff67985720, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007ff7c21d08e5 in QEventLoop::exec (this=this@entry=0x7fff67985720, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007ff7c21d5e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#27 0x00007ff7c2bc134c in QApplication::exec () at kernel/qapplication.cpp:3828
#28 0x0000000000403660 in main (argc=1, argv=0x7fff67985968) at ../../../kontact/src/main.cpp:219

The reporter indicates this bug may be a duplicate of or related to bug 328755.

Possible duplicates by query: bug 328755.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-11 05:41:07 UTC

*** This bug has been marked as a duplicate of bug 328755 ***