Bug 329995 - When %SIGNATURE is used in reply template everything else is ignored
Summary: When %SIGNATURE is used in reply template everything else is ignored
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 4.12
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-15 14:49 UTC by Pierre
Modified: 2014-01-17 08:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2014-01-15 14:49:51 UTC
This happens since 4.12, with 4.11 it still worked.
Related bugs:
https://bugs.kde.org/show_bug.cgi?id=324229
https://bugs.kde.org/show_bug.cgi?id=315431

Reproducible: Always

Steps to Reproduce:
1. Insert %SIGNATURE anywhere in "Reply to Sender" template
2. Reply to email
Actual Results:  
Composer window only contains signature, no quote or anything else that is configured in the reply template.

Expected Results:  
Composer window should contain everything that is set in the reply template.
Comment 1 Laurent Montel 2014-01-15 15:13:31 UTC
I will investigate it.
Comment 2 Laurent Montel 2014-01-16 07:05:52 UTC
Could you paste you template code please ?
Comment 3 Pierre 2014-01-16 11:10:07 UTC
Sure:

%REM="Default reply template"%-
%CURSOR
%BLANK
%SIGNATURE
On %ODATE %OTIMELONG you wrote:
%QUOTE

But it does not really matter.