Bug 324229 - Bug in the Emaileditor. The %CURSOR did not work in the template to send a new mail
Summary: Bug in the Emaileditor. The %CURSOR did not work in the template to send a ne...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Unclassified
Component: config dialog (show other bugs)
Version: 4.10.5
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-29 16:46 UTC by Martin Brugger
Modified: 2017-01-07 21:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Brugger 2013-08-29 16:46:34 UTC
Under the Kmail Settings i want to configure a default template for sending a new email.

My Configuration for the Email Editor looks like:

%CURSOR
%SIGNATURE

but the Cursor will not jump into the first line.






Reproducible: Always
Comment 1 Laurent Montel 2013-08-31 09:06:01 UTC
Will investigate it.
Comment 2 Laurent Montel 2013-09-04 17:44:17 UTC
it's when you reply to email ? or create new ? etc.
Comment 3 Martin Brugger 2013-09-04 22:26:34 UTC
Its only when i create new mail!
Comment 4 Laurent Montel 2013-09-05 05:35:58 UTC
Ok can reproduce it
Will investigate
Comment 5 Laurent Montel 2013-09-17 07:31:28 UTC
Git commit e4431d53527bed29a206d8ba4793a377765297c2 by Montel Laurent.
Committed on 17/09/2013 at 07:30.
Pushed by mlaurent into branch 'KDE/4.11'.

Fix Bug 324229 - Bug in the Emaileditor. The %CURSOR did not work in the template to send a new mail

FIXED-IN: 4.11.2

M  +1    -1    kmail/kmmainwidget.cpp

http://commits.kde.org/kdepim/e4431d53527bed29a206d8ba4793a377765297c2
Comment 6 Martin Brugger 2013-10-26 20:10:20 UTC
Hello Mr. Montel,

i am sorry but the bug is not fixed in 4.11.2

Best Regards

Martin Brugger

Dienstag, 17. September 2013, 07:31:28 - Martin Brugger schrieb:
> https://bugs.kde.org/show_bug.cgi?id=324229
> 
> Laurent Montel <montel@kde.org> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>    Version Fixed In|                            |4.11.2
>          Resolution|---                         |FIXED
>       Latest Commit|                            |http://commits.kde.org/kdep
>                    |                            |im/e4431d53527bed29a206d8ba
>                    |                            |4793a377765297c2
> 
> --- Comment #5 from Laurent Montel <montel@kde.org> ---
> Git commit e4431d53527bed29a206d8ba4793a377765297c2 by Montel Laurent.
> Committed on 17/09/2013 at 07:30.
> Pushed by mlaurent into branch 'KDE/4.11'.
> 
> Fix Bug 324229 - Bug in the Emaileditor. The %CURSOR did not work in the
> template to send a new mail
> 
> FIXED-IN: 4.11.2
> 
> M  +1    -1    kmail/kmmainwidget.cpp
> 
> http://commits.kde.org/kdepim/e4431d53527bed29a206d8ba4793a377765297c2
> 
> -- 
> You are receiving this mail because:
> You reported the bug.
Comment 7 Martin Brugger 2013-11-22 12:43:10 UTC
Sorry but is not fixed in 4.11.2
Comment 8 Tilman Klaeger 2013-12-22 19:08:30 UTC
I have got a similiar bug in KDE 4.12.0. I can use %CURSOR in the template without any problems, but adding %SIGNATURE breaks everything and only the signature is shown, without the text I put above or below.
Don´t know if this is a different bug or is caused by the same piece of code. With KDE 4.11 the templates with signature worked very well!
Comment 9 Denis Kurz 2016-09-24 18:24:22 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 10 Denis Kurz 2017-01-07 21:33:52 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.