Bug 328654 - Kickoff application navigation is broken
Summary: Kickoff application navigation is broken
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: master
Platform: unspecified Linux
: NOR normal
Target Milestone: 1.0
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks: 328586
  Show dependency treegraph
 
Reported: 2013-12-11 11:06 UTC by Alex Fiestas
Modified: 2013-12-20 19:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
video of the brokeness (3.29 MB, video/x-matroska)
2013-12-11 11:06 UTC, Alex Fiestas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Fiestas 2013-12-11 11:06:19 UTC
See attached video for all the issues

Reproducible: Always

Steps to Reproduce:
Open kickoff, try to execute an app
Comment 1 Alex Fiestas 2013-12-11 11:06:56 UTC
Created attachment 84030 [details]
video of the brokeness
Comment 2 Martin Klapetek 2013-12-20 15:28:31 UTC
Git commit 67a3129f74ba466fde46cc92233b15d5f747fa02 by Martin Klapetek.
Committed on 20/12/2013 at 15:25.
Pushed by mklapetek into branch 'master'.

[Kickoff] Disable layoutChange signals; fixes Kickoff's navigation

The breadcrumb issues still remain, apparently it happens because
ListModel is unable to store QVariant(QModelIndex).

M  +10   -3    plasma/desktop/applets/kickoff/core/applicationmodel.cpp

http://commits.kde.org/kde-workspace/67a3129f74ba466fde46cc92233b15d5f747fa02
Comment 3 Martin Klapetek 2013-12-20 19:29:00 UTC
Git commit 3e034d3c1da4b3605b953b94065d1bd3233079fb by Martin Klapetek.
Committed on 20/12/2013 at 19:28.
Pushed by mklapetek into branch 'master'.

[Kickoff] Fix breadcrumb navigation

Workaround for ListModel not being able to store QVariant(QModelIndex)
values. Now it's stored in another model property. Makes the breadcrumb
navigation work again.

M  +5    -2    plasma/desktop/applets/kickoff/package/contents/ui/ApplicationsView.qml
M  +5    -4    plasma/desktop/applets/kickoff/package/contents/ui/Breadcrumb.qml

http://commits.kde.org/kde-workspace/3e034d3c1da4b3605b953b94065d1bd3233079fb