Bug 326689 - Digikam crashes while tagging faces
Summary: Digikam crashes while tagging faces
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Engine (show other bugs)
Version: 3.4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-26 14:52 UTC by aj_
Modified: 2019-12-23 06:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments
New crash information added by DrKonqi (9.47 KB, text/plain)
2014-01-02 07:21 UTC, Vincent Villatte
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aj_ 2013-10-26 14:52:22 UTC
Application: digikam (3.4.0)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
I tagged a recogniced face with a name, when I clicked on OK it crashed.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xad537900 (LWP 13172))]

Thread 10 (Thread 0xad50eb40 (LWP 13180)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb4a79a0b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xadb9c392 in ?? () from /lib/i386-linux-gnu/libusb-1.0.so.0
#3  0xb3214d78 in start_thread (arg=0xad50eb40) at pthread_create.c:311
#4  0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 9 (Thread 0xaaf88b40 (LWP 13186)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb4a778db in read () at ../sysdeps/unix/syscall-template.S:81
#2  0xb2e38d4e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2df665b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2df6afa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2df704b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xadd0f32a in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#7  0xb2e1cc4a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb3214d78 in start_thread (arg=0xaaf88b40) at pthread_create.c:311
#9  0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 8 (Thread 0xaa4f0b40 (LWP 13187)):
#0  0xb2df6107 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2df6a5f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2df6ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2df6d2e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2e1cc4a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb3214d78 in start_thread (arg=0xaa4f0b40) at pthread_create.c:311
#6  0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 7 (Thread 0xa90ffb40 (LWP 13228)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb321884b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb4a969bc in __pthread_cond_wait (cond=0x94d5180, mutex=0x94d5168) at forward.c:149
#3  0xb4d78ca5 in wait (time=4294967295, this=0x94d5168) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=this@entry=0x94d50dc, mutex=mutex@entry=0x94d50d8, time=time@entry=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x0820d9c4 in Digikam::ScanController::run (this=0x94eb398) at /build/buildd/digikam-3.4.0/core/digikam/database/scancontroller.cpp:725
#6  0xb4d7872f in QThreadPrivate::start (arg=0x94eb398) at thread/qthread_unix.cpp:338
#7  0xb3214d78 in start_thread (arg=0xa90ffb40) at pthread_create.c:311
#8  0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 6 (Thread 0xa7e85b40 (LWP 13229)):
#0  0xb2e3986e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2e39ba8 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2df6009 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2df6a5f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2df6ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4eb78df in QEventDispatcherGlib::processEvents (this=0xa91026e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4e869f3 in QEventLoop::processEvents (this=this@entry=0xa7e85068, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4e86d19 in QEventLoop::exec (this=this@entry=0xa7e85068, flags=...) at kernel/qeventloop.cpp:204
#8  0xb4d75e3d in QThread::exec (this=this@entry=0x94ee4a0) at thread/qthread.cpp:542
#9  0xb4e66e14 in QInotifyFileSystemWatcherEngine::run (this=0x94ee4a0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb4d7872f in QThreadPrivate::start (arg=0x94ee4a0) at thread/qthread_unix.cpp:338
#11 0xb3214d78 in start_thread (arg=0xa7e85b40) at pthread_create.c:311
#12 0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 5 (Thread 0xa9affb40 (LWP 13290)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb321884b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb4a969bc in __pthread_cond_wait (cond=0x984c068, mutex=0x984c050) at forward.c:149
#3  0xb4d78ca5 in wait (time=4294967295, this=0x984c050) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=this@entry=0x984b248, mutex=mutex@entry=0x984b244, time=time@entry=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6984d54 in Digikam::ParkingThread::run (this=0x984b238) at /build/buildd/digikam-3.4.0/core/libs/threads/threadmanager.cpp:119
#6  0xb4d7872f in QThreadPrivate::start (arg=0x984b238) at thread/qthread_unix.cpp:338
#7  0xb3214d78 in start_thread (arg=0xa9affb40) at pthread_create.c:311
#8  0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 4 (Thread 0x9da83b40 (LWP 13608)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb4a79a0b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb2e05a4b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2df6b68 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2df6ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4eb78df in QEventDispatcherGlib::processEvents (this=0xa7087448, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4e869f3 in QEventLoop::processEvents (this=this@entry=0x9da83068, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4e86d19 in QEventLoop::exec (this=this@entry=0x9da83068, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6984322 in Digikam::WorkerObjectRunnable::run (this=0xaa6ee920) at /build/buildd/digikam-3.4.0/core/libs/threads/threadmanager.cpp:196
#9  0xb4d6b63a in QThreadPoolThread::run (this=0xaa629920) at concurrent/qthreadpool.cpp:107
#10 0xb4d7872f in QThreadPrivate::start (arg=0xaa629920) at thread/qthread_unix.cpp:338
#11 0xb3214d78 in start_thread (arg=0x9da83b40) at pthread_create.c:311
#12 0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 3 (Thread 0x99805b40 (LWP 13616)):
#0  0xb2e39bd0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2df6a00 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2df6ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4eb78df in QEventDispatcherGlib::processEvents (this=0xbaf8448, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0xb4e869f3 in QEventLoop::processEvents (this=this@entry=0x99805068, flags=...) at kernel/qeventloop.cpp:149
#5  0xb4e86d19 in QEventLoop::exec (this=this@entry=0x99805068, flags=...) at kernel/qeventloop.cpp:204
#6  0xb6984322 in Digikam::WorkerObjectRunnable::run (this=0xa709e250) at /build/buildd/digikam-3.4.0/core/libs/threads/threadmanager.cpp:196
#7  0xb4d6b63a in QThreadPoolThread::run (this=0xa923680) at concurrent/qthreadpool.cpp:107
#8  0xb4d7872f in QThreadPrivate::start (arg=0xa923680) at thread/qthread_unix.cpp:338
#9  0xb3214d78 in start_thread (arg=0x99805b40) at pthread_create.c:311
#10 0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 2 (Thread 0x99004b40 (LWP 13617)):
#0  0xb2e39887 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2e39be8 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2df5b72 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2df6a08 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2df6ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4eb78df in QEventDispatcherGlib::processEvents (this=0xc7899c8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4e869f3 in QEventLoop::processEvents (this=this@entry=0x99004068, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4e86d19 in QEventLoop::exec (this=this@entry=0x99004068, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6984322 in Digikam::WorkerObjectRunnable::run (this=0xa9bfd418) at /build/buildd/digikam-3.4.0/core/libs/threads/threadmanager.cpp:196
#9  0xb4d6b63a in QThreadPoolThread::run (this=0xa9216d8) at concurrent/qthreadpool.cpp:107
#10 0xb4d7872f in QThreadPrivate::start (arg=0xa9216d8) at thread/qthread_unix.cpp:338
#11 0xb3214d78 in start_thread (arg=0x99004b40) at pthread_create.c:311
#12 0xb4a8901e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xad537900 (LWP 13172)):
[KCrash Handler]
#7  0x0824ddfa in data (arole=37, this=0xdfa86f8) at /usr/include/qt4/QtCore/qabstractitemmodel.h:402
#8  Digikam::AssignNameOverlay::checkIndex (this=0x996e528, index=...) at /build/buildd/digikam-3.4.0/core/digikam/items/assignnameoverlay.cpp:239
#9  0xb69dace2 in Digikam::AbstractWidgetDelegateOverlay::checkIndexOnEnter (this=0x996e528, index=...) at /build/buildd/digikam-3.4.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:282
#10 0xb69dad87 in Digikam::PersistentWidgetDelegateOverlay::slotEntered (this=0x996e528, index=...) at /build/buildd/digikam-3.4.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:577
#11 0xb69db153 in Digikam::PersistentWidgetDelegateOverlay::setPersistent (this=0x996e528, persistent=false) at /build/buildd/digikam-3.4.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:536
#12 0xb69db2f3 in Digikam::PersistentWidgetDelegateOverlay::leavePersistentMode (this=this@entry=0x996e528) at /build/buildd/digikam-3.4.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:558
#13 0x0824ec24 in Digikam::AssignNameOverlay::eventFilter (this=0x996e528, o=0xbdba320, e=0xbfd258d0) at /build/buildd/digikam-3.4.0/core/digikam/items/assignnameoverlay.cpp:349
#14 0xb4e8804e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x92cfa50, receiver=receiver@entry=0xbdba320, event=event@entry=0xbfd258d0) at kernel/qcoreapplication.cpp:1056
#15 0xb53e3721 in QApplicationPrivate::notify_helper (this=0x92cfa50, receiver=0xbdba320, e=0xbfd258d0) at kernel/qapplication.cpp:4563
#16 0xb53ea223 in QApplication::notify (this=0xbfd26328, receiver=receiver@entry=0xbdba320, e=e@entry=0xbfd258d0) at kernel/qapplication.cpp:4353
#17 0xb5f30ff4 in KApplication::notify (this=0xbfd26328, receiver=0xbdba320, event=0xbfd258d0) at ../../kdeui/kernel/kapplication.cpp:311
#18 0xb4e87eda in QCoreApplication::notifyInternal (this=0xbfd26328, receiver=receiver@entry=0xbdba320, event=event@entry=0xbfd258d0) at kernel/qcoreapplication.cpp:946
#19 0xb53e82a1 in sendEvent (event=0xbfd258d0, receiver=0xbdba320) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QApplicationPrivate::setFocusWidget (focus=focus@entry=0x9acf230, reason=reason@entry=Qt::MouseFocusReason) at kernel/qapplication.cpp:2268
#21 0xb5437938 in QWidget::setFocus (this=this@entry=0x9acf230, reason=reason@entry=Qt::MouseFocusReason) at kernel/qwidget.cpp:6463
#22 0xb53e1d90 in QApplicationPrivate::giveFocusAccordingToFocusPolicy (widget=0xcf00208, focusPolicy=focusPolicy@entry=Qt::ClickFocus, focusReason=focusReason@entry=Qt::MouseFocusReason) at kernel/qapplication.cpp:5601
#23 0xb53ebcb8 in QApplication::notify (this=0xbfd26328, receiver=receiver@entry=0xcf00208, e=e@entry=0xbfd25c74) at kernel/qapplication.cpp:4067
#24 0xb5f30ff4 in KApplication::notify (this=0xbfd26328, receiver=0xcf00208, event=0xbfd25c74) at ../../kdeui/kernel/kapplication.cpp:311
#25 0xb4e87eda in QCoreApplication::notifyInternal (this=0xbfd26328, receiver=receiver@entry=0xcf00208, event=event@entry=0xbfd25c74) at kernel/qcoreapplication.cpp:946
#26 0xb53e9aa3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#27 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0xcf00208, event=0xbfd25c74, alienWidget=0xcf00208, nativeWidget=0x9acf230, buttonDown=buttonDown@entry=0xb5d58cc4 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3178
#28 0xb546d4e8 in QETWidget::translateMouseEvent (this=0x9acf230, event=event@entry=0xbfd25e9c) at kernel/qapplication_x11.cpp:4631
#29 0xb546cc05 in QApplication::x11ProcessEvent (this=0xbfd26328, event=event@entry=0xbfd25e9c) at kernel/qapplication_x11.cpp:3624
#30 0xb5498274 in x11EventSourceDispatch (s=0x92ce448, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#31 0xb2df683e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb2df6be8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb2df6ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb4eb78bf in QEventDispatcherGlib::processEvents (this=this@entry=0x9249010, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0xb549832e in QGuiEventDispatcherGlib::processEvents (this=0x9249010, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0xb4e869f3 in QEventLoop::processEvents (this=this@entry=0xbfd26158, flags=...) at kernel/qeventloop.cpp:149
#37 0xb4e86d19 in QEventLoop::exec (this=this@entry=0xbfd26158, flags=...) at kernel/qeventloop.cpp:204
#38 0xb4e8c89e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#39 0xb53e1974 in QApplication::exec () at kernel/qapplication.cpp:3828
#40 0x080bc0b0 in main (argc=5, argv=0xbfd26464) at /build/buildd/digikam-3.4.0/core/digikam/main/main.cpp:235

The reporter indicates this bug may be a duplicate of or related to bug 297558.

Possible duplicates by query: bug 315497, bug 309142.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-06 10:18:07 UTC

*** This bug has been marked as a duplicate of bug 297558 ***
Comment 2 Vincent Villatte 2014-01-02 07:21:11 UTC
Created attachment 84404 [details]
New crash information added by DrKonqi

digikam (2.5.0) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:

I was tagging new faces.

I also noticed that DigiKam crashes when searching for new faces. I usually let it run as it takes a while, when I came back after a while it had closed off and when I restarted it only approximately a 100 new faces had been added. I was not interacting with the computer at the time.

I am running DigiKam in Gnome (UBUNTU 12.04LTS)

-- Backtrace (Reduced):
#6  0x0000000000607f3f in data (arole=37, this=0x65feea0) at /usr/include/qt4/QtCore/qabstractitemmodel.h:402
#7  Digikam::AssignNameOverlay::checkIndex (this=<optimized out>, index=...) at /build/buildd/digikam-2.5.0/core/digikam/items/assignnameoverlay.cpp:241
#8  0x00007f703b4f41ff in checkIndexOnEnter (index=..., this=0x1bee660) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:282
#9  Digikam::AbstractWidgetDelegateOverlay::checkIndexOnEnter (this=0x1bee660, index=...) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:270
#10 0x00007f703b4f4267 in Digikam::PersistentWidgetDelegateOverlay::slotEntered (this=0x1bee660, index=...) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:577
Comment 3 caulier.gilles 2019-12-23 06:21:54 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier