Bug 309142 - Face Crash
Summary: Face Crash
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Engine (show other bugs)
Version: 2.5.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-28 13:13 UTC by Derek
Modified: 2019-12-23 06:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek 2012-10-28 13:13:12 UTC
Application: digikam (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-32-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Crashed while typing in a new name on the face.  It occured while hovering over the face area that the name is suppose to be typed in.  No warning, just closed.

The crash can be reproduced some of the time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xaeabc8c0 (LWP 19930))]

Thread 6 (Thread 0xace2db40 (LWP 19933)):
#0  0xb480da1a in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0xb47f15d8 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb31aca7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb319f0ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb319f56b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xace32134 in ?? () from /usr/lib/i386-linux-gnu/gio/modules/libdconfsettings.so
#6  0xb31c26b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb3546d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb47ffd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xac4ffb40 (LWP 19934)):
#0  0xb480da1a in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0xb47f15d8 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb31aca7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb319f0ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb319f56b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xaf8f11ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb31c26b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb3546d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb47ffd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xaa658b40 (LWP 19936)):
#0  0xb778c424 in __kernel_vsyscall ()
#1  0xb354a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb480d64c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4ad3350 in wait (time=4294967295, this=0x91e0d18) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x91dbc14, mutex=0x91dbc10, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x0820346e in Digikam::ScanController::run (this=0x91e0b78) at /build/buildd/digikam-2.5.0/core/digikam/database/scancontroller.cpp:647
#6  0xb4ad2de0 in QThreadPrivate::start (arg=0x91e0b78) at thread/qthread_unix.cpp:298
#7  0xb3546d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb47ffd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa9cffb40 (LWP 19937)):
#0  0xb31de0f6 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb31de3c8 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb319eb85 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb319f042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb319f201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4c1a8e7 in QEventDispatcherGlib::processEvents (this=0xa9300468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4be650d in QEventLoop::processEvents (this=0xa9cff0c0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4be67a9 in QEventLoop::exec (this=0xa9cff0c0, flags=...) at kernel/qeventloop.cpp:204
#8  0xb4acf94c in QThread::exec (this=0x91dcb08) at thread/qthread.cpp:501
#9  0xb4bc3b5d in QInotifyFileSystemWatcherEngine::run (this=0x91dcb08) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb4ad2de0 in QThreadPrivate::start (arg=0x91dcb08) at thread/qthread_unix.cpp:298
#11 0xb3546d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb47ffd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xabaffb40 (LWP 20012)):
#0  0xb778c424 in __kernel_vsyscall ()
#1  0xb354a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb480d64c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4ad3350 in wait (time=4294967295, this=0x93f3860) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x93f36a0, mutex=0x93f369c, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6a88b2c in Digikam::ParkingThread::run (this=0x93f3690) at /build/buildd/digikam-2.5.0/core/libs/threads/threadmanager.cpp:119
#6  0xb4ad2de0 in QThreadPrivate::start (arg=0x93f3690) at thread/qthread_unix.cpp:298
#7  0xb3546d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb47ffd3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xaeabc8c0 (LWP 19930)):
[KCrash Handler]
#7  0x082449bd in data (arole=<optimized out>, this=<optimized out>) at /usr/include/qt4/QtCore/qabstractitemmodel.h:402
#8  Digikam::AssignNameOverlay::checkIndex (this=0x95c9d40, index=...) at /build/buildd/digikam-2.5.0/core/digikam/items/assignnameoverlay.cpp:241
#9  0xb6ae593d in checkIndexOnEnter (index=..., this=0x95c9d40) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:282
#10 Digikam::AbstractWidgetDelegateOverlay::checkIndexOnEnter (this=0x95c9d40, index=...) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:270
#11 0xb6ae59bc in Digikam::PersistentWidgetDelegateOverlay::slotEntered (this=0x95c9d40, index=...) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:577
#12 0xb6ae5e4b in setPersistent (this=<optimized out>, persistent=<optimized out>) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:542
#13 Digikam::PersistentWidgetDelegateOverlay::setPersistent (this=0x95c9d40, persistent=false) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:525
#14 0xb6ae6023 in Digikam::PersistentWidgetDelegateOverlay::leavePersistentMode (this=0x95c9d40) at /build/buildd/digikam-2.5.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:558
#15 0x082448d4 in Digikam::AssignNameOverlay::eventFilter (this=0x95c9d40, o=0x94baea8, e=0xbfd5cd00) at /build/buildd/digikam-2.5.0/core/digikam/items/assignnameoverlay.cpp:351
#16 0xb4be7b16 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x902afa8, receiver=0x94baea8, event=0xbfd5cd00) at kernel/qcoreapplication.cpp:986
#17 0xb5153ea2 in notify_helper (e=0xbfd5cd00, receiver=0x94baea8, this=0x902afa8) at kernel/qapplication.cpp:4555
#18 QApplicationPrivate::notify_helper (this=0x902afa8, receiver=0x94baea8, e=0xbfd5cd00) at kernel/qapplication.cpp:4531
#19 0xb51593a2 in QApplication::notify (this=0x902afa8, receiver=0x94baea8, e=0xbfd5cd00) at kernel/qapplication.cpp:4524
#20 0xb5cd8e01 in KApplication::notify (this=0xbfd5daa0, receiver=0x94baea8, event=0xbfd5cd00) at ../../kdeui/kernel/kapplication.cpp:311
#21 0xb4be797e in QCoreApplication::notifyInternal (this=0xbfd5daa0, receiver=0x94baea8, event=0xbfd5cd00) at kernel/qcoreapplication.cpp:876
#22 0xb515240a in sendEvent (event=0xbfd5cd00, receiver=0x94baea8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QApplicationPrivate::setFocusWidget (focus=0x93ffa80, reason=Qt::MouseFocusReason) at kernel/qapplication.cpp:2260
#24 0xb519fe1b in QWidget::setFocus (this=0x93ffa80, reason=Qt::MouseFocusReason) at kernel/qwidget.cpp:6450
#25 0xb5151eb0 in QApplicationPrivate::giveFocusAccordingToFocusPolicy (widget=0x95aadf8, focusPolicy=Qt::ClickFocus, focusReason=Qt::MouseFocusReason) at kernel/qapplication.cpp:5593
#26 0xb515b4e4 in QApplication::notify (this=0xbfd5daa0, receiver=0x95aadf8, e=0xbfd5d1d4) at kernel/qapplication.cpp:4059
#27 0xb5cd8e01 in KApplication::notify (this=0xbfd5daa0, receiver=0x95aadf8, event=0xbfd5d1d4) at ../../kdeui/kernel/kapplication.cpp:311
#28 0xb4be797e in QCoreApplication::notifyInternal (this=0xbfd5daa0, receiver=0x95aadf8, event=0xbfd5d1d4) at kernel/qcoreapplication.cpp:876
#29 0xb5154e95 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QApplicationPrivate::sendMouseEvent (receiver=0x95aadf8, event=0xbfd5d1d4, alienWidget=0x95aadf8, nativeWidget=0x93ffa80, buttonDown=0xb5ae8cf4, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#31 0xb51e1074 in QETWidget::translateMouseEvent (this=0x93ffa80, event=0xbfd5d68c) at kernel/qapplication_x11.cpp:4617
#32 0xb51dfc0d in QApplication::x11ProcessEvent (this=0xbfd5daa0, event=0xbfd5d68c) at kernel/qapplication_x11.cpp:3732
#33 0xb520ceac in x11EventSourceDispatch (s=0x902ad58, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#34 0xb319ed86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb319f125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb319f201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0xb4c1a887 in QEventDispatcherGlib::processEvents (this=0x8fe78a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#38 0xb520caaa in QGuiEventDispatcherGlib::processEvents (this=0x8fe78a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0xb4be650d in QEventLoop::processEvents (this=0xbfd5d984, flags=...) at kernel/qeventloop.cpp:149
#40 0xb4be67a9 in QEventLoop::exec (this=0xbfd5d984, flags=...) at kernel/qeventloop.cpp:204
#41 0xb4bebeba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#42 0xb5151a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#43 0x080b69e4 in main (argc=<error reading variable: Cannot access memory at address 0x360031>, argv=<error reading variable: Cannot access memory at address 0x360035>) at /build/buildd/digikam-2.5.0/core/digikam/main/main.cpp:232

Possible duplicates by query: bug 303328, bug 301506, bug 297558, bug 287961, bug 285517.

Reported using DrKonqi
Comment 1 caulier.gilles 2012-10-28 13:38:26 UTC

*** This bug has been marked as a duplicate of bug 297558 ***
Comment 2 caulier.gilles 2019-12-23 06:22:22 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier