Bug 326449 - Kontact crashes on decryption of PGP encrypted message
Summary: Kontact crashes on decryption of PGP encrypted message
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-22 15:32 UTC by Samir Nassar
Modified: 2013-10-23 01:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samir Nassar 2013-10-22 15:32:24 UTC
Application: kontact (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-12-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

Decrypting a PGP encrypted message. Kleopatra is not configured yet.

- Unusual behavior I noticed:

Upon entering my passphrase and hitting enter Kontact crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f797de7b7c0 (LWP 5734))]

Thread 7 (Thread 0x7f795f783700 (LWP 5735)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7978c581cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f7978c58209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f7975382f6e in start_thread (arg=0x7f795f783700) at pthread_create.c:311
#4  0x00007f797b3e59cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 6 (Thread 0x7f791ee80700 (LWP 5736)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7978998bbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f7978c87a76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f7975382f6e in start_thread (arg=0x7f791ee80700) at pthread_create.c:311
#4  0x00007f797b3e59cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7f790f85a700 (LWP 5742)):
#0  0x00007f7974eea0e6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7974eea389 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7974ea9c07 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7974eaa5b3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7974eaa79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f797bb5ea76 in QEventDispatcherGlib::processEvents (this=0x7f79000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f797bb305ef in QEventLoop::processEvents (this=this@entry=0x7f790f859d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f797bb308e5 in QEventLoop::exec (this=this@entry=0x7f790f859d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f797ba2f88f in QThread::exec (this=this@entry=0x26b1af0) at thread/qthread.cpp:542
#9  0x00007f797bb11d13 in QInotifyFileSystemWatcherEngine::run (this=0x26b1af0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f797ba31f2f in QThreadPrivate::start (arg=0x26b1af0) at thread/qthread_unix.cpp:338
#11 0x00007f7975382f6e in start_thread (arg=0x7f790f85a700) at pthread_create.c:311
#12 0x00007f797b3e59cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f790df77700 (LWP 5744)):
#0  0x00007f7974ea9d30 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7974eaa5b3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7974eaa79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f797bb5ea76 in QEventDispatcherGlib::processEvents (this=0x7f78f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f797bb305ef in QEventLoop::processEvents (this=this@entry=0x7f790df76db0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f797bb308e5 in QEventLoop::exec (this=this@entry=0x7f790df76db0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f797ba2f88f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f797ba31f2f in QThreadPrivate::start (arg=0x221eac0) at thread/qthread_unix.cpp:338
#8  0x00007f7975382f6e in start_thread (arg=0x7f790df77700) at pthread_create.c:311
#9  0x00007f797b3e59cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f78efd59700 (LWP 5795)):
#0  0x00007fffe77fe993 in clock_gettime ()
#1  0x00007f797b3fa96d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f797ba86757 in do_gettime (frac=0x7f78efd58b00, sec=0x7f78efd58af8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f797bb5ffe5 in updateCurrentTime (this=0x7f78e8002860) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x7f78e8002860, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x00007f797bb5e82c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f78efd58bb4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f797bb5e8d5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f7974ea9d3d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f7974eaa5b3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f7974eaa79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f797bb5ea76 in QEventDispatcherGlib::processEvents (this=0x7f78e80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f797bb305ef in QEventLoop::processEvents (this=this@entry=0x7f78efd58d70, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f797bb308e5 in QEventLoop::exec (this=this@entry=0x7f78efd58d70, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f797ba2f88f in QThread::exec (this=this@entry=0x3f76820) at thread/qthread.cpp:542
#15 0x00007f797bb11d13 in QInotifyFileSystemWatcherEngine::run (this=0x3f76820) at io/qfilesystemwatcher_inotify.cpp:265
#16 0x00007f797ba31f2f in QThreadPrivate::start (arg=0x3f76820) at thread/qthread_unix.cpp:338
#17 0x00007f7975382f6e in start_thread (arg=0x7f78efd59700) at pthread_create.c:311
#18 0x00007f797b3e59cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f78f511b700 (LWP 7845)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f791213106b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f79121310a9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f7975382f6e in start_thread (arg=0x7f78f511b700) at pthread_create.c:311
#4  0x00007f797b3e59cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f797de7b7c0 (LWP 5734)):
[KCrash Handler]
#6  0x00007f79719fd434 in KMime::Content::parent (this=this@entry=0x4bc6a70) at ../../kmime/kmime_content.cpp:953
#7  0x00007f791628c807 in MessageCore::NodeHelper::nextSibling (node=node@entry=0x4bc6a70) at ../../messagecore/helpers/nodehelper.cpp:32
#8  0x00007f7914852f3f in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=this@entry=0x7fffe777dd50, node=node@entry=0x4bc6a70) at ../../messageviewer/viewer/objecttreeparser.cpp:296
#9  0x00007f7914854a29 in MessageViewer::ObjectTreeParser::parseObjectTree (this=this@entry=0x7fffe777dd50, node=node@entry=0x4bc6a70) at ../../messageviewer/viewer/objecttreeparser.cpp:266
#10 0x00007f7914880c78 in MessageViewer::ViewerPrivate::parseContent (this=this@entry=0x26586e0, content=0x4bc6a70) at ../../messageviewer/viewer/viewer_p.cpp:1007
#11 0x00007f7914881422 in MessageViewer::ViewerPrivate::displayMessage (this=this@entry=0x26586e0) at ../../messageviewer/viewer/viewer_p.cpp:879
#12 0x00007f791488206e in MessageViewer::ViewerPrivate::updateReaderWin (this=0x26586e0) at ../../messageviewer/viewer/viewer_p.cpp:2270
#13 0x00007f791488986d in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0x26586e0, _c=4294967295, _id=0, _a=0x7f797b6ac748 <main_arena+8>) at ./viewer_p.moc:255
#14 0x00007f797bb45a58 in QMetaObject::activate (sender=0x2658770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#15 0x00007f797bb49be1 in QObject::event (this=0x2658770, e=<optimized out>) at kernel/qobject.cpp:1156
#16 0x00007f797c522dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1f61980, receiver=receiver@entry=0x2658770, e=e@entry=0x7fffe777e480) at kernel/qapplication.cpp:4567
#17 0x00007f797c529470 in QApplication::notify (this=this@entry=0x7fffe777e800, receiver=receiver@entry=0x2658770, e=e@entry=0x7fffe777e480) at kernel/qapplication.cpp:4353
#18 0x00007f797d22ca6a in KApplication::notify (this=0x7fffe777e800, receiver=0x2658770, event=0x7fffe777e480) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f797bb318bd in QCoreApplication::notifyInternal (this=0x7fffe777e800, receiver=0x2658770, event=0x7fffe777e480) at kernel/qcoreapplication.cpp:946
#20 0x00007f797bb61403 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QTimerInfoList::activateTimers (this=0x1f61ed0) at kernel/qeventdispatcher_unix.cpp:622
#22 0x00007f797bb5e7a1 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#23 0x00007f7974eaa3a6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f7974eaa6f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f7974eaa79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f797bb5ea55 in QEventDispatcherGlib::processEvents (this=0x1f27690, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007f797c5c49d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f797bb305ef in QEventLoop::processEvents (this=this@entry=0x7fffe777e700, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f797bb308e5 in QEventLoop::exec (this=this@entry=0x7fffe777e700, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007f797bb35e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#31 0x00007f797c52134c in QApplication::exec () at kernel/qapplication.cpp:3828
#32 0x0000000000403660 in main (argc=1, argv=0x7fffe777e948) at ../../../kontact/src/main.cpp:219

The reporter indicates this bug may be a duplicate of or related to bug 279749.

Possible duplicates by query: bug 325175.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-10-23 01:18:55 UTC

*** This bug has been marked as a duplicate of bug 279749 ***