Bug 326367 - Always says no updates available, even when there are updates
Summary: Always says no updates available, even when there are updates
Status: RESOLVED DUPLICATE of bug 326256
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR major
Target Milestone: ---
Assignee: Jonathan Thomas
URL: http://bugsfiles.kde.org/attachment.c...
Keywords:
: 326658 326985 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-21 10:13 UTC by Rick J
Modified: 2016-03-02 13:28 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick J 2013-10-21 10:13:54 UTC
When updates are available, the notification icon appears correctly. But running the updater always reports "The software on this computer is up to date" with no updates listed. The updates can be found and installed using muon package manager, but never using the updater.

Running from the command line show the following errors:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
JSonScanner::yylex - error reading from io device

Reproducible: Always

Steps to Reproduce:
1. Run muon-updater when updates are available (either from the notification or directly)
Actual Results:  
No updates listed

Expected Results:  
List available updates

Refreshing the updater shows waiting icon for several seconds, but still lists no updates
Comment 1 krzychoo_m 2013-10-21 18:15:29 UTC
I noticed the same problem.
muon-updater always shows "The software on this computer is up to date".
from console:
$ muon-updater
JSonScanner::yylex - error reading from io device
Comment 2 Nick Elliott 2013-10-22 08:12:18 UTC
I can confirm, this behaviour started after upgrading to Kubuntu 13.10.

The notification icon appears but when you click on it the updater reports "The software on this computer is up to date" with no updates listed.

However if you check for updates using apt-get or muon package manager both will identify and install the updates.

This is probably a duplicate of 326256
Comment 3 Graeme Hewson 2013-10-23 07:28:26 UTC
I too get this problem after upgrading Kubuntu to 13.10.

I see the above messages when running muon-updater from Konsole. Also, when clicking More... and Check for Updates, this CLI message is issued:

found error while replying QDBusError("org.freedesktop.DBus.Error.InvalidArgs", "")

Nothing happens after that.
Comment 4 Graeme Hewson 2013-10-25 04:12:52 UTC
I've been applying updates manually after muon-updater failed.

Today after clicking "Install Updates", Muon displayed "Loading Software List" with a progress bar, but stalled at 33%. I was unable to quit from Muon, so killed it. I then found that Muon had, in fact, applied the updates.
Comment 5 Graeme Hewson 2013-10-29 06:30:48 UTC
See also https://bugs.launchpad.net/ubuntu/+source/muon/+bug/1245061.

Muon packages have been upgraded, from 2.0.65+git20131008-0ubuntu4 to 2.1.0-0ubuntu0.1, so hopefully this bug is now fixed. I can't find any details on Launchpad, though.
Comment 6 krzychoo_m 2013-10-30 08:31:44 UTC
On new version is still same problem.
Comment 7 Rick J 2013-10-30 09:46:48 UTC
(In reply to comment #6)
> On new version is still same problem.

Agree, I now have 2.1.0-0ubuntu0.1 and the problem is unchanged. Updater says system is up to date, but package manager and notifier both correctly show available updates.
Comment 8 msmigiel 2013-10-30 20:32:14 UTC
I have the same problem. After upgrading to Kubuntu 13.10, whenver I see the little gear icon telling me I have updates, none appear in Muon. Running "sudo apt-get update" and "sudo apt-get upgrade" did work though.
Comment 9 Martin Stockhammer 2013-10-30 20:57:15 UTC
Same problem here on kubuntu 13.10
Comment 10 windplume 2013-10-30 22:44:40 UTC
I am having the same problem. After upgrading from Kubuntu 13.04 to 13.10. 

No updates are listed, but the "Install Updates" button become available after a while and updates can be installed.
Comment 11 Jekyll Wu 2013-11-01 08:02:21 UTC
*** Bug 326658 has been marked as a duplicate of this bug. ***
Comment 12 Jekyll Wu 2013-11-01 10:56:32 UTC
*** Bug 326985 has been marked as a duplicate of this bug. ***
Comment 13 Nick 2013-11-01 22:43:04 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 Aleix Pol 2013-11-04 17:32:56 UTC

*** This bug has been marked as a duplicate of bug 326256 ***
Comment 15 georg 2013-11-20 05:19:43 UTC
Works now since the update from 2013-11-13.