Bug 325273 - digitaglinktree : CLI tool doesn't work with MySQL
Summary: digitaglinktree : CLI tool doesn't work with MySQL
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-WishForNewTools (show other bugs)
Version: 3.3.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-24 21:20 UTC by Thomas Bleher
Modified: 2019-07-28 21:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Bleher 2013-09-24 21:20:30 UTC
Digikam currently supports two database backends: sqlite and mysql. Unfortunately, digitaglinktree as shipped with digikam supports only sqlite currently. This is not very clear from the man page.
Digitaglinktree should be fixed to work with both backends. Ideally it should read the database information directly from the digikam ini file, so username and password does not have to be given on the command line. This would also make digitaglinktree easier to use for the sqlite case.

Reproducible: Always
Comment 1 caulier.gilles 2013-11-30 09:11:43 UTC
krienke,

Another entry about digikamlinktree for you...

Gilles Caulier
Comment 2 krienke 2013-12-04 13:10:34 UTC
Hello

you can try digitaglinktree 1.8.4beta if mysql support therein works for you. You find this version attached to Bug 323507.

Rainer
Comment 3 caulier.gilles 2014-08-24 08:27:18 UTC

*** This bug has been marked as a duplicate of bug 323507 ***
Comment 4 caulier.gilles 2019-07-28 21:22:23 UTC
Fixed with bug #323507