Bug 324860 - copying from one tab to another, crash
Summary: copying from one tab to another, crash
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdecore (show other bugs)
Version: 4.10.5
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-12 22:11 UTC by Jeffrey
Modified: 2018-11-13 16:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey 2013-09-12 22:11:40 UTC
Application: dolphin (2.2)
KDE Platform Version: 4.10.5
Qt Version: 4.8.5
Operating System: Linux 3.2.0-4-686-pae i686
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:
I had two tabs open and I was drag-dropping files from one to the other; once the first process started (dropped into a visible folder on tab 2), I went back to the first tab, selected new folders, and drag-dropped them to a different folder on the second tab.  Dolphin crashed and my file copy processes all hung.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/i686/cmov/libthread_db.so.1".
[Current thread is 1 (Thread 0xb778e740 (LWP 20631))]

Thread 3 (Thread 0xb63b1b40 (LWP 20644)):
#0  0xb77d8424 in __kernel_vsyscall ()
#1  0x4b79d80b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0x411a476b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x41195758 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x41195898 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x41ab5e3f in QEventDispatcherGlib::processEvents (this=0xb5a00468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x41a84d53 in QEventLoop::processEvents (this=this@entry=0xb63b1228, flags=...) at kernel/qeventloop.cpp:149
#7  0x41a85079 in QEventLoop::exec (this=this@entry=0xb63b1228, flags=...) at kernel/qeventloop.cpp:204
#8  0x4197351d in QThread::exec (this=this@entry=0x97e6c60) at thread/qthread.cpp:536
#9  0x41a650f4 in QInotifyFileSystemWatcherEngine::run (this=0x97e6c60) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x41975e6f in QThreadPrivate::start (arg=0x97e6c60) at thread/qthread_unix.cpp:338
#11 0x4b8c0cf1 in start_thread (arg=0xb63b1b40) at pthread_create.c:311
#12 0x4b7abfee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 2 (Thread 0xb2dfeb40 (LWP 20746)):
#0  0xb77d8424 in __kernel_vsyscall ()
#1  0x4b7beb92 in clock_gettime (clock_id=1, tp=0xb2dfdfc8) at ../sysdeps/unix/clock_gettime.c:115
#2  0x419d12ec in do_gettime (frac=0xb2dfdfc0, sec=0xb2dfdfb8) at tools/qelapsedtimer_unix.cpp:127
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#4  0x41ab76b2 in updateCurrentTime (this=0xb2402074) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=this@entry=0xb2402074, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#6  0x41ab5c6b in timerSourcePrepareHelper (src=src@entry=0xb2402040, timeout=0xb2dfe0bc) at kernel/qeventdispatcher_glib.cpp:136
#7  0x41ab5cfa in timerSourcePrepare (source=0xb2402040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x41194d33 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x4119564f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x41195898 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0x41ab5e3f in QEventDispatcherGlib::processEvents (this=0xb2400468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#12 0x41a84d53 in QEventLoop::processEvents (this=this@entry=0xb2dfe228, flags=...) at kernel/qeventloop.cpp:149
#13 0x41a85079 in QEventLoop::exec (this=this@entry=0xb2dfe228, flags=...) at kernel/qeventloop.cpp:204
#14 0x4197351d in QThread::exec (this=this@entry=0x9b75f90) at thread/qthread.cpp:536
#15 0x41a650f4 in QInotifyFileSystemWatcherEngine::run (this=0x9b75f90) at io/qfilesystemwatcher_inotify.cpp:256
#16 0x41975e6f in QThreadPrivate::start (arg=0x9b75f90) at thread/qthread_unix.cpp:338
#17 0x4b8c0cf1 in start_thread (arg=0xb2dfeb40) at pthread_create.c:311
#18 0x4b7abfee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xb778e740 (LWP 20631)):
[KCrash Handler]
#7  0x41a86415 in size (this=0xa2a7a80) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#8  size (this=0xa2a7a80) at ../../include/QtCore/../../src/corelib/tools/qlist.h:137
#9  QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x967ac20, receiver=receiver@entry=0xa6457f8, event=event@entry=0xbfacfd20) at kernel/qcoreapplication.cpp:1051
#10 0x41fa9b61 in QApplicationPrivate::notify_helper (this=0x967ac20, receiver=0xa6457f8, e=0xbfacfd20) at kernel/qapplication.cpp:4563
#11 0x41fb0683 in QApplication::notify (this=0xbfad08b0, receiver=receiver@entry=0xa6457f8, e=e@entry=0xbfacfd20) at kernel/qapplication.cpp:4353
#12 0x42f29a94 in KApplication::notify (this=0xbfad08b0, receiver=0xa6457f8, event=0xbfacfd20) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x41a8630a in QCoreApplication::notifyInternal (this=0xbfad08b0, receiver=0xa6457f8, event=event@entry=0xbfacfd20) at kernel/qcoreapplication.cpp:949
#14 0x41a9fdcf in sendEvent (event=0xbfacfd20, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QObjectPrivate::setParent_helper (this=0xa6d2fa0, o=o@entry=0xa6457f8) at kernel/qobject.cpp:1950
#16 0x41aa07f6 in QObject::setParent (this=this@entry=0xa137460, parent=parent@entry=0xa6457f8) at kernel/qobject.cpp:1894
#17 0x41aa0886 in QObject::QObject (this=0xa137460, parent=0xa6457f8) at kernel/qobject.cpp:730
#18 0x41aa4a64 in QTimer::QTimer (this=0xa137460, parent=0xa6457f8) at kernel/qtimer.cpp:145
#19 0x42a3e36a in KJob::emitSpeed (this=0xa6457f8, value=13996864) at ../../kdecore/jobs/kjob.cpp:341
#20 0x43cda46f in slotSpeed (speed=<optimized out>, this=<optimized out>) at ../../kio/kio/job.cpp:209
#21 KIO::Job::qt_static_metacall (_o=_o@entry=0xa6457f8, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfacfed4) at ./jobclasses.moc:56
#22 0x41a9b425 in QMetaObject::activate (sender=sender@entry=0xa27a530, m=m@entry=0x42be248c <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=16, argv=argv@entry=0xbfacfed4) at kernel/qobject.cpp:3547
#23 0x42a3e2ed in KJob::speed (this=this@entry=0xa27a530, _t1=_t1@entry=0xa27a530, _t2=_t2@entry=13996864) at ./kjob.moc:270
#24 0x42a3e334 in KJob::emitSpeed (this=0xa27a530, value=13996864) at ../../kdecore/jobs/kjob.cpp:345
#25 0x43cda46f in slotSpeed (speed=<optimized out>, this=<optimized out>) at ../../kio/kio/job.cpp:209
#26 KIO::Job::qt_static_metacall (_o=_o@entry=0xa27a530, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfad0004) at ./jobclasses.moc:56
#27 0x41a9b425 in QMetaObject::activate (sender=sender@entry=0xa75b3a8, m=m@entry=0x42be248c <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=16, argv=argv@entry=0xbfad0004) at kernel/qobject.cpp:3547
#28 0x42a3e2ed in KJob::speed (this=this@entry=0xa75b3a8, _t1=_t1@entry=0xa75b3a8, _t2=_t2@entry=13996864) at ./kjob.moc:270
#29 0x42a3e334 in KJob::emitSpeed (this=0xa75b3a8, value=13996864) at ../../kdecore/jobs/kjob.cpp:345
#30 0x43cda39f in slotSpeed (speed=<optimized out>, this=<optimized out>) at ../../kio/kio/job.cpp:543
#31 KIO::SimpleJob::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbfad0138, _c=<optimized out>) at ./jobclasses.moc:164
#32 0x41a9b425 in QMetaObject::activate (sender=sender@entry=0xa55a910, m=m@entry=0x43ea1da0 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=17, argv=argv@entry=0xbfad0138) at kernel/qobject.cpp:3547
#33 0x43d89785 in KIO::SlaveInterface::speed (this=this@entry=0xa55a910, _t1=13996864) at ./slaveinterface.moc:273
#34 0x43d898e2 in KIO::SlaveInterface::calcSpeed (this=0xa55a910) at ../../kio/kio/slaveinterface.cpp:132
#35 0x43d89da0 in KIO::SlaveInterface::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbfad0238, _c=<optimized out>) at ./slaveinterface.moc:109
#36 0x41a9b425 in QMetaObject::activate (sender=sender@entry=0xa69d5e4, m=m@entry=0x41bf1a18 <QTimer::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3547
#37 0x41aebae5 in QTimer::timeout (this=this@entry=0xa69d5e4) at .moc/release-shared/moc_qtimer.cpp:147
#38 0x41aa4ce6 in QTimer::timerEvent (this=0xa69d5e4, e=0xbfad05b0) at kernel/qtimer.cpp:280
#39 0x41a9f8ec in QObject::event (this=0xa69d5e4, e=0xbfad05b0) at kernel/qobject.cpp:1156
#40 0x41fa9b84 in QApplicationPrivate::notify_helper (this=0x967ac20, receiver=0xa69d5e4, e=0xbfad05b0) at kernel/qapplication.cpp:4567
#41 0x41fb0683 in QApplication::notify (this=0xbfad08b0, receiver=receiver@entry=0xa69d5e4, e=e@entry=0xbfad05b0) at kernel/qapplication.cpp:4353
#42 0x42f29a94 in KApplication::notify (this=0xbfad08b0, receiver=0xa69d5e4, event=0xbfad05b0) at ../../kdeui/kernel/kapplication.cpp:311
#43 0x41a8630a in QCoreApplication::notifyInternal (this=0xbfad08b0, receiver=0xa69d5e4, event=event@entry=0xbfad05b0) at kernel/qcoreapplication.cpp:949
#44 0x41ab8bdb in sendEvent (event=0xbfad05b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#45 QTimerInfoList::activateTimers (this=0x967942c) at kernel/qeventdispatcher_unix.cpp:621
#46 0x41ab5c0b in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#47 idleTimerSourceDispatch (source=0x967b5e0) at kernel/qeventdispatcher_glib.cpp:233
#48 0x4119542e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#49 0x411957d8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#50 0x41195898 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0x41ab5e1f in QEventDispatcherGlib::processEvents (this=this@entry=0x9655d58, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#52 0x4205b09e in QGuiEventDispatcherGlib::processEvents (this=0x9655d58, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x41a84d53 in QEventLoop::processEvents (this=this@entry=0xbfad07d8, flags=...) at kernel/qeventloop.cpp:149
#54 0x41a85079 in QEventLoop::exec (this=this@entry=0xbfad07d8, flags=...) at kernel/qeventloop.cpp:204
#55 0x41a8acee in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#56 0x41fa8014 in QApplication::exec () at kernel/qapplication.cpp:3828
#57 0x42c30bcd in kdemain (argc=5, argv=0xbfad0994) at ../../../dolphin/src/main.cpp:90
#58 0x0804856b in main (argc=5, argv=0xbfad0994) at dolphin_dummy.cpp:3

Possible duplicates by query: bug 324648, bug 324353, bug 324187, bug 324177, bug 324002.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2013-09-13 13:41:34 UTC
Thanks for the bug report. Looks like a problem in KJob.
Comment 2 Andrew Crouthamel 2018-10-29 23:58:33 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-11-13 14:43:07 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Jeffrey 2018-11-13 15:07:13 UTC
Hi, this report is older and I haven't experienced this bug recently. I cannot say if this bug is valid at this time. If you're unable to reproduce this, please feel free to close the bug report.

Thanks for KDE
Comment 5 Andrew Crouthamel 2018-11-13 16:25:56 UTC
Thanks for the update!