Bug 324498 - imap resource tries to login without waiting for kwallet?
Summary: imap resource tries to login without waiting for kwallet?
Status: RESOLVED DUPLICATE of bug 298954
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.11
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-04 13:18 UTC by Martin Tlustos
Modified: 2014-01-18 14:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tlustos 2013-09-04 13:18:28 UTC
It seems that the akonadi imap resource tries to log in into my mailserver without waiting for kwallet to open (for example when I start kontact, leave the computer and come back after a few minutes). As it does not have the password, but tries multiple times, I finally get blocked from accessing my email account for a while, which is bothersome. It ao shows a "multiple wrong login" error.
The funny thing is, I have to other imap accounts (one on the same server) that don't show this behaviour. But I recently changed the password on this specific account. The password in kwallet is the new, correct one, but I wonder whether kmail has stored the old (wrong) one somewhere else?

Reproducible: Always

Steps to Reproduce:
1. Start kontact/kmail
2. do not open kwallet for a while
3.
Actual Results:  
One account shows "login blocked because of too many failed login attempts" error, other accounts are fine

Expected Results:  
It shouldn't try to login without waiting for kwallet to open
Comment 1 Martin Tlustos 2013-09-12 10:07:30 UTC
Additional information: I actually have several akonadi resources connected to the same server and the same login information:
an Imap resource (already mentioned)
a Caldav resource with several caldav and carddav collections
a ldap addressbook resource
and an ical resource for tasks (caldav tasks support with this server doesn't work)

So the error could lie in any of those resources, although the error message i normally get is with the imap resource.

Additionally I have two more resources connecting to the same server, but with different credentials (another user account).

Anything I can do to clarify what's happening? I have akonadiconsole installed, should I enable the debugger and then try to trigger this behaviour?
Comment 2 Kevin Ottens 2013-11-16 07:26:13 UTC
The IMAP resource has a new maintainer, reassigning to him.
Comment 3 Martin Tlustos 2013-12-09 08:21:17 UTC
Workaround:
Open kwallet
cancel all akonadi requests that are not for opening kwallet, e.g. manual password requests for accounts
open akonadiconsole
You will find some resource cannot connect to kwallet - right-click and restart those.
Same for resources that show the not-connected - icon.

Finished

(it would still be better to not have to do that every time I'm not in front of my computer when it starts up...)
Comment 4 Martin 2014-01-18 14:14:29 UTC

*** This bug has been marked as a duplicate of bug 298954 ***