Bug 298954 - Akonadi is too fast for kwallet - Bombed with password dialogs
Summary: Akonadi is too fast for kwallet - Bombed with password dialogs
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 324498 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-28 03:54 UTC by Matthias
Modified: 2016-09-28 16:44 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias 2012-04-28 03:54:09 UTC
kmail/kde 4.8.2

Sometimes akonadi is starting too fast for kwallet. I just see >10 imap password dialogs and then i see the kwallet password prompt on my desktop. That's really annoying. But after that fun i still can't sent mails without a manual restart of the "Mail Dispatcher Agent" ressource.  

Is there any way to fixt that?

And it would be really nice to disable this kwallet password dialog...

Reproducible: Sometimes

Steps to Reproduce:
1. Booting my pc
2. Login to kde
3. Waiting for the dialogs
Actual Results:  
I can input >10 passwords.

Expected Results:  
Just one kwallet password dialog
Comment 1 Martin 2014-01-18 14:14:29 UTC
*** Bug 324498 has been marked as a duplicate of this bug. ***
Comment 2 Denis Kurz 2016-09-24 18:02:04 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 3 Martin Tlustos 2016-09-27 08:23:08 UTC
works for me now. kmail 5.1.3
Comment 4 Denis Kurz 2016-09-28 16:44:24 UTC
Thanks for the reply, Martin.