Bug 324406 - Application crashes on startup
Summary: Application crashes on startup
Status: RESOLVED DUPLICATE of bug 322848
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: 2.1.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-02 15:39 UTC by Vijay Dhameliya
Modified: 2013-09-02 16:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vijay Dhameliya 2013-09-02 15:39:04 UTC
Application: kstars (2.1.0)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic i686
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

Application never starts, after building successfully when tried to run it get crashes rather than opening.

-- Backtrace:
Application: KStars (kstars), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb409f740 (LWP 31957))]

Thread 2 (Thread 0xaf7a5b40 (LWP 31960)):
#0  0xb779e424 in __kernel_vsyscall ()
#1  0xb55abc9b in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb4d74d4e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4d321e3 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4d32662 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4d32831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb6bb2c3f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xb6b7f3ec in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0xb6b7f6e1 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb6a6afec in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb6b5ef2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb6a6db18 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb4e46d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb55bd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb409f740 (LWP 31957)):
[KCrash Handler]
#6  0xb779e424 in __kernel_vsyscall ()
#7  0xb54fab1f in raise () from /lib/i386-linux-gnu/libc.so.6
#8  0xb54fe0b3 in abort () from /lib/i386-linux-gnu/libc.so.6
#9  0xb6a627fc in qt_message_output(QtMsgType, char const*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb6a62c09 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb6a62d28 in qFatal(char const*, ...) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb6a62db5 in qt_assert(char const*, char const*, int) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0x080f4ae9 in SkyPoint::updateCoords (this=0xa475e18, num=0xbff28878, lat=0x0, LST=0x0, forceRecompute=false) at /home/vijay13/kde/kstars/kstars/skyobjects/skypoint.cpp:349
#14 0x081a2634 in SupernovaeComponent::update (this=0xa36c8e8, num=0xbff28878) at /home/vijay13/kde/kstars/kstars/skycomponents/supernovaecomponent.cpp:47
#15 0x08185536 in SkyMapComposite::update (this=0x91c7250, num=0xbff28878) at /home/vijay13/kde/kstars/kstars/skycomponents/skymapcomposite.cpp:149
#16 0x080869f3 in KStarsData::updateTime (this=0x906c6f8, geo=0x906c708, skymap=0x90c3180, automaticDSTchange=true) at /home/vijay13/kde/kstars/kstars/kstarsdata.cpp:214
#17 0x080768b6 in KStars::updateTime (this=0x9059f20, automaticDSTchange=true) at /home/vijay13/kde/kstars/kstars/kstars.cpp:342
#18 0x080771a7 in KStars::qt_static_metacall (_o=0x9059f20, _c=QMetaObject::InvokeMetaMethod, _id=39, _a=0xbff28c78) at /home/vijay13/kde/build/kstars/kstars.moc:264
#19 0xb6b96b56 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#20 0x080b26f6 in SimClock::clockToggled (this=0x906c770, _t1=false) at /home/vijay13/kde/build/kstars/simclock.moc:148
#21 0x080b1e8e in SimClock::start (this=0x906c770) at /home/vijay13/kde/kstars/kstars/simclock.cpp:132
#22 0x080a84d5 in KStars::datainitFinished (this=0x9059f20) at /home/vijay13/kde/kstars/kstars/kstarsinit.cpp:588
#23 0x08074d6d in KStars::KStars (this=0x9059f20, doSplash=true, clockrun=true, startdate=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /home/vijay13/kde/kstars/kstars/kstars.cpp:120
#24 0x08074e72 in KStars::createInstance (doSplash=true, clockrun=true, startdate=...) at /home/vijay13/kde/kstars/kstars/kstars.cpp:132
#25 0x080b16c8 in main (argc=1, argv=0xbff29244) at /home/vijay13/kde/kstars/kstars/main.cpp:200

Possible duplicates by query: bug 322848.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-09-02 16:54:56 UTC

*** This bug has been marked as a duplicate of bug 322848 ***