Bug 322848 - crash starting
Summary: crash starting
Status: RESOLVED FIXED
Alias: None
Product: kstars
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords: drkonqi
: 324406 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-26 15:29 UTC by Jaime Torres
Modified: 2013-10-18 13:47 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments
the conflicting file (bzip2 compressed) (12.91 KB, application/x-bzip)
2013-08-23 17:37 UTC, Jaime Torres
Details
New crash information added by DrKonqi (2.47 KB, text/plain)
2013-09-06 17:59 UTC, smjensen51
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Torres 2013-07-26 15:29:18 UTC
Application: kstars (2.1.0)
KDE Platform Version: 4.10.95 (Compiled from sources)
Qt Version: 4.8.5
Operating System: Linux 3.10.0-16.g3dcd746-desktop x86_64
Distribution: "openSUSE 13.1 Milestone 2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

just starting. no window shown yet.
stdout msg:
kstars(15854) KSParser::DummyRow: File named  "/home/jtorres/.kde/share/apps/kstars/supernovae.dat"  encountered an error while reading 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Quaoar" 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Eros" 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Hektor" 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Chiron" 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Hale-Bopp (1995 O1)" 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Hyakutake (1996 B2)" 
kstars(15854) KStarsData::readURLData: "No se encontró ningún objeto denominado Kohoutek" 

ASSERT: "std::isfinite( RA.Degrees() ) && std::isfinite( Dec.Degrees() )" in file /g/kdegit/kdeedu/kstars/kstars/skyobjects/skypoint.cpp, line 349

compiled from:
commit 6d72e756081843245344822a1f669fff5e41a563
Author: Henry de Valence <hdevalence@hdevalence.ca>
Date:   Sat Jul 13 14:56:36 2013 -0400

The crash can be reproduced every time.

-- Backtrace:
Application: KStars (kstars), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
To enable execution of this file add
	add-auto-load-safe-path /home/jtorres/gcc44/lib64/libstdc++.so.6.0.18-gdb.py
line to your configuration file "/home/jtorres/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/jtorres/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
[Current thread is 1 (Thread 0x7f4431295780 (LWP 15854))]

Thread 2 (Thread 0x7f4417fff700 (LWP 15857)):
#0  0x00007f442f871964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f441c80e82b in ?? () from /usr/lib64/dri/r600_dri.so
#2  0x00007f442f86de0e in start_thread () from /lib64/libpthread.so.0
#3  0x00007f442b95db9d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4431295780 (LWP 15854)):
[KCrash Handler]
#6  0x00007f442b8aa3a5 in raise () from /lib64/libc.so.6
#7  0x00007f442b8ab828 in abort () from /lib64/libc.so.6
#8  0x00007f442fb10481 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=<optimized out>) at /g/kdegit/qt/src/corelib/global/qglobal.cpp:2323
#9  0x00007f442fb105ab in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f442fc75498 "ASSERT: \"%s\" in file %s, line %d", ap=ap@entry=0x7fff8337a0b8) at /g/kdegit/qt/src/corelib/global/qglobal.cpp:2369
#10 0x00007f442fb10ca2 in qFatal (msg=msg@entry=0x7f442fc75498 "ASSERT: \"%s\" in file %s, line %d") at /g/kdegit/qt/src/corelib/global/qglobal.cpp:2552
#11 0x00007f442fb10ce6 in qt_assert (assertion=<optimized out>, file=<optimized out>, line=<optimized out>) at /g/kdegit/qt/src/corelib/global/qglobal.cpp:2018
#12 0x00000000004b69bc in SkyPoint::updateCoords (this=0x2965620, num=0x7fff8337a310, lat=0x0, LST=0x0, forceRecompute=<optimized out>) at /g/kdegit/kdeedu/kstars/kstars/skyobjects/skypoint.cpp:349
#13 0x0000000000542211 in SupernovaeComponent::update (this=<optimized out>, num=0x7fff8337a310) at /g/kdegit/kdeedu/kstars/kstars/skycomponents/supernovaecomponent.cpp:47
#14 0x0000000000526588 in SkyMapComposite::update (this=0xf49e40, num=0x7fff8337a310) at /g/kdegit/kdeedu/kstars/kstars/skycomponents/skymapcomposite.cpp:149
#15 0x0000000000451e4e in KStarsData::updateTime (this=0xddec50, geo=0xddec70, skymap=0xea88a0, automaticDSTchange=<optimized out>) at /g/kdegit/kdeedu/kstars/kstars/kstarsdata.cpp:214
#16 0x00000000004419fc in KStars::updateTime (this=<optimized out>, automaticDSTchange=<optimized out>) at /g/kdegit/kdeedu/kstars/kstars/kstars.cpp:342
#17 0x0000000000441fef in KStars::qt_static_metacall (_o=0xe39e40, _c=<optimized out>, _id=<optimized out>, _a=0x7fff8337a720) at /g/b45/kdeedu/kstars/kstars/kstars.moc:263
#18 0x00007f442fc29137 in QMetaObject::activate (sender=0xdded00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8337a720) at /g/kdegit/qt/src/corelib/kernel/qobject.cpp:3547
#19 0x0000000000476330 in SimClock::clockToggled (this=this@entry=0xdded00, _t1=_t1@entry=false) at /g/b45/kdeedu/kstars/kstars/simclock.moc:147
#20 0x0000000000476597 in SimClock::start (this=0xdded00) at /g/kdegit/kdeedu/kstars/kstars/simclock.cpp:132
#21 0x000000000047160a in KStars::datainitFinished (this=0xe39e40) at /g/kdegit/kdeedu/kstars/kstars/kstarsinit.cpp:588
#22 0x00000000004436c7 in KStars::KStars (this=0xe39e40, doSplash=doSplash@entry=true, clockrun=clockrun@entry=true, startdate=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /g/kdegit/kdeedu/kstars/kstars/kstars.cpp:120
#23 0x000000000044381b in KStars::createInstance (doSplash=<optimized out>, clockrun=<optimized out>, startdate=...) at /g/kdegit/kdeedu/kstars/kstars/kstars.cpp:132
#24 0x000000000043bebc in main (argc=<optimized out>, argv=<optimized out>) at /g/kdegit/kdeedu/kstars/kstars/main.cpp:200

Reported using DrKonqi
Comment 1 Rishab Arora 2013-08-22 19:27:31 UTC
Could you attach the the file "/home/jtorres/.kde/share/apps/kstars/supernovae.dat" to the report?
Comment 2 Jaime Torres 2013-08-23 17:37:45 UTC
Created attachment 81883 [details]
the conflicting file (bzip2 compressed)

it was downloaded long time ago (1 or 2 years) using kstars from khotnew.
Comment 3 Christoph Feck 2013-09-02 16:54:56 UTC
*** Bug 324406 has been marked as a duplicate of this bug. ***
Comment 4 smjensen51 2013-09-06 17:59:20 UTC
Created attachment 82195 [details]
New crash information added by DrKonqi

kstars (2.1.0) on KDE Platform 4.10.5 using Qt 4.8.5

- What I was doing when the application crashed:
Just starting - splash screen is shown and then it crashes
NOTE: this kstars compiled from source - I am looking to have kstars control my telescope through indi. The version of kstars that come with my distribution (Fedora 18) is old and does not intlcue te capability.

-- Backtrace (Reduced):
#12 0x435fa6d6 in qt_assert(char const*, char const*, int) () from /lib/libQtCore.so.4
#13 0x08142f1d in SkyPoint::updateCoords (this=0xa2499b0, num=0xbfc620c8, lat=0x0, LST=0x0, forceRecompute=false) at /home/sjensen/kde/kstars/kstars/skyobjects/skypoint.cpp:349
#14 0x0823c59c in SupernovaeComponent::update (this=0xa15fd18, num=0xbfc620c8) at /home/sjensen/kde/kstars/kstars/skycomponents/supernovaecomponent.cpp:47
#15 0x0821f276 in SkyMapComposite::update (this=0x8fd35e8, num=0xbfc620c8) at /home/sjensen/kde/kstars/kstars/skycomponents/skymapcomposite.cpp:149
#16 0x080c79f9 in KStarsData::updateTime (this=0x8ef4518, geo=0x8ef4528, skymap=0x8f65cd0, automaticDSTchange=true) at /home/sjensen/kde/kstars/kstars/kstarsdata.cpp:214
Comment 5 Albert Astals Cid 2013-10-18 13:47:17 UTC
Git commit 65e57507b6acd1fc9290b3d6455bf9d25ef5d53f by Albert Astals Cid, on behalf of Vijay Dhameliya.
Committed on 18/10/2013 at 13:46.
Pushed by aacid into branch 'KDE/4.11'.

Restring addition of null supernovae objects to supernovaecomponent list

While loading data for supernovae, there seems error in reading file supernovae.dat  so it leads to creation of dummy supernovae object which leads to various error during run time of Kstars. So lets avoid creation of such dummy supernovae objects.
This fixes attached bug too.

Approved by Henry de Valence

FIXED-IN: 4.11.3
REVIEW: 112879

M  +3    -0    kstars/skycomponents/supernovaecomponent.cpp

http://commits.kde.org/kstars/65e57507b6acd1fc9290b3d6455bf9d25ef5d53f