Bug 324272 - Brightness and shadows of windows don't work in system preferences, workspace appearance
Summary: Brightness and shadows of windows don't work in system preferences, workspace...
Status: RESOLVED DUPLICATE of bug 323527
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 4.11.0
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-30 12:52 UTC by Victor Marin
Modified: 2013-08-31 15:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
No windows shadows / brightness in KDE 4.11. (100.77 KB, image/jpeg)
2013-08-30 15:24 UTC, Victor Marin
Details
2. No windows bright-shadows nor effects in KDE 4.11 (106.44 KB, image/jpeg)
2013-08-30 20:42 UTC, Victor Marin
Details
3. No windows bright-shadows nor effects in KDE 4.11 (109.24 KB, image/jpeg)
2013-08-30 20:44 UTC, Victor Marin
Details
glxinfo (18.12 KB, application/octet-stream)
2013-08-31 15:23 UTC, Victor Marin
Details
Xrender tab (298.69 KB, image/png)
2013-08-31 15:35 UTC, Victor Marin
Details
Details of desktop effects that couldn't be loaded with Xrender (148.39 KB, image/jpeg)
2013-08-31 15:37 UTC, Victor Marin
Details
Failed to activate desktop effects with OpenGL (230.86 KB, image/png)
2013-08-31 15:42 UTC, Victor Marin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Marin 2013-08-30 12:52:08 UTC
All windows have the same, very tiny edge in blue color, with not longer brightness effect. 

Trying to change color to red or yellow, etc. and size of the windows brightness at shadows tab in the windows decoration dialog of workspace appearance at system preferences, it does nothing; It always returns the same window decoration in the same tiny blue edge, with not bright effects at all.

Shadow of the window it's inexistent too, and it can't be adjusted.

Closing and re-opening session, or restarting the system don't make any difference.

It happens when updating KDE from 4.8.5 (of Kubuntu 12.04 LTS) to the current 4.11 KDE version.



Reproducible: Always

Steps to Reproduce:
1. Go to System preferences, workspace appearance, windows decoration, set decoration, shadows.
2. Change options of size and color for the edge of the windows and accept. 
3. It does not happen anything but the windows continue with the same tiny blue edge and not bright nor shadows.
Actual Results:  
The windows continue with the same tiny blue edge and not bright nor shadows, not matter the chosen color and size for the windows bright / shadow.

Expected Results:  
1. The windows to have brightness and shadows. 
2. And to be able to change these options accordingly, 

The OS it's Kubuntu 12.04 LTS 64bits and Spanish language.
Comment 1 Hugo Pereira Da Costa 2013-08-30 15:01:46 UTC
Can you post a screenshot ?

My suspission is that after the upgrade, you do not have compositing enabled any more, which is why all the shadows are disabled (and the settings ignored).

In which case this is likely unrelated with oxygen (and related to either kwin, or your graphics card driver).

http://wstaw.org/m/2013/08/30/plasma-desktopCD2962.png
(this is how windows appear, here when compositing is disabled)
Comment 2 Victor Marin 2013-08-30 15:24:13 UTC
Created attachment 82037 [details]
No windows shadows / brightness in KDE 4.11.
Comment 3 Victor Marin 2013-08-30 15:24:59 UTC
Perhaps, I don't have compositing enabled anymore after upgrading to 4.11; How could I enable it?
Also, I not longer have windows transparency effect nor gelatinous windows, etc.
Yes, I'm posting a screenshot.
Thanks in advance.
Comment 4 Hugo Pereira Da Costa 2013-08-30 16:49:58 UTC
So compositing indeed.
If available, it can usually be enabled with shift+alt+F12
Otherwise, will forward to kwin team.
Comment 5 Victor Marin 2013-08-30 20:42:24 UTC
Created attachment 82041 [details]
2. No windows bright-shadows nor effects in KDE 4.11
Comment 6 Victor Marin 2013-08-30 20:44:53 UTC
Created attachment 82042 [details]
3. No windows bright-shadows nor effects in KDE 4.11
Comment 7 Victor Marin 2013-08-30 21:02:26 UTC
Yes, it seems the problem has to do with a compositing error.

Going to system preferences --> desktop effects, it shows that it are enabled, but it are not... Marking or unmarking the activation of the desktop effects it does nothing; Also it can't be enabled by using Alt+Shift+F12.

If I try to change some effect in all the effects tab, then a yellowish message appears warning that 22 destkop effects couldn't be loaded. 

Clicking on the details button of such error message, it spawns that due to technical issues it can't be determined all possible causes of the error.

I attach 2 more screenshots.
Comment 8 Hugo Pereira Da Costa 2013-08-31 11:48:19 UTC
reassigning
Comment 9 Thomas Lübking 2013-08-31 11:54:15 UTC
(In reply to comment #7)
> Going to system preferences --> desktop effects, it shows that it are
> enabled
No, it shows to activate them with kwin startup - doesn't matter, though.

> desktop effects it does nothing; Also it can't be enabled by using
> Alt+Shift+F12.
please attach the output of "glxinfo" and in "kcmshell4 kwincompositing", 3rd tab, try to switch to xrender compositing - does that work?
Comment 10 Victor Marin 2013-08-31 15:23:25 UTC
Created attachment 82063 [details]
glxinfo
Comment 11 Victor Marin 2013-08-31 15:35:00 UTC
Created attachment 82064 [details]
Xrender tab
Comment 12 Victor Marin 2013-08-31 15:37:48 UTC
Created attachment 82065 [details]
Details of desktop effects that couldn't be loaded with Xrender
Comment 13 Victor Marin 2013-08-31 15:42:01 UTC
Created attachment 82066 [details]
Failed to activate desktop effects with OpenGL
Comment 14 Victor Marin 2013-08-31 15:47:33 UTC
Here I send you the "glxinfo" in a .txt file, and also 2 additional screenshots with the third tab of "kcmshell4 kwincompositing". 

Choosing Xrender it enables shadows and brightness in windows. Also, it can be adjusted and changed the windows shadows / brightness colors.
 
And it enables transparency effect, too. 

But, as the screenshot number 5 shows, some effects can't be loaded with Xrender but it need OpenGL, like gelatinous windows. 

Trying to enable desktop effects with any and all versions of OpenGL it throws the error message that I also send you in respective screenshot.
Comment 15 Thomas Lübking 2013-08-31 15:57:16 UTC
> OpenGL vendor string: Advanced Micro Devices, Inc.
> OpenGL renderer string: ATI Radeon HD 3200 Graphics 
> OpenGL version string: 3.3.11627 Compatibility Profile Context
> OpenGL shading language version string: 3.30

"Surprise"

See here for a workaround:
https://bugs.kde.org/show_bug.cgi?id=323927
Since direct rendering was disabled for being too crashy, don't forget to undo that workaround as soon as we figured what causes that GL error and avoid it.

*** This bug has been marked as a duplicate of bug 323527 ***