Bug 323927 - Kubuntu 12.04 with backports with ATI FirePro 2260 => update to KDE SC 4.11 => Opengl Problem
Summary: Kubuntu 12.04 with backports with ATI FirePro 2260 => update to KDE SC 4.11 =...
Status: RESOLVED DUPLICATE of bug 323527
Alias: None
Product: kwin
Classification: Unclassified
Component: scene-opengl (show other bugs)
Version: 4.11.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-23 14:43 UTC by André Herrmann
Modified: 2013-08-26 20:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
This is the (german) message which comes up when I try to switch composite type to opengl (88.86 KB, image/png)
2013-08-23 14:47 UTC, André Herrmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Herrmann 2013-08-23 14:43:54 UTC
I have a problem on my kubuntu 12.04 installation using the backports repository. I'm using the fglrx-driver which was suggested by jockey, which is version 8.96.7 with Opengl 3.3.11627.

I previously ran kde 4.10 without having any problems. After receiving the 4.11 Update my Desktop effects (Opengl) won't run anymore, telling me that it is not able to use Opengl (1.2,2.0,3.1).

If I work without those effects I get periodically get lot of fractals inside the current window when I change size or position of the window. I can remove them by sliding over with the mouse.

As intermediate solution I installed gnome shell and parts of unity. Wether Mutter nor Compiz does seem to have a problem with the fglrx driver due 3d is working as expected here. So I would say there is an incompatibility in Kwin with my driver?

gllrxinfo says:

andre@andre-Precision-T1500:~$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI FirePro 2260
OpenGL version string: 3.3.11627 Compatibility Profile Context

I know that I could make use of the fglrx-update packages but my graphics card is AFAIK only supported to Version 8.98, so I am currently not willing to update, because I cannot break my work-System ( http://ubuntuforums.org/showthread.php?t=2075779 ).

Any suggestions what I can do?

Thanks


Reproducible: Always

Steps to Reproduce:
1. Install Kubuntu 12.04 with latest updates
2. Having my Graphics card ATI FirePro 2260
3. Use jockey suggested fglrx-driver which is 8.96.7
4. Add KDE backports PPA https://launchpad.net/~kubuntu-ppa/+archive/backports
5. Update KDE to Version 4.11.0

Actual Results:  
Not beeing able to use Composit-Type OpenGL anymore ( whilst in kde 4.10 in ran perfectly, so as Mutter or Compiz are doing currently ) it always falls back to Xrender.

Expected Results:  
Worked as in 4.10 release, Including Desktop-Effects which are frequently used by my workflow
Comment 1 André Herrmann 2013-08-23 14:47:44 UTC
Created attachment 81875 [details]
This is the (german) message which comes up when I try to switch composite type to opengl
Comment 2 Thomas Lübking 2013-08-23 15:14:15 UTC
you're likely running into bug #323553 and friends.

Please run "kwin --replace" from konsole (ensure to have kwin debug output active) and compare the output about failing to initialize OpenGL1

Why (a very basic) indirect context (and OpenGL1) setup does not work, is atm. not clear.

-> Just enforce direct rendering (and OpenGL2) but be aware that it was initially blacklisted for random crashes.

There's also been reports that after "aticonfig --initial" things started to "mystically" work again, but there's no guarantee on that.
Comment 3 André Herrmann 2013-08-23 17:21:06 UTC
Hi Thomas,

i could not find some options for debug or verbose mode for kwin-replace, but after doing kwin-replace commandline gave me some output.

After kwin-replace I tried the following (just to compare with my output)

1. In system Settings Composite: Opengl version 2.0 native
2. In system Settings Composite: Opengl version 2.0 raster
3. Same with Opengl 3.1 in same order

Heres what I got:
andre@andre-Precision-T1500:~$ kwin --replace
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
file:///usr/share/kde4/apps/kwin/tabbox/thumbnails/contents/ui/main.qml:139:9: QML Image: Bilddaten können nicht geholt werden: image://client/-1/-1406457435-0
OpenGL vendor string:                   ATI Technologies Inc.
OpenGL renderer string:                 ATI FirePro 2260
OpenGL version string:                  2.1 (3.3.11627 Compatibility Profile Context)
OpenGL shading language version string: 
Driver:                                 Catalyst
Driver version:                         2.1
GPU class:                              Unknown
OpenGL version:                         2.1
GLSL version:                           0.0
X server version:                       1.11.3
Linux kernel version:                   3.2
Direct rendering:                       no
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
kwin(18402) KWin::checkGLError: GL error ( Init ):  "GL_INVALID_ENUM" 
kwin(18402): OpenGL 1 compositing setup failed 
QObject::connect: Cannot connect (null)::resetCompositing() to KWin::Compositor::restart()
kwin(18402): Failed to initialize compositing, compositing disabled 
kwin(18402): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up 


QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
andre@andre-Precision-T1500:~$ 
andre@andre-Precision-T1500:~$ 
andre@andre-Precision-T1500:~$ QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
OpenGL vendor string:                   ATI Technologies Inc.
OpenGL renderer string:                 ATI FirePro 2260
OpenGL version string:                  2.1 (3.3.11627 Compatibility Profile Context)
OpenGL shading language version string: 
Driver:                                 Catalyst
Driver version:                         2.1
GPU class:                              Unknown
OpenGL version:                         2.1
GLSL version:                           0.0
X server version:                       1.11.3
Linux kernel version:                   3.2
Direct rendering:                       no
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
kwin(18438) KWin::checkGLError: GL error ( Init ):  "GL_INVALID_ENUM" 
kwin(18438): OpenGL 1 compositing setup failed 
QObject::connect: Cannot connect (null)::resetCompositing() to KWin::Compositor::restart()
kwin(18438): Failed to initialize compositing, compositing disabled 
kwin(18438): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread


Thanks for your answer. I will consider the magic aticonfig --initial solution and will report about it.

As said upgrading driver seems to be not good for me due ati is not supporting my card after version 8.98
Comment 4 André Herrmann 2013-08-23 17:31:37 UTC
Ok I tried the aticonfig --initial thing but it did not change anything for my situation :-(
Comment 5 Thomas Lübking 2013-08-23 17:39:08 UTC
ok, is same bug.

export KWIN_DIRECT_GL=1
export KWIN_COMPOSE=O2
kwin --replace &

if that works, put the two exports into an executable #!/bin/sh in ~/.kde/env

*** This bug has been marked as a duplicate of bug 323527 ***
Comment 6 André Herrmann 2013-08-26 19:58:35 UTC
I can confirm, that this did the trick. But putting this into an executable in kde/env is not working wether with or without kwin --replace command.

I will figure out a way that will automatically set the variables needed tomorrow and will report about it.

Thanks for yourmquick help :-)
Comment 7 Thomas Lübking 2013-08-26 20:09:53 UTC
Try "kcmshell4 autostart" (gui to add env scripts)
Notice that the script has to be executable and of course contain a usable shebang

------- snip ------------
#!/bin/sh
export export KWIN_DIRECT_GL=1
export KWIN_COMPOSE=O2
# do *not* kwin --replace here!
------- /snip ------------

chmod +x /path/to/script
Comment 8 Thomas Lübking 2013-08-26 20:11:47 UTC
copy 'n paste is evil.

------- snip ------------
#!/bin/sh
export KWIN_DIRECT_GL=1
export KWIN_COMPOSE=O2
# do *not* kwin --replace here!
------- /snip ------------
Comment 9 André Herrmann 2013-08-26 20:22:42 UTC
:-) 

Of course I made it executable (This is why I called it an executable) and gave it a shebang line. First I just put in the export commands and if this was not working, I added th kwin-replace.

I consider  putting those variables in a global scope or in rc.local. Currently I cannot try this due I'm not at work. I will report tommorow what I achieved. 

Best