Bug 323980 - Duplicate messages if antispam filter enabled
Summary: Duplicate messages if antispam filter enabled
Status: RESOLVED DUPLICATE of bug 283682
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Mail Filter Agent (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-24 18:07 UTC by NSLW
Modified: 2017-03-22 00:06 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NSLW 2013-08-24 18:07:19 UTC
If I enable antispam filter (SpamAssassin or SpamBayes) I recive more than once every incoming e-mail.
It happens with IMAP account on Polish e-mail provider www.onet.pl. It doesn't happen with GMail. It has been observed for "auto checking for new e-mails" functionality.
The problem doesn't exist if antispam filter is disabled.


Reproducible: Sometimes

Steps to Reproduce:
1. set up an mail account on www.onet.pl (free of charge)
2. configure above account with kmail (IMAP way)
3. set up antispam filter
4. send e-mail to yourself
5. check for new e-mails on kmail
Actual Results:  
Identical messages are proliferating in my kmail mailbox and thus on mail server. They've got the same incoming date and titles.

Expected Results:  
One message on mail server. One message in my kmail mailbox.

I suspect, it can be encoding that an provider uses, i.e.
Onet uses:
Content-Type: text/plain; charset="ISO-8859-1"
GMail uses:
Content-Type: text/html; charset=UTF-8

Above are from message source.

Maybe some Kmail routine have problems to compare e-mails on server with e-mails that I already received and sends me something that I already have.
Comment 1 Angelos Skembris 2013-10-18 14:14:22 UTC
I have a similar problem with a POP3 account - I have SpamAssassin and Bogofilter installed and I also apply filters on the sender's email address to classify my messages into separate folders. About 1 out of every 3 emails from those that are filtered to go into one of the folders (but not the ones staying into the generic inbox) are duplicated. It seems related to Bug 283682 (but I am not sure).

Please let me know what types of log / tests I can provide
Comment 2 Angelos Skembris 2013-10-18 14:16:04 UTC
Sorry, forgot to specify I am on KDE 4.11.2 on OpenSUSE 12.3
Comment 3 Tobias Leupold 2013-12-01 14:54:05 UTC
Probably the same problem described in Bug #316419?
Comment 4 Angelos Skembris 2013-12-08 21:24:29 UTC
For me it seems to be the same problem, yes,
Comment 5 Tobias Leupold 2013-12-09 11:22:30 UTC
There are quite a few bugs around here complaining about duplicate emails after filtering. I found Bug #316419, Bug #95064, Bug #322126, Bug #322676 and there are probably even more.

Perhaps someone (a kmail developer?!) could check which bugs actually describe the very same problem, choose one of them to work on and mark the others as duplicates.

This is really annoying and I would love to see this fixed – I delete quite a lot of duplicate emails by hand each day.
Comment 6 Tobias Leupold 2014-01-12 17:02:12 UTC
I still see the problem in kmail-4.12.0.
Comment 7 Tobias Leupold 2014-12-08 21:08:30 UTC
This is very likely caused by the problem described in Bug #283682
Comment 8 Daniel Vrátil 2017-03-22 00:06:11 UTC

*** This bug has been marked as a duplicate of bug 283682 ***