Bug 323969 - KNotify crashes sometimes
Summary: KNotify crashes sometimes
Status: RESOLVED DUPLICATE of bug 323812
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: 4.11.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-24 14:07 UTC by Alexander Wolf
Modified: 2013-08-24 22:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Wolf 2013-08-24 14:07:29 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.11.00
Qt Version: 4.8.2
Operating System: Linux 3.8.0-29-generic x86_64
Distribution: Ubuntu 12.04.3 LTS

-- Information about the crash:
After update KDE  to 4.11.00 I catch crashes of knotify.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5e9f590780 (LWP 19743))]

Thread 2 (Thread 0x7f5e8c0b2700 (LWP 19745)):
#0  0x00007f5e9c722900 in pthread_mutex_unlock (mutex=0x7f5e84000a60) at forward.c:184
#1  0x00007f5e99d8d5e1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5e99d51fea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5e99d52124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5e9ce8a926 in QEventDispatcherGlib::processEvents (this=0x7f5e840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f5e9ce59e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f5e9ce5a0b7 in QEventLoop::exec (this=0x7f5e8c0b1dd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f5e9cd59077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f5e9ce39b6f in QInotifyFileSystemWatcherEngine::run (this=0x1f59ee0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f5e9cd5c09b in QThreadPrivate::start (arg=0x1f59ee0) at thread/qthread_unix.cpp:307
#10 0x00007f5e9a21ee9a in start_thread (arg=0x7f5e8c0b2700) at pthread_create.c:308
#11 0x00007f5e9c714ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5e9f590780 (LWP 19743)):
[KCrash Handler]
#6  deref (this=0x72ff32d) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  ~QString (this=0x7fff612c51b0, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qstring.h:880
#8  v_clear<QString> (d=0x7fff612c51b0) at ../../include/QtCore/private/../../../src/corelib/kernel/qvariant_p.h:144
#9  clear (d=0x7fff612c51b0) at kernel/qvariant.cpp:199
#10 0x00007f5e9e84f97a in Solid::Backends::UDev::UDevManager::Private::isPowerBubtton (this=<optimized out>, device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:152
#11 0x00007f5e9e84fbf2 in Solid::Backends::UDev::UDevManager::Private::checkOfInterest (this=0x1f34040, device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:121
#12 0x00007f5e9e85139c in isOfInterest (device=..., udi=..., this=0x1f34040) at ../../../solid/solid/backends/udev/udevmanager.cpp:77
#13 Solid::Backends::UDev::UDevManager::Private::isOfInterest (this=0x1f34040, udi=..., device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:71
#14 0x00007f5e9e851846 in Solid::Backends::UDev::UDevManager::slotDeviceRemoved (this=0x1f35290, device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:268
#15 0x00007f5e9ce6f781 in QMetaObject::activate (sender=0x1f36250, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff612c5690) at kernel/qobject.cpp:3547
#16 0x00007f5e9e85a605 in UdevQt::Client::deviceRemoved (this=<optimized out>, _t1=...) at ./udevqt.moc:153
#17 0x00007f5e9e85a7ac in UdevQt::ClientPrivate::_uq_monitorReadyRead (this=0x1f57e60, fd=<optimized out>) at ../../../solid/solid/backends/shared/udevqtclient.cpp:107
#18 0x00007f5e9ce6f781 in QMetaObject::activate (sender=0x1f58010, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff612c5820) at kernel/qobject.cpp:3547
#19 0x00007f5e9cebc7fe in QSocketNotifier::activated (this=<optimized out>, _t1=10) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#20 0x00007f5e9ce78b0b in QSocketNotifier::event (this=0x1f58010, e=0x7fff612c5e90) at kernel/qsocketnotifier.cpp:317
#21 0x00007f5e9dad77b4 in notify_helper (e=0x7fff612c5e90, receiver=0x1f58010, this=0x1cc36b0) at kernel/qapplication.cpp:4556
#22 QApplicationPrivate::notify_helper (this=0x1cc36b0, receiver=0x1f58010, e=0x7fff612c5e90) at kernel/qapplication.cpp:4528
#23 0x00007f5e9dadc583 in QApplication::notify (this=0x7fff612c6140, receiver=0x1f58010, e=0x7fff612c5e90) at kernel/qapplication.cpp:4417
#24 0x00007f5e9ef8dd96 in KApplication::notify (this=0x7fff612c6140, receiver=0x1f58010, event=0x7fff612c5e90) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f5e9ce5b32c in QCoreApplication::notifyInternal (this=0x7fff612c6140, receiver=0x1f58010, event=0x7fff612c5e90) at kernel/qcoreapplication.cpp:915
#26 0x00007f5e9ce89f97 in sendEvent (event=0x7fff612c5e90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#27 socketNotifierSourceDispatch (source=0x1cc3880) at kernel/qeventdispatcher_glib.cpp:110
#28 0x00007f5e99d51d13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f5e99d52060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f5e99d52124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f5e9ce8a926 in QEventDispatcherGlib::processEvents (this=0x1c93770, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#32 0x00007f5e9db7fcde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f5e9ce59e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f5e9ce5a0b7 in QEventLoop::exec (this=0x7fff612c60a0, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f5e9ce5f407 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#36 0x00000000004099a7 in main (argc=1, argv=0x7fff612c64c8) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 323812, bug 323640.

Отправить на https://bugs.kde.org/

Reproducible: Sometimes
Comment 1 Christoph Feck 2013-08-24 22:12:14 UTC

*** This bug has been marked as a duplicate of bug 323812 ***