Bug 323640 - Application crashes when I remove plug from my laptop
Summary: Application crashes when I remove plug from my laptop
Status: RESOLVED DUPLICATE of bug 323812
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: libsolid-udev (show other bugs)
Version: 4.11.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-17 14:15 UTC by Neal
Modified: 2013-08-23 15:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neal 2013-08-17 14:15:40 UTC
Application: kded4 (4.11.00)
KDE Platform Version: 4.11.00
Qt Version: 4.8.2
Operating System: Linux 3.5.3-030503-generic x86_64
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I removed the plug from my laptop. Please note that I use Jupiter.

-- Backtrace:
Application: KDE Daemon (kded4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f03a363a780 (LWP 5123))]

Thread 2 (Thread 0x7f037fd55700 (LWP 5361)):
#0  0x00007f03a86118cd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f03a57698cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f03a572eba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f03a572efd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f03a572f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f03a9a63926 in QEventDispatcherGlib::processEvents (this=0x7f03740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f03a9a32e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f03a9a330b7 in QEventLoop::exec (this=0x7f037fd54dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f03a9932077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f03a9a12b6f in QInotifyFileSystemWatcherEngine::run (this=0x1e5eb00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f03a993509b in QThreadPrivate::start (arg=0x1e5eb00) at thread/qthread_unix.cpp:307
#11 0x00007f03a6005e9a in start_thread (arg=0x7f037fd55700) at pthread_create.c:308
#12 0x00007f03a861eccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f03a363a780 (LWP 5123)):
[KCrash Handler]
#6  deref (this=0x72ff32d) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  ~QString (this=0x7fffbec87a10, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qstring.h:880
#8  v_clear<QString> (d=0x7fffbec87a10) at ../../include/QtCore/private/../../../src/corelib/kernel/qvariant_p.h:144
#9  clear (d=0x7fffbec87a10) at kernel/qvariant.cpp:199
#10 0x00007f03a04af97a in Solid::Backends::UDev::UDevManager::Private::isPowerBubtton (this=<optimized out>, device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:152
#11 0x00007f03a04afbf2 in Solid::Backends::UDev::UDevManager::Private::checkOfInterest (this=0x1cfcbb0, device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:121
#12 0x00007f03a04b139c in isOfInterest (device=..., udi=..., this=0x1cfcbb0) at ../../../solid/solid/backends/udev/udevmanager.cpp:77
#13 Solid::Backends::UDev::UDevManager::Private::isOfInterest (this=0x1cfcbb0, udi=..., device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:71
#14 0x00007f03a04b1846 in Solid::Backends::UDev::UDevManager::slotDeviceRemoved (this=0x1cac130, device=...) at ../../../solid/solid/backends/udev/udevmanager.cpp:268
#15 0x00007f03a9a48781 in QMetaObject::activate (sender=0x1cbb2f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbec87ef0) at kernel/qobject.cpp:3547
#16 0x00007f03a04ba605 in UdevQt::Client::deviceRemoved (this=<optimized out>, _t1=...) at ./udevqt.moc:153
#17 0x00007f03a04ba7ac in UdevQt::ClientPrivate::_uq_monitorReadyRead (this=0x1f41910, fd=<optimized out>) at ../../../solid/solid/backends/shared/udevqtclient.cpp:107
#18 0x00007f03a9a48781 in QMetaObject::activate (sender=0x1e86de0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbec88080) at kernel/qobject.cpp:3547
#19 0x00007f03a9a957fe in QSocketNotifier::activated (this=<optimized out>, _t1=11) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#20 0x00007f03a9a51b0b in QSocketNotifier::event (this=0x1e86de0, e=0x7fffbec886f0) at kernel/qsocketnotifier.cpp:317
#21 0x00007f03a8db57b4 in notify_helper (e=0x7fffbec886f0, receiver=0x1e86de0, this=0x1cbbec0) at kernel/qapplication.cpp:4556
#22 QApplicationPrivate::notify_helper (this=0x1cbbec0, receiver=0x1e86de0, e=0x7fffbec886f0) at kernel/qapplication.cpp:4528
#23 0x00007f03a8dba583 in QApplication::notify (this=0x7fffbec88970, receiver=0x1e86de0, e=0x7fffbec886f0) at kernel/qapplication.cpp:4417
#24 0x00007f03aa7d2d96 in KApplication::notify (this=0x7fffbec88970, receiver=0x1e86de0, event=0x7fffbec886f0) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f03a9a3432c in QCoreApplication::notifyInternal (this=0x7fffbec88970, receiver=0x1e86de0, event=0x7fffbec886f0) at kernel/qcoreapplication.cpp:915
#26 0x00007f03a9a62f97 in sendEvent (event=0x7fffbec886f0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#27 socketNotifierSourceDispatch (source=0x1cbd200) at kernel/qeventdispatcher_glib.cpp:110
#28 0x00007f03a572ed53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f03a572f0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f03a572f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f03a9a63926 in QEventDispatcherGlib::processEvents (this=0x1c1a7d0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#32 0x00007f03a8e5dcde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f03a9a32e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f03a9a330b7 in QEventLoop::exec (this=0x7fffbec88900, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f03a9a38407 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#36 0x00007f0395f88bd5 in kdemain (argc=1, argv=0x1c96e00) at ../../kded/kded.cpp:925
#37 0x000000000040866c in launch (argc=1, _name=0x40b446 "kded4", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b32e "0") at ../../kinit/kinit.cpp:738
#38 0x0000000000405a79 in main (argc=4, argv=0x7fff00000001, envp=0x7fffbec89ae0) at ../../kinit/kinit.cpp:1853

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-08-23 15:45:47 UTC
See https://bugs.kde.org/show_bug.cgi?id=323812#c1

*** This bug has been marked as a duplicate of bug 323812 ***