Bug 323743 - Nepomuk crashes
Summary: Nepomuk crashes
Status: RESOLVED DUPLICATE of bug 312760
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-19 18:52 UTC by Hatredman from Hatred Space
Modified: 2013-08-20 03:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hatredman from Hatred Space 2013-08-19 18:52:33 UTC
Application: nepomukservicestub (0.1.0)
KDE Platform Version: 4.10.5 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: FUCKING LOGING IN THE FUCKING KDE PIECE OF SHIT.

There's nothing more I can say.

The crash can be reproduced every time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7faabdba1780 (LWP 1599))]

Thread 3 (Thread 0x7faaa9ae5700 (LWP 1713)):
[KCrash Handler]
#5  0x00007faabaed43d5 in raise () from /lib64/libc.so.6
#6  0x00007faabaed5858 in abort () from /lib64/libc.so.6
#7  0x00007faabb2b28cd in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib64/libstdc++.so.6
#8  0x00007faabb2b09c6 in ?? () from /usr/lib64/libstdc++.so.6
#9  0x00007faabb2b09f3 in std::terminate() () from /usr/lib64/libstdc++.so.6
#10 0x00007faabb2b150f in __cxa_pure_virtual () from /usr/lib64/libstdc++.so.6
#11 0x00007faab9963dd2 in QAbstractSocketEngine::createSocketEngine (socketDescripter=18, parent=0x7faa9c002808) at socket/qabstractsocketengine.cpp:133
#12 0x00007faab9970733 in QAbstractSocket::setSocketDescriptor (this=0x7faa9c002808, socketDescriptor=18, socketState=QAbstractSocket::ConnectedState, openMode=...) at socket/qabstractsocket.cpp:1604
#13 0x00007faab997f890 in QLocalSocket::setSocketDescriptor (this=<optimized out>, socketDescriptor=18, socketState=QLocalSocket::ConnectedState, openMode=...) at socket/qlocalsocket_unix.cpp:370
#14 0x00007faaadf87543 in (anonymous namespace)::LocalServerConnection::createIODevice (this=0xd44a80) at /usr/src/debug/soprano-2.9.0/server/localserver.cpp:41
#15 0x00007faaadf83dc7 in Soprano::Server::ServerConnection::run (this=0xd44a80) at /usr/src/debug/soprano-2.9.0/server/serverconnection.cpp:140
#16 0x00007faabd54d0cc in QThreadPrivate::start (arg=0xd44a80) at thread/qthread_unix.cpp:338
#17 0x00007faabd2b6e0f in start_thread () from /lib64/libpthread.so.0
#18 0x00007faabaf877dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7faaa92e4700 (LWP 1714)):
#0  0x00007faabaf83449 in syscall () from /lib64/libc.so.6
#1  0x00007faabd54bb74 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7faa9c002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=0x7faa9c002b80, timeout=<optimized out>) at thread/qmutex_unix.cpp:113
#3  0x00007faabd547d75 in QMutex::lockInternal (this=<optimized out>) at thread/qmutex.cpp:450
#4  0x00007faab9964120 in lockInline (this=0x7faa9c002b68) at ../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7faa9c002b68, this=0x7faaa92e3c00) at ../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7faaa0002d60, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007faab99678b3 in ~QHttpSocketEngineHandler (this=0x7faaa0002d60, __in_chrg=<optimized out>) at socket/qhttpsocketengine_p.h:189
#8  QHttpSocketEngineHandler::~QHttpSocketEngineHandler (this=0x7faaa0002d60, __in_chrg=<optimized out>) at socket/qhttpsocketengine_p.h:189
#9  0x00007faab995a114 in ~QGlobalNetworkProxy (this=0x7faaa0002d00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:266
#10 globalNetworkProxy () at kernel/qnetworkproxy.cpp:340
#11 0x00007faab995ad4d in QNetworkProxy::QNetworkProxy (this=0x7faaa0002ba8) at kernel/qnetworkproxy.cpp:445
#12 0x00007faab9970ebe in QAbstractSocketPrivate::QAbstractSocketPrivate (this=0x7faaa0002a60) at socket/qabstractsocket.cpp:489
#13 0x00007faab997645e in QTcpSocketPrivate (this=0x7faaa0002a60) at socket/qtcpsocket_p.h:61
#14 QTcpSocket::QTcpSocket (this=0x7faaa0002a08, parent=0x0) at socket/qtcpsocket.cpp:94
#15 0x00007faab997e9b6 in QLocalUnixSocket (this=0x7faaa0002a08) at socket/qlocalsocket_p.h:83
#16 QLocalSocketPrivate::QLocalSocketPrivate (this=0x7faaa0002920) at socket/qlocalsocket_unix.cpp:72
#17 0x00007faab9978bfe in QLocalSocket::QLocalSocket (this=0x7faaa00013c0, parent=0x0) at socket/qlocalsocket.cpp:337
#18 0x00007faaadf87528 in (anonymous namespace)::LocalServerConnection::createIODevice (this=0x1041490) at /usr/src/debug/soprano-2.9.0/server/localserver.cpp:40
#19 0x00007faaadf83dc7 in Soprano::Server::ServerConnection::run (this=0x1041490) at /usr/src/debug/soprano-2.9.0/server/serverconnection.cpp:140
#20 0x00007faabd54d0cc in QThreadPrivate::start (arg=0x1041490) at thread/qthread_unix.cpp:338
#21 0x00007faabd2b6e0f in start_thread () from /lib64/libpthread.so.0
#22 0x00007faabaf877dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7faabdba1780 (LWP 1599)):
#0  0x00007faabaf83449 in syscall () from /lib64/libc.so.6
#1  0x00007faabd54bb74 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7faa9c002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=0x7faa9c002b80, timeout=<optimized out>) at thread/qmutex_unix.cpp:113
#3  0x00007faabd547d75 in QMutex::lockInternal (this=<optimized out>) at thread/qmutex.cpp:450
#4  0x00007faab9964120 in lockInline (this=0x7faa9c002b68) at ../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7faa9c002b68, this=0x7fff4f0eb110) at ../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7faa9c0013e0, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007faab996e3d3 in ~QSocks5SocketEngineHandler (this=0x7faa9c0013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#8  QSocks5SocketEngineHandler::~QSocks5SocketEngineHandler (this=0x7faa9c0013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#9  0x00007faab995c078 in ~QGlobalNetworkProxy (this=0x7faa9c002b00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:265
#10 QGlobalStaticDeleter<QGlobalNetworkProxy>::~QGlobalStaticDeleter (this=0x7faab9be57c8 <globalNetworkProxy()::cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1949
#11 0x00007faabaed6f61 in __run_exit_handlers () from /lib64/libc.so.6
#12 0x00007faabaed6fe5 in exit () from /lib64/libc.so.6
#13 0x00007faabb79b5b8 in ?? () from /usr/lib64/libQtGui.so.4
#14 0x00007faabc7465d8 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib64/libkdeui.so.5
#15 0x00007faab8b54bce in _XIOError () from /usr/lib64/libX11.so.6
#16 0x00007faab8b5266d in _XEventsQueued () from /usr/lib64/libX11.so.6
#17 0x00007faab8b43b5b in XEventsQueued () from /usr/lib64/libX11.so.6
#18 0x00007faabb7d1a7c in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00007faaba7d55ac in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#20 0x00007faaba7d5a42 in ?? () from /usr/lib64/libglib-2.0.so.0
#21 0x00007faaba7d5bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#22 0x00007faabd6772c6 in QEventDispatcherGlib::processEvents (this=0xafac90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007faabb7d1c1e in ?? () from /usr/lib64/libQtGui.so.4
#24 0x00007faabd647adf in QEventLoop::processEvents (this=this@entry=0x7fff4f0eb410, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007faabd647d68 in QEventLoop::exec (this=0x7fff4f0eb410, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007faabd64ca08 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#27 0x0000000000404270 in ?? ()
#28 0x00007faabaec0a15 in __libc_start_main () from /lib64/libc.so.6
#29 0x0000000000404591 in _start ()

Possible duplicates by query: bug 323708, bug 323620, bug 322439, bug 322338, bug 320946.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-08-20 03:16:28 UTC
fixed in KDE SC 4.11

*** This bug has been marked as a duplicate of bug 312760 ***