Bug 323708 - Nepomuk Crashes on Login
Summary: Nepomuk Crashes on Login
Status: RESOLVED DUPLICATE of bug 312760
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: 4.10.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-19 10:50 UTC by Kevin Adams
Modified: 2013-08-19 16:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Adams 2013-08-19 10:50:26 UTC
Application: nepomukservicestub (0.1.0)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-27-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

The service crashes almost every time I restart my machine.  Every time I do a cold boot I recieve this crash notice..

The crash can be reproduced sometimes.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5962cab7c0 (LWP 2409))]

Thread 4 (Thread 0x7f594a3d8700 (LWP 2646)):
#0  0x00007f59602e2f89 in syscall () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f596265d694 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7f593c002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=this@entry=0x7f593c002b80, timeout=timeout@entry=-1) at thread/qmutex_unix.cpp:113
#3  0x00007f59626598a5 in QMutex::lockInternal (this=this@entry=0x7f593c002b68) at thread/qmutex.cpp:450
#4  0x00007f595ea85b50 in lockInline (this=0x7f593c002b68) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7f593c002b68, this=0x7f594a3d7bc0) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7f59340013e0, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007f595ea8fe23 in ~QSocks5SocketEngineHandler (this=0x7f59340013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#8  QSocks5SocketEngineHandler::~QSocks5SocketEngineHandler (this=0x7f59340013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#9  0x00007f595ea7bb35 in ~QGlobalNetworkProxy (this=0x7f5934002d00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:265
#10 globalNetworkProxy () at kernel/qnetworkproxy.cpp:340
#11 0x00007f595ea7c77d in QNetworkProxy::QNetworkProxy (this=0x7f5934002ba8) at kernel/qnetworkproxy.cpp:445
#12 0x00007f595ea9266e in QAbstractSocketPrivate::QAbstractSocketPrivate (this=0x7f5934002a60) at socket/qabstractsocket.cpp:489
#13 0x00007f595ea97ebe in QTcpSocketPrivate (this=0x7f5934002a60) at socket/qtcpsocket_p.h:61
#14 QTcpSocket::QTcpSocket (this=0x7f5934002a08, parent=0x0) at socket/qtcpsocket.cpp:94
#15 0x00007f595eaa0406 in QLocalUnixSocket (this=0x7f5934002a08) at socket/qlocalsocket_p.h:83
#16 QLocalSocketPrivate::QLocalSocketPrivate (this=0x7f5934002920) at socket/qlocalsocket_unix.cpp:72
#17 0x00007f595ea9a60e in QLocalSocket::QLocalSocket (this=0x7f59340013c0, parent=0x0) at socket/qlocalsocket.cpp:337
#18 0x00007f595183d4a8 in ?? () from /usr/lib/libsopranoserver.so.1
#19 0x00007f5951839e87 in ?? () from /usr/lib/libsopranoserver.so.1
#20 0x00007f596265ebec in QThreadPrivate::start (arg=0x240e1a0) at thread/qthread_unix.cpp:338
#21 0x00007f595ffd8f8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#22 0x00007f59602e7e1d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 3 (Thread 0x7f5949bd7700 (LWP 2647)):
#0  0x00007f59602e2f89 in syscall () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f596265d694 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7f593c002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=this@entry=0x7f593c002b80, timeout=timeout@entry=-1) at thread/qmutex_unix.cpp:113
#3  0x00007f59626598a5 in QMutex::lockInternal (this=this@entry=0x7f593c002b68) at thread/qmutex.cpp:450
#4  0x00007f595ea85b50 in lockInline (this=0x7f593c002b68) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7f593c002b68, this=0x7f5949bd6bc0) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7f593c0013e0, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007f595ea8fe23 in ~QSocks5SocketEngineHandler (this=0x7f593c0013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#8  QSocks5SocketEngineHandler::~QSocks5SocketEngineHandler (this=0x7f593c0013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#9  0x00007f595ea7bb35 in ~QGlobalNetworkProxy (this=0x7f593c002b00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:265
#10 globalNetworkProxy () at kernel/qnetworkproxy.cpp:340
#11 0x00007f595ea7c77d in QNetworkProxy::QNetworkProxy (this=0x7f593c0029a8) at kernel/qnetworkproxy.cpp:445
#12 0x00007f595ea9266e in QAbstractSocketPrivate::QAbstractSocketPrivate (this=0x7f593c002860) at socket/qabstractsocket.cpp:489
#13 0x00007f595ea97ebe in QTcpSocketPrivate (this=0x7f593c002860) at socket/qtcpsocket_p.h:61
#14 QTcpSocket::QTcpSocket (this=0x7f593c002808, parent=0x0) at socket/qtcpsocket.cpp:94
#15 0x00007f595eaa0406 in QLocalUnixSocket (this=0x7f593c002808) at socket/qlocalsocket_p.h:83
#16 QLocalSocketPrivate::QLocalSocketPrivate (this=0x7f593c002720) at socket/qlocalsocket_unix.cpp:72
#17 0x00007f595ea9a60e in QLocalSocket::QLocalSocket (this=0x7f593c0013c0, parent=0x0) at socket/qlocalsocket.cpp:337
#18 0x00007f595183d4a8 in ?? () from /usr/lib/libsopranoserver.so.1
#19 0x00007f5951839e87 in ?? () from /usr/lib/libsopranoserver.so.1
#20 0x00007f596265ebec in QThreadPrivate::start (arg=0x24d2b10) at thread/qthread_unix.cpp:338
#21 0x00007f595ffd8f8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#22 0x00007f59602e7e1d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7f59493d6700 (LWP 2648)):
[KCrash Handler]
#5  0x00007f5960225037 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x00007f5960228698 in abort () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x00007f5960616e8d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#8  0x00007f5960614f76 in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#9  0x00007f5960614fa3 in std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#10 0x00007f5960615acf in __cxa_pure_virtual () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#11 0x00007f595ea85802 in QAbstractSocketEngine::createSocketEngine (socketDescripter=socketDescripter@entry=19, parent=parent@entry=0x7f5938002808) at socket/qabstractsocketengine.cpp:133
#12 0x00007f595ea91ee3 in QAbstractSocket::setSocketDescriptor (this=this@entry=0x7f5938002808, socketDescriptor=socketDescriptor@entry=19, socketState=socketState@entry=QAbstractSocket::ConnectedState, openMode=...) at socket/qabstractsocket.cpp:1604
#13 0x00007f595eaa12e0 in QLocalSocket::setSocketDescriptor (this=<optimized out>, socketDescriptor=19, socketState=QLocalSocket::ConnectedState, openMode=...) at socket/qlocalsocket_unix.cpp:370
#14 0x00007f595183d4c3 in ?? () from /usr/lib/libsopranoserver.so.1
#15 0x00007f5951839e87 in ?? () from /usr/lib/libsopranoserver.so.1
#16 0x00007f596265ebec in QThreadPrivate::start (arg=0x27c29f0) at thread/qthread_unix.cpp:338
#17 0x00007f595ffd8f8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#18 0x00007f59602e7e1d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f5962cab7c0 (LWP 2409)):
#0  0x00007f59602e2f89 in syscall () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f596265d694 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7f593c002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=this@entry=0x7f593c002b80, timeout=timeout@entry=-1) at thread/qmutex_unix.cpp:113
#3  0x00007f59626598a5 in QMutex::lockInternal (this=this@entry=0x7f593c002b68) at thread/qmutex.cpp:450
#4  0x00007f595ea85b50 in lockInline (this=0x7f593c002b68) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7f593c002b68, this=0x7fffe57ec7a0) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7f59380013e0, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007f595ea8fe23 in ~QSocks5SocketEngineHandler (this=0x7f59380013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#8  QSocks5SocketEngineHandler::~QSocks5SocketEngineHandler (this=0x7f59380013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#9  0x00007f595ea7daa8 in ~QGlobalNetworkProxy (this=0x7f5938002b00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:265
#10 QGlobalStaticDeleter<QGlobalNetworkProxy>::~QGlobalStaticDeleter (this=0x7f595ed10458 <globalNetworkProxy()::cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#11 0x00007f596022a121 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#12 0x00007f596022a1a5 in exit () from /lib/x86_64-linux-gnu/libc.so.6
#13 0x00007f5960aee348 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#14 0x00007f5961a89f38 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
#15 0x00007f595dc835be in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#16 0x00007f595dc8108d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#17 0x00007f595dc7265b in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#18 0x00007f5960b29bdc in x11EventSourceCheck (s=0x229a610) at kernel/qguieventdispatcher_glib.cpp:85
#19 0x00007f595f902c69 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f595f903175 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f595f903304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f596278a016 in QEventDispatcherGlib::processEvents (this=0x2271ac0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007f5960b2a1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f596275a38f in QEventLoop::processEvents (this=this@entry=0x7fffe57ecaa0, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f596275a618 in QEventLoop::exec (this=this@entry=0x7fffe57ecaa0, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007f596275fcf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#27 0x00007f5960a82ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#28 0x0000000000403e70 in main (argc=<optimized out>, argv=0x7fffe57ecf08) at ../../servicestub/main.cpp:180

This bug may be a duplicate of or related to bug 312760.

Possible duplicates by query: bug 323620, bug 322439, bug 322338, bug 320946, bug 320676.

Reported using DrKonqi
Comment 1 Simeon Bird 2013-08-19 16:47:56 UTC
Try 4.11

*** This bug has been marked as a duplicate of bug 312760 ***