Bug 323462 - akregator refreshes all feeds when network connection state changes
Summary: akregator refreshes all feeds when network connection state changes
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 4.10.5
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-13 15:43 UTC by Orivej Desh
Modified: 2016-12-04 21:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orivej Desh 2013-08-13 15:43:53 UTC
When network connection state changes while Akregator is running, it begins downloading all feeds. There is no setting to disable this unwarranted behaviour, which is particularly nasty with mobile connections and when connection state changes from 'connected' to 'disconnected'.

Reproducible: Always
Comment 1 Ricardo J. Barberis 2014-01-07 02:01:28 UTC
Confirmed on KDE SC 4.11.4.
Maybe related to bug 141244?
Comment 2 Ricardo J. Barberis 2014-01-07 02:03:14 UTC
Oh, and it even updates feeds which have their update interval set to Never.
Comment 3 Maarten De Meyer 2014-01-15 20:04:06 UTC
Hi,
As far as I know this is the intended behavior. When the network connection was down and it goes back up all feeds are fetched.
This is only when it changes to connected, no feeds are fetched when it's not connected. (I assume)

If you are on a mobile connection and akregator is running does it matter if it runs on a regular interval or when the network goes back up? Feeds are fetched either way..

Thanks.
Comment 4 Orivej Desh 2014-01-15 20:21:16 UTC
(1) Having updated KDE SC to 4.12.0 (among other software updates), I no longer see Akregator try fetching feeds on disconnect.
(2) It fetches feeds on connect even with all automatic fetching ("Fetch on startup" and "Fetch periodically") turned off.
Comment 5 Ricardo J. Barberis 2014-01-16 14:57:04 UTC
(In reply to comment #3)
> Hi,
> As far as I know this is the intended behavior. When the network connection
> was down and it goes back up all feeds are fetched.

But if I set a feed to never update, it shouldn't automatically update it!

> This is only when it changes to connected, no feeds are fetched when it's
> not connected. (I assume)

That's right.

> If you are on a mobile connection and akregator is running does it matter if
> it runs on a regular interval or when the network goes back up? Feeds are
> fetched either way..

Yes it does, I may be charged for extra downloads for example.

Not that it matters much, but in my case I set the feeds to update only once or twice a day.

> Thanks.
Comment 6 Denis Kurz 2016-09-24 19:42:03 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of akregator (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 7 Ricardo J. Barberis 2016-12-04 20:48:29 UTC
I can confirm that this bug is resolved as of akregator 5.3.0 (applications 16.08.2).
Comment 8 Orivej Desh 2016-12-04 21:12:09 UTC
Thanks for the confirmation!  (I did not confirm it myself, although I reported this bug, because my distribution Gentoo is cautious of updating KDE PIM, and still ships the latest KDE 5 with KDE PIM 4.)