Bug 141244 - aKregator updates feed even if configured to never do so
Summary: aKregator updates feed even if configured to never do so
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 56 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 221901 319519 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-05 23:01 UTC by michal
Modified: 2016-12-06 23:30 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michal 2007-02-05 23:01:17 UTC
Version:           1.2.6 (using KDE 3.5.6, PLD Linux Distribution)
Compiler:          gcc version 3.3.6 (PLD Linux)
OS:                Linux (i686) release 2.6.18

I have configured aKregator to update feeds every 30 minutes and then set some feeds using "custom update interval" to never update.

When I star aKregator it updates all feeds, even these set to "never".
Comment 1 Frank Osterfeld 2007-02-25 10:58:13 UTC
Do you have "Fetch all feeds on startup" on the General tab of the config dialog enabled?
Comment 2 michal 2007-03-04 19:14:22 UTC
I do, but IMHO it would be logical for "custom update interval" to override this setting.
Comment 3 Manuel Schmid 2008-12-27 13:32:26 UTC
I was just about to report the same bug. I think Akregator shouldn’t update feeds on start-up, if the custom update interval is set to never, as you sometimes want to keep a feed in the feed list without updating it and you still want to update all your other feeds on start-up.
Comment 4 Christophe Giboudeaux 2010-02-22 00:32:53 UTC
*** Bug 221901 has been marked as a duplicate of this bug. ***
Comment 5 Björn Hendriks 2010-06-18 10:52:49 UTC
I can confirm this bug for Akregator 1.6.2 of KDE 4.4.2 from Kubuntu 10.04.

It's pretty annoying as I have a feed which's source recently got login protected. Although I cannot get new messages I still want to keep the old ones. So I have to cancel a login request each time I start Akregator, now.

A "disable fetching completely" in the feed settings would be really nice, as suggested by the comments of the duplicated bug report #221901.
Comment 6 mailbox.tec 2012-12-17 09:42:42 UTC
Confirmed in KDE 4.9.4 on Arch Linux.
Comment 7 Maarten De Meyer 2013-05-08 12:48:42 UTC
*** Bug 319519 has been marked as a duplicate of this bug. ***
Comment 8 Ricardo J. Barberis 2014-01-07 01:34:33 UTC
This bug is still present in KDE SC 4.11.4.
Unfortunately I can't code C++, but I have a spare laptop where I can try new versions or patches if someone has any idea for a fix.

Thanks.
Comment 9 Denis Kurz 2016-09-24 19:38:51 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of akregator (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 10 Ricardo J. Barberis 2016-12-04 20:40:45 UTC
Unfortunately, this bug is still present on akregator 5.3.0 (applications 16.08.2) if you have Check feeds on startup enabled.

Feeds also get updated if you use Ctr+L to update all the feeds, even the feeds configured to never update.
Comment 11 Laurent Montel 2016-12-06 12:50:49 UTC
Git commit 9cf98318ca08b74ce0e29b71c97c2a687cd06b09 by Montel Laurent.
Committed on 06/12/2016 at 12:50.
Pushed by mlaurent into branch 'Applications/16.12'.

Fix Bug 141244 - aKregator updates feed even if configured to never do so

FIXED-IN: 5.4.0

M  +9    -1    src/folder.cpp

https://commits.kde.org/akregator/9cf98318ca08b74ce0e29b71c97c2a687cd06b09
Comment 12 Ricardo J. Barberis 2016-12-06 23:30:45 UTC
Thanks!