Bug 323113 - kmail2 ignores the "per contact" settings randomly
Summary: kmail2 ignores the "per contact" settings randomly
Status: RESOLVED DUPLICATE of bug 346212
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.14.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-02 17:21 UTC by Till Schäfer
Modified: 2016-12-21 12:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2013-08-02 17:21:05 UTC
I have configured kmail to render the mails of some contacts in html (basically some news-feeds) while the general rule is to show plain text only. This usually works well, but sometimes the per contact settings are ignored. 
Sometimes it helps to restart the akonadi service, but sometimes i have to restart kde completely. It also helps (again only sometimes) to add a new duplicate contact with the html settings. After adding this new contact i am able to delete the duplicate (new) contact again and the settings are working again. 

Kmail also randomly asks to create a new user when setting the encryption settings because it is unaware of the already existing one. It also applies for the display of external sources in html messages. 
Therefore, i think this is a general problem of per user settings. Maybe the contact resource becomes unavailable to kmail for some reason. 

Reproducible: Sometimes
Comment 1 Till Schäfer 2014-01-31 16:08:15 UTC
this is fixed since the 4.12 days for me.
Comment 2 Till Schäfer 2014-02-14 10:13:13 UTC
i am sorry, this bug is back for me after a longer time.
Comment 3 Till Schäfer 2014-02-14 10:15:04 UTC
maybe this information is omportant: i am unsing the DAV resource (davical server) for storeing the contacts.
Comment 4 Till Schäfer 2016-12-21 12:47:51 UTC

*** This bug has been marked as a duplicate of bug 346212 ***