Bug 323064 - Screensaver process is still running after the screensaver is gone
Summary: Screensaver process is still running after the screensaver is gone
Status: RESOLVED DUPLICATE of bug 224200
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: screensavers (show other bugs)
Version: 4.10.5
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 328785 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-31 21:33 UTC by Nick Stallman
Modified: 2014-04-17 06:40 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
CPU Load due to Screensavers still running (67.76 KB, image/jpeg)
2014-03-30 08:30 UTC, Samuel
Details
List of kss porcesses associated with the CPU load in the previous example (151.06 KB, image/jpeg)
2014-03-30 08:35 UTC, Samuel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Stallman 2013-07-31 21:33:29 UTC
I've noticed screensaver processes not being killed.
There are no problems with the functionality, move the mouse and the screensaver goes away correctly.
But the actual process doesn't exit and more importantly it looks like they are still actually rendering the screensavers in the background.

I have 5 monitors so each time 5 separate instances of the screensaver are created, one for each monitor (ugh looks nasty but that is another issue).
Right now grepping for 'euphoria' shows this:

nick     19808  3.8  0.2 554844 37096 ?        Sl   Jul31  32:12 euphoria -window-id 94371957 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     19809  3.9  0.2 554844 37544 ?        Sl   Jul31  32:21 euphoria -window-id 94371980 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     19810  3.9  0.2 555872 38084 ?        Sl   Jul31  32:48 euphoria -window-id 94371998 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     19811  3.9  0.2 555868 38232 ?        Sl   Jul31  32:40 euphoria -window-id 94372016 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     19812  3.9  0.2 554848 37192 ?        Sl   Jul31  32:50 euphoria -window-id 94372034 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     20563  3.4  0.2 554844 37288 ?        Sl   Jul31  19:30 euphoria -window-id 94371957 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     20564  3.4  0.2 554844 36904 ?        Sl   Jul31  19:29 euphoria -window-id 94371980 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     20574  3.5  0.2 554844 37192 ?        Sl   Jul31  19:45 euphoria -window-id 94371998 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     20581  3.5  0.2 554848 37444 ?        Sl   Jul31  19:41 euphoria -window-id 94372016 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     20588  3.5  0.2 554848 37196 ?        Sl   Jul31  19:48 euphoria -window-id 94372034 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     21390 15.2  0.2 555868 38360 ?        Sl   07:08   2:14 euphoria -window-id 94371957 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     21391 15.2  0.2 554844 37292 ?        Sl   07:08   2:14 euphoria -window-id 94371980 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     21395 16.1  0.2 554844 37460 ?        Sl   07:08   2:22 euphoria -window-id 94371998 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     21405 16.1  0.2 554844 37200 ?        Sl   07:08   2:22 euphoria -window-id 94372016 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3
nick     21415 16.1  0.2 554844 37376 ?        Sl   07:08   2:22 euphoria -window-id 94372034 -i 5 -b 2 -d 25 -v 35 -s 15 -f 0 -e 1 -c 3

As you can see, my screensaver has run three times, leaving behind 15 processes. You'll notice from the CPU usage column that they are all still running as well.

This is clearly a problem. I generally leave my computer on all the time so I really don't want hundreds of screensavers running constantly.

Reproducible: Always

Steps to Reproduce:
1. Let screensaver trigger
2. Double check if the process has actually gone away or not
3.
Actual Results:  
Multiple processes were left running

Expected Results:  
The screensaver process should have been killed
Comment 1 Martin Weidner 2013-10-29 07:17:05 UTC
I have the same problem since upgrade to Kubuntu 13.10.

I tried uninstall/reinstall of kscreensaver, but the issue still exists. Any solutions/workarounds?

KDELibs Version 4.11.2
Qt Version 4.8.4
Kernel Version 3.11.0-12-generic
64-bit
Comment 2 Christoph Feck 2013-12-16 22:02:14 UTC
*** Bug 328785 has been marked as a duplicate of this bug. ***
Comment 3 Mark Haase 2014-01-30 01:08:55 UTC
Confirmed here... this has been happening since upgrading to Ubuntu 13.10.

/home/mhaase $ ps aux | grep kdeasciiquarium | wc -l
24

(Needless to say, I don't have 24 screens. I have 2.)
Comment 4 John Everest 2014-01-30 08:37:52 UTC
Changed system from 32 bit Kubuntu 13.10 to 64 bit, the bug still persists.

KDELibs Version 4.11.3
Qt Version 4.8.4
Kernel Version 3.11.0-15 generic
Comment 5 Roman 2014-02-13 12:31:11 UTC
I am suffering the same issue, and I highlight that the background screensaver processes take significant GPU resources, causing degradation of the graphics performance.

The GPU load can be tested with intel_gpu_top for intel cards. Before launching the screensaver it only shows 3 counts that reach 100% load level, while the remaining counts show almost zero usage. After launching the screensaver, and getting out of it, the screensaver process may be left in the background, and then intel_gpu_top shows lots of GPU modules being 100% busy, even if the system is standby. The performance of KWin effects and other OpenGL applications remarkably degrades in this case.

However, the issue is not specific to intel cards, NVidia cards are affected in the same manner.

My KDE version is 4.11.5, KUbuntu 13.10
Comment 6 Jannis Liapis 2014-03-15 22:32:30 UTC
(In reply to comment #5)
> I am suffering the same issue, and I highlight that the background
> screensaver processes take significant GPU resources, causing degradation of
> the graphics performance.
> 
> The GPU load can be tested with intel_gpu_top for intel cards. Before
> launching the screensaver it only shows 3 counts that reach 100% load level,
> while the remaining counts show almost zero usage. After launching the
> screensaver, and getting out of it, the screensaver process may be left in
> the background, and then intel_gpu_top shows lots of GPU modules being 100%
> busy, even if the system is standby. The performance of KWin effects and
> other OpenGL applications remarkably degrades in this case.
> 
> However, the issue is not specific to intel cards, NVidia cards are affected
> in the same manner.
> 
> My KDE version is 4.11.5, KUbuntu 13.10

same here...It happens on nvidia cards also.KDE 4.12.3 kubuntu 13.10
Comment 7 Samuel 2014-03-30 08:30:24 UTC
Created attachment 85840 [details]
CPU Load due to Screensavers still running

I ran my system with KDE 4.12.95 with random selection of screensavers purposely left my system come out of screen saver with keyboard action.  I repeated this process multiple times and watched to CPU load steadly increase.
Comment 8 Samuel 2014-03-30 08:35:08 UTC
Created attachment 85841 [details]
List of kss porcesses associated with the CPU load in the previous example

This shows the list of .kss processes in memory.  As the number increase, multiple screen savers are displayed.  For example, I might have three KDE and a Clock flashing in and out while the main screen saver is active.
Comment 9 Samuel 2014-03-30 08:45:34 UTC
I really enjoy the list of screen savers that are provided.  Unfortunately for some time now I have not been able to use them because of the CPU load taken up after my computer has been left on for some time and it has gone in and out of Screen Saver mode.  The attached images illustrate what is happening.

When I reboot my computer, all the .kss process are gone.  Thank you for fixing the problem which kept them in memory on reboot.  I have an ASUS R501VM with Intel Core i7-3610QM CPU at 2.3GHz.

I hope this helps to have this problem CONFIRMED
Comment 10 Roman 2014-03-31 09:06:46 UTC
I may also add that when just a single screensaver process is left to spin in the background, I often have severe graphics corruptions when watching movies or running other fullscreen applications. The screen begins to crazily blink, as if the graphics driver could not decide whether it should show the movie or the screensaver on the visible screen.
Comment 11 Wolfgang Bauer 2014-04-17 06:40:48 UTC
Isn't this the same as bug#224200?

*** This bug has been marked as a duplicate of bug 224200 ***