Bug 322966 - Problem with Kleopatra 2.1.1 on Ubuntu 13.04 | Result of self-test at program start: unexpected error
Summary: Problem with Kleopatra 2.1.1 on Ubuntu 13.04 | Result of self-test at program...
Status: RESOLVED UPSTREAM
Alias: None
Product: kleopatra
Classification: Applications
Component: general (show other bugs)
Version: git master
Platform: Ubuntu Linux
: NOR grave with 20 votes (vote)
Target Milestone: ---
Assignee: Andre Heinecke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 21:25 UTC by aslam karachiwala
Modified: 2016-05-02 17:43 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot showing the error (31.39 KB, image/png)
2013-07-29 21:25 UTC, aslam karachiwala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aslam karachiwala 2013-07-29 21:25:10 UTC
Created attachment 81430 [details]
screenshot showing the error

+++ This bug was initially created as a clone of Bug #322561 +++

Reproducible: Always

Steps to Reproduce:
1.Download Kleopatra 2.1.1 from the software repositories.
2.Run Kleopatra.
Actual Results:  
Every time I start Kleopatra, it will show the results of its self-tests. One of the tests is called 'Gpg-agent connectivity'. The result of the test is always 'unexpected error'. The explanation message is 'Unexpected error when asking gpg-agent for its version. The error returned was: IPC parameter error.'

Expected Results:  
I expect to see no error messages when I start Kleopatra.

Ubuntu 13.04
KDE 4.10.5
Comment 1 aslam karachiwala 2013-07-29 21:26:25 UTC
$ env |grep GPG
GPG_AGENT_INFO=/run/user/myname/keyring-2gFlYE/gpg:0:1
Comment 2 Kent 2013-08-31 18:28:54 UTC
I am seeing the same error with Kleopatra 2.0.12 Debian sid (Siduction)
 (kernels 3.10.4 or 3.9.4)
Comment 3 Kent 2013-08-31 18:29:49 UTC
env | grep GPG gives nothing
Comment 4 Brian DeRocher 2014-06-05 20:03:35 UTC
I'm also seeing this on Debian sid  gnupg-agent 2.0.22-3
Comment 5 Andre Heinecke 2014-08-28 14:57:26 UTC
Hi,

this issue is caused by gnome-keyring hjacking the gpg-agent socket 

there are several bugs about this: e.g.
https://bugzilla.redhat.com/show_bug.cgi?id=1058372

But this issue has developed in an argument between gnome-keyring and gnupg maintainers so while this is basically an Upstream bug Kleopatra should print a Warning about that hjacking instead of an unknown error.

I'm taking this to add a warning similar to the one added in gnupg 2.0.23

The GNOME keyring manager hijacked the GnuPG agent.
GnuPG will not work proberly - please configure that
tool to not interfere with the GnuPG system!

( http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=ffa39be5ebfc1059a737905ee317c9b6f3d2a77e; hp=e184a11f94e2d41cd9266484542631bec23628b5 )
Comment 6 Andre Heinecke 2015-09-10 18:14:13 UTC
Did not come around to this. In the meantime gnome-keyring and gnupg have resolved the problem. Gnupg provides a pinentry-gnome that integrates with gnome-keyring and gnome-keyring no longer fakes to be a gpg-agent. So i'm marking this as resolved upstream.

Also with gnupg 2.1 this problem never existed as the hijacking did not work with that.
Comment 7 Vincent Fortier 2016-05-02 17:43:15 UTC
I believe the issue is still on-going:
https://bugs.launchpad.net/kubuntu-ppa/+bug/684902